From 8b1423718e97f03fa164c9176256b572de9a190f Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 14 Dec 2012 19:29:54 -0600
Subject: LinHES-config:  fix  a typo in Slave_backend client smb filesharing.
 Start folding at home service when foldingathome it installed

---
 abs/core/LinHES-config/PKGBUILD        |  8 ++++----
 abs/core/LinHES-config/mv_common.py    | 11 +++++++++++
 abs/core/LinHES-config/mv_fileshare.py |  2 +-
 abs/core/LinHES-config/mv_software.py  | 33 +++++++++++++++++++++++++--------
 4 files changed, 41 insertions(+), 13 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 649cc5a..c09536b 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=195
+pkgrel=196
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -152,19 +152,19 @@ md5sums=('26e20dba8d1bea96a07131ef945fd2f7'
          '3d1e4a119f38cff0498bf8a67e94e4b3'
          '71fd2d0d448fc2fcd15415a1beed7109'
          'af6b3c5ec0d974b3e19ff1ed50662ee5'
-         'cbc7cb10bde9a133e16fb63df6242f29'
+         '3d1e3c7315881a109fb089a540d2262c'
          'b845de3e05c1734cce4b9ac5e8f1baaf'
          'f5b2f4ed26a3099e66163040811ea2bd'
          '8b7dce4a3a0a281fa6656aa8781a648e'
          'f7f2dc11d1ba454cd25eeaa133104b62'
          '824e49d9b01fed295c704ab68908b464'
          'fe5e31b833cc6707209e9d656b6eb53c'
-         'ecb52b9b7a9ac0c8988093c1dfdda635'
+         'a1dab8e26e8cbc326b8c1a0794bc25d8'
          '087a0ef743bc8af915503f8773536ce4'
          'c4a17e76bed8d8c56c1d3f4408be315d'
          'b4900090d841d3e390cb840cf16afd85'
          'f2a19e3e864984ec95ac5ea090cbfa69'
-         'c9c9390ac12145169dfe9a76896db328'
+         'cf51cb22e23218ae7e9b55cac1ba3a7f'
          'e4b61402858058f7575b776d62d5ee89'
          'c2ef0f1140bd3fbeb44294fdf5415a32'
          '2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_common.py b/abs/core/LinHES-config/mv_common.py
index c2138dc..432c270 100755
--- a/abs/core/LinHES-config/mv_common.py
+++ b/abs/core/LinHES-config/mv_common.py
@@ -212,6 +212,7 @@ def pacinstall(pkg):
     elif pkg == "dvdcss":
         pacinstall("libdvdcss")
     elif pkg == "webmin":
+        pacinstall("webmin")
         add_service("webmin")
     elif pkg == "fuppes":
         pacinstall("fuppes-svn")
@@ -221,6 +222,11 @@ def pacinstall(pkg):
         pacinstall("dolphin-emu")
     elif pkg == "webonlinhes":
         pacinstall("web-on-linhes")
+    elif pkg == "mame":
+         pacinstall("sdlmame")
+    elif pkg == "foldingathome":
+         add_service("fah")
+
     elif pkg == "xymonclient":
         if os.path.exists('/home/xymon/client'):
             cmd='''pacman --noconfirm --dbonly -Sddf xymonclient'''
@@ -252,6 +258,11 @@ def pacremove(pkg):
         pacremove("dolphin-emu")
     elif pkg == "webonlinhes":
         pacremove("web-on-linhes")
+    elif pkg == "mame":
+        pacremove("sdlmame")
+    elif pkg == "foldingathome":
+        remove_service("fah")
+
 
     if  not pkg_blacklist_check(pkg):
         if not pkg_installed_check(pkg):
diff --git a/abs/core/LinHES-config/mv_fileshare.py b/abs/core/LinHES-config/mv_fileshare.py
index 96e9a28..746dbbf 100755
--- a/abs/core/LinHES-config/mv_fileshare.py
+++ b/abs/core/LinHES-config/mv_fileshare.py
@@ -42,7 +42,7 @@ def setup_nfs_client(systemconfig,data_config):
             nfslist.append(item)
     else:
         #if frontend_only or slave try to use MBE  nfs_map_auto
-        if systemconfig.get("SystemType") == "Frontend_only" or systemconfig["SystemType"] == "Slave_Backend":
+        if systemconfig.get("SystemType") == "Frontend_only" or systemconfig["SystemType"] == "Slave_backend":
             logging.info("     Central NFS not found, trying to use MBE as nfs server")
             nfsmap_serverfile = "nfsmap_auto"
             ip=systemconfig.get("dbhost")
diff --git a/abs/core/LinHES-config/mv_software.py b/abs/core/LinHES-config/mv_software.py
index c803a14..20b355e 100755
--- a/abs/core/LinHES-config/mv_software.py
+++ b/abs/core/LinHES-config/mv_software.py
@@ -17,21 +17,38 @@ def setup_software(systemconfig, data_config):
         postfix = "-release-fixes"
       else:
         postfix = "-svn"
-#This section is for MythVantage OS, not LINHES
+      #This section is for MythVantage OS, not LINHES
       default_disabled = ("mytharchive", "mythbrowser", "mythnews",
                           "mythgame",  "mythweather", "mythzoneminder","mythnetvision" )
 
       default_installed=("mythgallery", "mythmusic")
       other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mupen64")
     else:
-      default_disabled = ("mytharchive", "mythbrowser", "mythnews",
-                          "mythgame", "mythweather",
-                          "mythappletrailers", "mythstream",  "mythzoneminder","mythnetvision" )
+      default_disabled = ("mytharchive",
+                          "mythbrowser",
+                          "mythnews",
+                          "mythgame",
+                          "mythweather",
+                          "mythzoneminder",
+                          "mythnetvision" )
+
+      default_installed=("mythgallery",
+                         "mythmusic")
+      other_pkg=("romdb",
+                 "snes9x",
+                 "fceux",
+                 "mame",
+                 "mednafen",
+                 "mupen64",
+                 "dolphinemu",
+                 "xe",
+                 "mythappletrailers",
+                 "miro",
+                 "webonlinhes",
+                 "huludesktop",
+                 "dvdcss",
+                 "foldingathome")
 
-      default_installed=("mythgallery", "mythmovies", "mythmusic")
-      other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin",
-                 "fuppes", "foldingathome","mupen64","dolphinemu",
-                 "webonlinhes","huludesktop")
 
     for pkg in default_disabled:
         pkgname=pkg+postfix
-- 
cgit v0.12