From 9483401f2f1866075d574bdafc4910877367d8b1 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 4 Jan 2018 14:19:48 +0000
Subject: linhes-theme: status-ui.xml.patch: adjust length of titlesubtitle

---
 abs/core/linhes-theme/PKGBUILD            |   4 +-
 abs/core/linhes-theme/status-ui.xml.patch | 192 ++++++++++++++++++++++++++----
 2 files changed, 170 insertions(+), 26 deletions(-)

diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 7d12dd6..d45b85e 100755
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-theme
 pkgver=8.5.1
-pkgrel=2
+pkgrel=4
 pkgdesc="Default LinHES MythTV theme"
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -115,7 +115,7 @@ md5sums=('2dca856c2a4d1f959473512c94e43b60'
          '958d25f7b932c923cf9f8376063eeb57'
          'a0b6733e4a6734a3c24e8dc3b0c14e74'
          '384871202030f41148536e2e89bb1801'
-         '4d01487b534e45c631734501ec0da501'
+         '979cdd540b672e3383b33188ccb247b6'
          '8312aff444945f80a76100696c81cb2e'
          '81a2706cd36a16a1e0c54d87f3a0857b'
          '4125880d1739b196a8041ecc3d773ee2'
diff --git a/abs/core/linhes-theme/status-ui.xml.patch b/abs/core/linhes-theme/status-ui.xml.patch
index 9c26d77..400f14c 100644
--- a/abs/core/linhes-theme/status-ui.xml.patch
+++ b/abs/core/linhes-theme/status-ui.xml.patch
@@ -1,53 +1,197 @@
---- status-ui.xml.orig	2017-01-12 02:25:29.328323754 +0000
-+++ status-ui.xml	2017-01-12 02:19:35.527174739 +0000
-@@ -212,9 +212,9 @@
+--- status-ui.xml.orig	2018-01-03 21:51:16.028700351 +0000
++++ status-ui.xml	2018-01-03 21:21:37.423911248 +0000
+@@ -170,100 +170,140 @@
+     </window>
  
-         <textarea name="title">
-             <area>4,4,552,64</area>
+     <window name="standbymode">
+-        <area>-1,-1,568,320</area>
++        <area>0,0,1280,720</area>
+ 
+-        <animation trigger="AboutToShow">
+-            <section>
+-                <alpha start="0" end="255" easingcurve="OutQuart"/>
+-                <zoom start="0" end="100" easingcurve="OutQuart"/>
+-            </section>
+-        </animation>
+-
+-        <animation trigger="AboutToHide">
+-            <section>
+-                <alpha start="255" end="0" easingcurve="InQuart"/>
+-                <zoom start="100" end="0" easingcurve="InQuart"/>
+-            </section>
+-        </animation>
++        <textarea name="heading" from="base_heading">
++            <value>Standby</value>
++        </textarea>
+ 
+         <shape name="standbymode-backdrop" from="base_backdrop">
+-            <area>0,0,568,320</area>
++            <area>20,36,1240,649</area>
+         </shape>
+ 
+         <shape name="standbymode-backdrop-line" from="base_backdrop_line">
+-            <area>1,1,566,318</area>
++            <area>21,37,1238,647</area>
+         </shape>
+ 
+         <shape name="standbymode-top-line" from="base_highlight_line">
+-            <area>2,2,564,2</area>
++            <area>22,38,1236,2</area>
+         </shape>
+ 
+         <shape name="standbymode-bottom-line" from="base_highlight_line">
+-            <area>2,316,564,2</area>
++            <area>22,681,1236,2</area>
+         </shape>
+ 
+         <shape name="standbymode-left-line" from="base_highlight_vertical_line">
+-            <area>2,4,2,312</area>
++            <area>22,40,2,641</area>
+         </shape>
+ 
+         <shape name="standbymode-right-line" from="base_highlight_vertical_line">
+-            <area>564,4,2,312</area>
++            <area>1256,40,2,641</area>
+         </shape>
+ 
+-        <textarea name="title">
+-            <area>4,4,552,64</area>
 -            <font>basemedium</font>
-+            <font>basemediumyellow</font>
-             <align>allcenter</align>
+-            <align>allcenter</align>
 -            <value>MythTV is in standby mode!</value>
-+            <value>MythTV is in Standby Mode</value>
-         </textarea>
+-        </textarea>
++        <shape name="standbymode-status-seperator-line" from="base_line">
++            <area>43,100,1194,2</area>
++        </shape>
++
++        <shape name="standbymode-recording-status-seperator-line" from="base_line">
++            <area>43,318,1194,2</area>
++        </shape>
++
++        <shape name="standbymode-scheduled-recording-status-seperator-line" from="base_line">
++            <area>43,536,1194,2</area>
++        </shape>
  
          <statetype name="backendstatus">
-@@ -230,7 +230,7 @@
-                 <textarea name="status">
-                     <area>4,248,552,64</area>
-                     <font>basemediumgreen</font>
+-            <area>4,4,560,312</area>
++            <area>40,40,1200,60</area>
+             <state name="idle">
+-                <area>0,0,560,312</area>
+-                <shape name="icon">
+-                    <area>74,64,412,184</area>
+-                    <type>roundbox</type>
+-                    <fill color="#80d400" />
+-                    <cornerradius>5</cornerradius>
+-                </shape>
+-                <textarea name="status">
+-                    <area>4,248,552,64</area>
+-                    <font>basemediumgreen</font>
 -                    <value>Backend is idle!</value>
++                <area>0,0,1200,60</area>
++                <textarea name="status" from="basetextarea">
++                    <area>0,0,1200,60</area>
++                    <font>baseextralarge</font>
 +                    <value>Backend is Idle</value>
                      <align>allcenter</align>
-                     <multiline>true</multiline>
+-                    <multiline>true</multiline>
                  </textarea>
-@@ -241,16 +241,16 @@
-                 </shape>
+             </state>
+             <state name="recording" from="idle">
+-                <shape name="icon">
+-                    <fill color="#d93636" />
+-                </shape>
                  <textarea name="status">
-                     <font>basemediumred</font>
+-                    <font>basemediumred</font>
 -                    <value>Backend is recording!</value>
 +                    <value>Backend is Recording</value>
                  </textarea>
              </state>
              <state name="shuttingdown" from="idle">
-                 <shape name="icon">
+-                <shape name="icon">
 -                    <fill color="#d9d900" />
-+                    <fill color="#d97616" />
-                 </shape>
+-                </shape>
                  <textarea name="status">
 -                    <font>basemediumyellow</font>
 -                    <value>Shutting Down!</value>
-+                    <font>basemediumorange</font>
 +                    <value>MythTV is Shutting Down</value>
                  </textarea>
              </state>
              <state name="offline" from="idle">
-@@ -259,7 +259,7 @@
-                 </shape>
+-                <shape name="icon">
+-                    <fill color="#d93636" />
+-                </shape>
                  <textarea name="status">
-                     <font>basemediumred</font>
+-                    <font>basemediumred</font>
 -                    <value>Backend is offline!</value>
 +                    <value>Backend is Offline</value>
                  </textarea>
              </state>
          </statetype>
+ 
++        <textarea name="currentrecordingheading" from="basetextarea">
++            <area>40,110,1200,30</area>
++            <font>basemediumlargerdarkyellow</font>
++            <align>allcenter</align>
++            <value>Currently Recording</value>
++        </textarea>
++        <textarea name="nothingrecording" depends="!currentrecording">
++            <area>40,144,1200,170</area>
++            <font>basesmall</font>
++            <align>hcenter,top</align>
++            <value>Nothing is Recording</value>
++        </textarea>
++        <buttonlist name="currentrecording">
++            <area>40,144,1200,170</area>
++            <layout>vertical</layout>
++            <spacing>4</spacing>
++            <scrollstyle>free</scrollstyle>
++            <arrange>stack</arrange>
++            <wrapstyle>items</wrapstyle>
++            <buttonarea>0,0,100%,100%</buttonarea>
++            <statetype name="buttonitem">
++                <state name="active">
++                    <textarea name="shorttimedate" from="basetextarea">
++                        <area>0,1,400,24</area>
++                        <align>right,vcenter</align>
++                    </textarea>
++                    <textarea name="channame" from="shorttimedate">
++                        <area>405,1,180,24</area>
++                        <align>allcenter</align>
++                    </textarea>
++                    <textarea name="titlesubtitle" from="shorttimedate">
++                        <area>590,1,610,24</area>
++                        <align>left,vcenter</align>
++                    </textarea>
++                </state>
++                <state name="selectedactive" from="active"/>
++                <state name="selectedinactive" from="selectedactive" />
++            </statetype>
++        </buttonlist>
++
++        <textarea name="nextrecordingheading" from="currentrecordingheading">
++            <area>40,328,1200,30</area>
++            <value>Upcoming Recordings</value>
++        </textarea>
++        <textarea name="nothingscheduled" depends="!nextrecording" from="nothingrecording">
++            <area>40,362,1200,170</area>
++            <value>No Recordings Are Scheduled</value>
++        </textarea>
++        <buttonlist name="nextrecording" from="currentrecording">
++            <area>40,362,1200,170</area>
++        </buttonlist>
++
++        <textarea name="conflictsheading" from="nextrecordingheading">
++            <area>40,546,1200,30</area>
++            <value>Recording Conflicts</value>
++        </textarea>
++        <textarea name="nothingconflicted" depends="!conflicts" from="nothingrecording">
++            <area>40,580,1200,91</area>
++            <value>No Conflicts</value>
++        </textarea>
++        <buttonlist name="conflicts" from="currentrecording">
++            <area>40,580,1200,91</area>
++        </buttonlist>
++
+     </window>
+ 
+ </mythuitheme>
-- 
cgit v0.12