From dfd216f3480a1a047d5b5fd18819563f6c2eb789 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 6 Aug 2012 17:40:24 -0500
Subject: dialog: 1.1 201220706

---
 abs/core/dialog/PKGBUILD      | 22 +++++++++++-----------
 abs/core/dialog/timeout.patch | 11 -----------
 2 files changed, 11 insertions(+), 22 deletions(-)
 delete mode 100644 abs/core/dialog/timeout.patch

diff --git a/abs/core/dialog/PKGBUILD b/abs/core/dialog/PKGBUILD
index f6b93ec..d615e05 100644
--- a/abs/core/dialog/PKGBUILD
+++ b/abs/core/dialog/PKGBUILD
@@ -1,27 +1,27 @@
-# $Id: PKGBUILD 94294 2010-10-06 14:23:10Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 163201 2012-07-09 14:42:05Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
 # Contributor: Andreas Radke <andyrtr@archlinux.org>
 
 pkgname=dialog
-pkgver=1.1_20100428
-_pkgver=1.1-20100428
-pkgrel=2
+pkgver=1.1_20120706
+pkgrel=1
 pkgdesc="A tool to display dialog boxes from shell scripts"
 arch=('i686' 'x86_64')
 url="http://invisible-island.net/dialog/"
-license=('GPL')
+license=('LGPL2.1')
 depends=('ncurses')
-source=(ftp://invisible-island.net/${pkgname}/${pkgname}-$_pkgver.tgz)
-md5sums=('519c0a0cbac28ddb992111ec2c3f82aa')
+source=(ftp://invisible-island.net/${pkgname}/${pkgname}-${pkgver/_/-}.tgz)
+sha1sums=('fa033f0fb166da86e29d70e68159a92a9b9cdb84')
 
 build() {
-  cd ${srcdir}/$pkgname-$_pkgver
+  cd "${srcdir}/$pkgname-${pkgver/_/-}"
   ./configure --prefix=/usr --mandir=/usr/share/man \
               --with-ncursesw --enable-nls
   make
 }
 
 package() {
-  cd ${srcdir}/$pkgname-$_pkgver
-  make DESTDIR=${pkgdir} install install-lib
+  cd "${srcdir}/$pkgname-${pkgver/_/-}"
+  make DESTDIR="${pkgdir}" install install-lib
 }
diff --git a/abs/core/dialog/timeout.patch b/abs/core/dialog/timeout.patch
deleted file mode 100644
index 257f275..0000000
--- a/abs/core/dialog/timeout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dialog-1.1-20070514/ui_getc.c	2007-05-15 00:24:00.000000000 +0200
-+++ dialog-1.1-20070514_fixed/ui_getc.c	2007-05-29 20:20:27.000000000 +0200
-@@ -252,6 +252,8 @@
- 	ch = wgetch(win);
- 	/* if error from resizing, wait and try again */
- 	if (ch == ERR) {
-+	    current = time((time_t *) 0);
-+	    if (interval > 0 && current >= expired) dlg_exiterr("timeout");
- 	    napms(50);
- 	    continue;
- 	}
-- 
cgit v0.12