From a50079018221f48ff750412ee68649ad63252908 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 20 Apr 2016 13:46:17 +0000
Subject: xymon: hobbit-myth-orphan.sh: make db backups not result in yellow
 condition

---
 abs/core/xymon/PKGBUILD              |  4 ++--
 abs/core/xymon/hobbit-myth-orphan.sh | 19 +++++++++++++------
 2 files changed, 15 insertions(+), 8 deletions(-)

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index b106e66..787ce61 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.17
-pkgrel=22
+pkgrel=23
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license="GPL"
 arch=('i686' 'x86_64')
@@ -169,7 +169,7 @@ md5sums=('d8d119a777e7b7204d1292fb27314312'
          'c9a31ea9ae131fb351db913e922c25aa'
          'b2f98ac0df013332deedc1efae0a270d'
          'df77d1de72157d23a301a72288fbf7e5'
-         'aa7c2eec6cd894dc171e90a4eed69de1'
+         '2a509d81ee1655130ce40bf970719e0a'
          '166279c006c3ef7bf0c21537cf89fc83'
          '80d9cfac86c6d96836e6f406e35e7cf5'
          'd210c43fb9ee9ad6cd7648e0c2e0efea'
diff --git a/abs/core/xymon/hobbit-myth-orphan.sh b/abs/core/xymon/hobbit-myth-orphan.sh
index ff91fb5..5f7c7ba 100644
--- a/abs/core/xymon/hobbit-myth-orphan.sh
+++ b/abs/core/xymon/hobbit-myth-orphan.sh
@@ -1,5 +1,5 @@
 #!/bin/bash
-TMPFILE=/tmp/oprhan.result
+TMPFILE=/tmp/orphan.result
 MYTHCONFDIR=/usr/share/mythtv /usr/LH/bin/find_orphans.py --printonly > $TMPFILE
 
 COLUMN=orphan    # Name of the column
@@ -12,18 +12,25 @@ for i in "Orphaned video files" "Orphaned snapshots" "Database backups" "Other f
 do
    grep -q  "$i" $TMPFILE
    status=$?
-   if [ $status -eq 0 ]
+   if [[ $status -eq 0 ]] && [[ $i == "Database backups" ]]
+   then
+       MSG="$i"
+   elif [ $status -eq 0 ]
    then
        COLOR="yellow"
-       MSG="Problems with $i"
+       MSG="Problems with"
    fi
 done
 
-if [[ $MSG != "No Orphans Found." ]]
+if [[ $MSG == "Database backups" ]]
 then
 MSG="
-    ${MSG}
-    `cat $TMPFILE`
+`cat $TMPFILE`
+"
+elif [[ $MSG != "No Orphans Found." ]]
+then
+MSG="
+${MSG} `cat $TMPFILE`
 
 <b>From <a href="/shell/" target="_blank">System >> Terminal</a> run find_orphans.py to clean up these issues.</b>
 "
-- 
cgit v0.12