From fd3f5c9e4a68d535247925ef3c72b69442f416ad Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 18 Mar 2010 16:25:13 -0500
Subject: dnsmasq: initial import for extra does not have a runit script, but
 that will be added.

refs 567
---
 abs/extra-testing/dnsmasq/PKGBUILD   | 40 ++++++++++++++++++++++++++++++++++++
 abs/extra-testing/dnsmasq/rc.dnsmasq | 36 ++++++++++++++++++++++++++++++++
 2 files changed, 76 insertions(+)
 create mode 100644 abs/extra-testing/dnsmasq/PKGBUILD
 create mode 100755 abs/extra-testing/dnsmasq/rc.dnsmasq

diff --git a/abs/extra-testing/dnsmasq/PKGBUILD b/abs/extra-testing/dnsmasq/PKGBUILD
new file mode 100644
index 0000000..a413df4
--- /dev/null
+++ b/abs/extra-testing/dnsmasq/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=dnsmasq
+pkgver=2.52
+pkgrel=1
+pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
+url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'bash')
+makedepends=('libcap>=2.16')
+backup=('etc/dnsmasq.conf')
+install=
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz" 
+        'rc.dnsmasq')
+md5sums=('1bb32fffdb4f977ead607802b5d701d0' 'e956eee1ec24212a3254d2b168187495')
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+
+  # Build
+  make || return 1
+
+  # Install
+  install -d $pkgdir/etc/rc.d || return 1
+  make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+
+  install -D -m755 \
+    $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
+  install -D -m644 \
+    dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+
+  # Make the Required Directories for DHCP Server Default Directories
+  install -d $pkgdir/var/db || return 1
+  install -d $pkgdir/var/lib/misc || return 1
+}
+
+# vim: ts=2 sw=2 et ft=sh
diff --git a/abs/extra-testing/dnsmasq/rc.dnsmasq b/abs/extra-testing/dnsmasq/rc.dnsmasq
new file mode 100755
index 0000000..1676072
--- /dev/null
+++ b/abs/extra-testing/dnsmasq/rc.dnsmasq
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/dnsmasq`
+case "$1" in
+  start)
+    stat_busy "Starting DNS/DHCP daemon"
+    [ -z "$PID" ] && /usr/sbin/dnsmasq
+    if [ $? -gt 0 ] ; then
+      stat_fail
+    else
+      add_daemon dnsmasq                     # create the 'state' dir
+      stat_done 
+    fi
+    ;;
+  stop)
+    stat_busy "Stopping DNS/DHCP daemon"
+    [ "$PID" ] && kill $PID &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      rm_daemon dnsmasq                      # remove the 'state' dir
+      stat_done
+    fi
+    ;;
+  restart)
+    $0 stop
+    sleep 5
+    $0 start
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
-- 
cgit v0.12