From 892d65138d7773d2c5595ff03bae0947f6b00fec Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 28 Aug 2010 22:32:59 -0500
Subject: mre: Update MLBEvent from goofee

---
 abs/extra-testing/community/mre/PKGBUILD   |  4 ++--
 abs/extra-testing/community/mre/patch.diff | 13 +++++++------
 2 files changed, 9 insertions(+), 8 deletions(-)

diff --git a/abs/extra-testing/community/mre/PKGBUILD b/abs/extra-testing/community/mre/PKGBUILD
index c950d0c..0987904 100644
--- a/abs/extra-testing/community/mre/PKGBUILD
+++ b/abs/extra-testing/community/mre/PKGBUILD
@@ -1,7 +1,7 @@
 arch=('i686')
 pkgname=mre
 pkgver=1.1.2
-pkgrel=4
+pkgrel=5
 _kernver=2.6.28-LinHES
 pkgdesc="Myth Recording Extender"
 url="http://sourceforge.net/projects/mythtv-tools/"
@@ -32,6 +32,6 @@ build() {
 }
 
 md5sums=('8ab312e7597ae9413a57bd5e9a068096'
-         '0d0b676367fc4fe459c4f8985872eda6'
+         'ed6cb9012c88d589e26132796132bf25'
          '10e01d572b45ad718e49ff9ef5c230c5'
          '6d71ab57afd974c5130c994b94e8746f')
diff --git a/abs/extra-testing/community/mre/patch.diff b/abs/extra-testing/community/mre/patch.diff
index 32a7919..38a501a 100644
--- a/abs/extra-testing/community/mre/patch.diff
+++ b/abs/extra-testing/community/mre/patch.diff
@@ -45,7 +45,7 @@
  
     /**
      * Class constructor.
-@@ -43,41 +43,24 @@
+@@ -43,41 +43,25 @@
           trigger_error("Unable to generate valid search terms! [$gameInfo]", E_USER_WARNING);
        else
        {
@@ -89,7 +89,8 @@
 +	    foreach($data_array as $line)
 +	    {
 +	       $line=str_replace("%20", " ", $line);
-+               if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
++	       $line=str_replace("Chicago Sox", "Chicago White Sox", $line); #Program guide gives Chicago White Sox, website gives Chicago Sox 
++              if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
 +   	       {
 +     		  if((strpos($line,'FINAL'))or(strpos($line,'Postponed'))) 
 + 		     $this->setEventOver(TRUE);
@@ -152,7 +153,7 @@
 +	    foreach($data_array as $line)
 +	    {
 +	       $line=str_replace("%20", " ", $line);
-+               if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
++              if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
 +	       {
 +		  if(strpos($line,'FINAL'))
 +		     $this->setEventOver(TRUE);
@@ -215,7 +216,7 @@
 +            foreach($data_array as $line)
 +	    {
 +	       $line=str_replace("%20", " ", $line);
-+               if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
++              if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
 +  	       {
 +       		  if(strpos($line,'FINAL')) 
 + 		     $this->setEventOver(TRUE);
@@ -276,7 +277,7 @@
 +            foreach($data_array as $line)
 +	    {
 +	       $line=str_replace("%20", " ", $line);
-+               if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
++              if((strpos($line,$criteria[0]))&&(strpos($line,$criteria[1])))
 +	       {
 +		  if(strpos($line,'FINAL')) 
 +		     $this->setEventOver(TRUE);
@@ -289,4 +290,4 @@
 +         }
        }
        if(!$this->isValid())
-          trigger_error("Unable to find NHL info for '$gameInfo'!  The NHL parser may need to be updated.", E_USER_WARNING);
+          trigger_error("Unable to find NHL info for '$gameInfo'!  The NHL parser may need to be updated.", E_USER_WARNING);
\ No newline at end of file
-- 
cgit v0.12