From 0a79f54c23c924f2736452e45d1490132dc0649e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 12 Oct 2018 19:11:12 +0000
Subject: python-ifaddr: initial inclusion

---
 abs/core/python_modules/python-ifaddr/PKGBUILD | 33 ++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 abs/core/python_modules/python-ifaddr/PKGBUILD

diff --git a/abs/core/python_modules/python-ifaddr/PKGBUILD b/abs/core/python_modules/python-ifaddr/PKGBUILD
new file mode 100644
index 0000000..4e06e8e
--- /dev/null
+++ b/abs/core/python_modules/python-ifaddr/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+
+_name=ifaddr
+pkgname=python-ifaddr
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Enumerates all IP addresses on all network adapters of the system"
+arch=('any')
+url="https://github.com/pydron/ifaddr"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-nose')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.zip)
+sha512sums=('5b080d8f328f7a974644e15929850ba93b9232cee545740d89e4d63e982e351287504befef365834bfb3f4c5f25dc99f4a4d76753405658ae197590e2ce94929')
+
+build() {
+  cd "${_name}-${pkgver}"
+  python3 setup.py build
+}
+
+package() {
+  cd "${_name}-${pkgver}"
+
+  python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+check() {
+  cd "${_name}-${pkgver}"
+  nosetests ${_name}/test_ifaddr.py
+}
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12