From 5b60b2a21e504020b1724a2c01c5f398b04b8f79 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sun, 2 Sep 2012 20:48:25 -0700
Subject: premake:initial inclusion. closes #801

---
 abs/extra/premake/PKGBUILD | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 abs/extra/premake/PKGBUILD

diff --git a/abs/extra/premake/PKGBUILD b/abs/extra/premake/PKGBUILD
new file mode 100644
index 0000000..f4343e1
--- /dev/null
+++ b/abs/extra/premake/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Anders Bergh <anders1@gmail.com>
+# Contributor: Mildred <silkensedai@online.fr>
+# Maintainer: Daniel J Griffiths <griffithsdj@archlinux.us>
+
+pkgname=premake
+pkgver=3.7
+pkgrel=1
+pkgdesc="A build configuration tool. Describe your build using Lua and generate \
+the project files for your specific toolset."
+arch=('i686' 'x86_64')
+url="http://premake.sourceforge.net"
+license=('GPL')
+makedepends=()
+source=("http://downloads.sourceforge.net/sourceforge/premake/premake-src-${pkgver}.zip")
+md5sums=('8d30dc5bbc52aad81abb1509c1dd7d8f')
+
+build() {
+	cd ${srcdir}/Premake-${pkgver}
+	make || return 1
+}
+
+package() {
+	cd ${srcdir}/Premake-${pkgver}
+	install -Dm755 bin/premake ${pkgdir}/usr/bin/premake
+}
-- 
cgit v0.12