From a6e78d13dc69266f844eb8a6d7238d5c6470a228 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 12:12:27 -0500
Subject: linux-atm 2.5.2

---
 abs/core/linux-atm/PKGBUILD        | 29 ++++++++++++++----------
 abs/core/linux-atm/man-pages.patch | 45 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+), 11 deletions(-)
 create mode 100644 abs/core/linux-atm/man-pages.patch

diff --git a/abs/core/linux-atm/PKGBUILD b/abs/core/linux-atm/PKGBUILD
index f2c5a24..5b6e62d 100644
--- a/abs/core/linux-atm/PKGBUILD
+++ b/abs/core/linux-atm/PKGBUILD
@@ -1,26 +1,33 @@
-# $Id: PKGBUILD 79085 2010-04-30 07:29:32Z tpowa $
+# $Id: PKGBUILD 158611 2012-05-05 03:12:24Z dreisner $
 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
 # Contributor: Surain Mallawa Arachchi <mas@crc32.net>
 
 pkgname=linux-atm
-pkgver=2.5.1
-pkgrel=1
+pkgver=2.5.2
+pkgrel=2
 pkgdesc="Drivers and tools to support ATM networking under Linux."
 arch=('i686' 'x86_64')
 depends=('glibc')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz)
 url="http://linux-atm.sourceforge.net/"
 license=(GPL)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz
+        man-pages.patch)
 options=(!libtool !makeflags)
-md5sums=('9560b0e1f410a05b849dfdab465dd758')
 
 build() {
-  cd $srcdir/$pkgname-$pkgver
-  ./configure --prefix=/usr --sysconfdir=/etc || return 1
-  make || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  patch -Np1 -i ../man-pages.patch
+
+  # install firmware in /usr/lib
+  sed -i "s#/lib/firmware#/usr/lib/firmware#" src/extra/Makefile.in
+
+  ./configure --prefix=/usr --sysconfdir=/etc
+  make
 }
+
 package() {
-  cd $srcdir/$pkgname-$pkgver
-  make DESTDIR=$pkgdir install
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
 }
-
+md5sums=('d49499368c3cf15f73a05d9bce8824a8'
+         '181390736336cdb615ae32f1ae5acfa6')
diff --git a/abs/core/linux-atm/man-pages.patch b/abs/core/linux-atm/man-pages.patch
new file mode 100644
index 0000000..c504cfe
--- /dev/null
+++ b/abs/core/linux-atm/man-pages.patch
@@ -0,0 +1,45 @@
+diff -up linux-atm-2.5.1/src/led/zeppelin.8.fixman linux-atm-2.5.1/src/led/zeppelin.8
+--- linux-atm-2.5.1/src/led/zeppelin.8.fixman	2003-05-02 19:35:04.000000000 +0200
++++ linux-atm-2.5.1/src/led/zeppelin.8	2010-10-13 12:58:18.000000000 +0200
+@@ -99,7 +99,7 @@ Ring and ATM parts of the ELAN, so using
+ recommended. Token Ring support has received less testing than its
+ Ethernet counterpart.
+ .SH FILES
+-.IP \fI/var/run/lec[interface number].pid\fP
++\fI/var/run/lec[interface number].pid\fP
+ The file containing the process id of zeppelin.
+ .SH BUGS
+ John Bonham died 1980 and Led Zeppelin broke.
+diff -up linux-atm-2.5.1/src/mpoad/mpcd.8.fixman linux-atm-2.5.1/src/mpoad/mpcd.8
+--- linux-atm-2.5.1/src/mpoad/mpcd.8.fixman	2001-10-10 00:33:07.000000000 +0200
++++ linux-atm-2.5.1/src/mpoad/mpcd.8	2010-10-13 12:59:14.000000000 +0200
+@@ -28,7 +28,7 @@ mpcd \- ATM MPOA (Multi\-Protocol Over A
+ .B ]]
+ .SH DESCRIPTION
+ MPOA client
+-.SM(MPC) is responsible for creating and receiving
++.SM (MPC) is responsible for creating and receiving
+ internetwork layer shortcuts. Using these shortcuts MPCs forward
+ unicast internetwork layer packets effectively over ATM without need
+ for routing protocols.
+@@ -43,7 +43,7 @@ accepts shortcuts and packets arriving o
+ shortcuts is done with the help of
+ .SM MPOA
+ server
+-.SM(MPS).
++.SM (MPS).
+ .PP
+ Just as the Linux
+ .SM LAN
+diff -up linux-atm-2.5.1/src/sigd/atmsigd.conf.4.fixman linux-atm-2.5.1/src/sigd/atmsigd.conf.4
+--- linux-atm-2.5.1/src/sigd/atmsigd.conf.4.fixman	2001-10-10 00:33:07.000000000 +0200
++++ linux-atm-2.5.1/src/sigd/atmsigd.conf.4	2010-10-13 12:58:49.000000000 +0200
+@@ -125,7 +125,7 @@ a comment. The `#' character cannot be e
+ .P
+ If an option is specified in \fBatmsigd.conf\fP and on the command
+ line, the command line has priority.
+-.COMPATIBILITY
++.SH COMPATIBILITY
+ Certain options used by past versions of \fBatmsigd\fP but no longer documented
+ on the man page are still recognized and supported, but they also yield a
+ warning message. Future versions of \fBatmsigd\fP will not recognize those
-- 
cgit v0.12