From e7404ba5f42677eefe496069cbeab89fbec1d5e2 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 12 Oct 2018 19:11:50 +0000
Subject: python-zeroconf: initial inclusion

---
 abs/core/python_modules/python-zeroconf/PKGBUILD | 33 ++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 abs/core/python_modules/python-zeroconf/PKGBUILD

diff --git a/abs/core/python_modules/python-zeroconf/PKGBUILD b/abs/core/python_modules/python-zeroconf/PKGBUILD
new file mode 100644
index 0000000..1b2e286
--- /dev/null
+++ b/abs/core/python_modules/python-zeroconf/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=python-zeroconf
+pkgver=0.21.3
+pkgrel=1
+pkgdesc="A pure python implementation of multicast DNS service discovery"
+arch=('any')
+url="https://github.com/jstasiak/python-zeroconf"
+license=('LGPL')
+depends=('python' 'python-netifaces' 'python-six' 'python-ifaddr')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("https://github.com/jstasiak/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('8c3aaed98f950b56c6e1aa440b56e0d48af49565cb4d7830a82cb3b01088aad8')
+
+build() {
+  cd "${pkgbase}-${pkgver}"
+  python3 setup.py build
+}
+
+package() {
+  cd "${pkgbase}-${pkgver}"
+
+  python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+check() {
+  cd "${pkgbase}-${pkgver}"
+  py.test .
+}
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12