From 85c7ce05c56566f4e731b80e86a153e00e11cd28 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 24 May 2018 19:58:10 +0000
Subject: mythweb: fix PHP warnings and fix videos layout

---
 .../stable-29/mythweb/FixPHPWarnings_13260.patch   | 21 +++++
 abs/core/mythtv/stable-29/mythweb/PKGBUILD         | 12 +--
 abs/core/mythtv/stable-29/mythweb/video.css.patch  | 98 ++++++++++++++++++++++
 3 files changed, 126 insertions(+), 5 deletions(-)
 create mode 100644 abs/core/mythtv/stable-29/mythweb/FixPHPWarnings_13260.patch
 create mode 100644 abs/core/mythtv/stable-29/mythweb/video.css.patch

diff --git a/abs/core/mythtv/stable-29/mythweb/FixPHPWarnings_13260.patch b/abs/core/mythtv/stable-29/mythweb/FixPHPWarnings_13260.patch
new file mode 100644
index 0000000..9fb3c04
--- /dev/null
+++ b/abs/core/mythtv/stable-29/mythweb/FixPHPWarnings_13260.patch
@@ -0,0 +1,21 @@
+--- ./modules/tv/recorded.php
++++ ./modules/tv/recorded.php
+@@ -179,14 +179,14 @@
+     if (function_exists('gmp_mul')) {
+     // GMP functions should work better with 64 bit numbers.
+         $size = gmp_mul('1024', $size);
+-        define(disk_size, gmp_strval($size));
++        define('disk_size', gmp_strval($size));
+         $size = gmp_mul('1024', $used);
+-        define(disk_used, gmp_strval($size));
++        define('disk_used', gmp_strval($size));
+     }
+     else {
+     // This is inaccurate, but it's the best we can get without GMP.
+-        define(disk_size, ($size * 1024));
+-        define(disk_used, ($used * 1024));
++        define('disk_size', ($size * 1024));
++        define('disk_used', ($used * 1024));
+     }
+ 
+ // Load the class for this page
diff --git a/abs/core/mythtv/stable-29/mythweb/PKGBUILD b/abs/core/mythtv/stable-29/mythweb/PKGBUILD
index 25dd0d9..a32f039 100644
--- a/abs/core/mythtv/stable-29/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythweb/PKGBUILD
@@ -1,16 +1,17 @@
 pkgname=mythweb
 pkgver=29
-pkgrel=3
+pkgrel=4
 commit_hash=`cat ../git_src/git_hash_web`
 pkgdesc="Web interface for MythTV's backend, $commit_hash"
-arch=('i686' 'x86_64')
+arch=('x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
 depends=('lighttpd' "mythtv>=${pkgver}" 'php' 'supplemental-web')
 groups=('mythtv-extras')
 install=mythweb.install
 
-patches=()
+patches=('FixPHPWarnings_13260.patch'
+         'video.css.patch')
 source=(`echo ${patches[@]:0}` 
         'mythweb.include'
         'mythweb_gen_light.conf')
@@ -36,7 +37,6 @@ build() {
 	done
     msg "--------------------------done applying patches-------------------------"
 
-	[ "$CARCH" = "i686"   ] && ARCH="i686"
 	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
 }
 
@@ -54,5 +54,7 @@ package() {
     #gen_light_conf
     install -D -m0744 ${srcdir}/mythweb_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythweb.conf
 }
-md5sums=('7645a6399434cbba35639713ac5d88e0'
+md5sums=('df80362c995ddfcf6a2119b83d26b2b4'
+         '668a36e404c8254f56e7a7304e655332'
+         '7645a6399434cbba35639713ac5d88e0'
          'df190116b3aba35720fb6631885f973f')
diff --git a/abs/core/mythtv/stable-29/mythweb/video.css.patch b/abs/core/mythtv/stable-29/mythweb/video.css.patch
new file mode 100644
index 0000000..f49a3fd
--- /dev/null
+++ b/abs/core/mythtv/stable-29/mythweb/video.css.patch
@@ -0,0 +1,98 @@
+--- ./skins/default/video.css.orig	2018-05-22 21:45:30.395508513 +0000
++++ ./skins/default/video.css	2018-05-22 21:41:27.326893228 +0000
+@@ -0,0 +1,95 @@
++    .video {
++        position:           relative;
++        padding:            1em;
++        float:              left;
++        background-color:   #003366;
++        margin-top:         1em;
++        margin-left:        1em;
++        width:              202px;
++        height:             168px;
++        border:             1px solid black;
++    }
++
++    .video .title {
++        font-weight:        bold;
++        margin-bottom:      .5em;
++        height:             2.5em;
++        overflow:           hidden;
++    }
++
++    .video img {
++        float:              left;
++        padding-right:      1em;
++    }
++
++    .video .command {
++        position:           absolute;
++        bottom:             1em;
++        right:              1em;
++    }
++
++    #path {
++        position:           relative;
++        padding:            1em;
++        float:              left;
++        background-color:   #102923;
++        margin-top:         1em;
++        margin-left:        1em;
++        border:             1px solid black;
++        min-width:          202px;
++        min-height:         168px;
++    }
++
++    #path .active {
++        color:              yellow;
++    }
++
++    #window {
++        position:           fixed;
++        left:               35%;
++        right:              35%;
++        width:              30%;
++        top:                35%;
++        background-color:   green;
++        padding-top:        1em;
++        z-index:            10;
++        border:             2px solid gray;
++    }
++
++    #window_content a {
++        padding-right:      1em;
++        padding-left:       1em;
++    }
++
++    #window iframe {
++        width:              100%;
++        border:             0px;
++        height:             250px;
++    }
++
++    #window_title {
++        position:           absolute;
++        top:                1px;
++        left:               1em;
++        font-weight:        bold;
++    }
++
++    .popup {
++        width:              30%;
++        font-size:          9pt;
++    }
++
++    .popup dt {
++        clear:              left;
++        float:              left;
++        padding-top:        3px;
++        white-space:        nowrap;
++        width:              6em;
++        font-weight:        bold;
++        text-align:         right;
++    }
++
++    .popup  dd {
++        margin-left:        6.5em;
++        padding-top:        3px;
++    }
-- 
cgit v0.12