From ebceeeaf0b0b2052988a29d9734dcc5e79c4eb8c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 7 Aug 2015 17:17:56 +0000
Subject: cmake: update to 3.3.0

---
 abs/core/cmake/PKGBUILD           | 50 +++++++++++++++++++++++----------------
 abs/core/cmake/__changelog        |  2 ++
 abs/core/cmake/findfreetype.patch | 26 --------------------
 abs/core/cmake/rebuild.list       |  5 ++++
 4 files changed, 37 insertions(+), 46 deletions(-)
 create mode 100644 abs/core/cmake/__changelog
 delete mode 100644 abs/core/cmake/findfreetype.patch
 create mode 100644 abs/core/cmake/rebuild.list

diff --git a/abs/core/cmake/PKGBUILD b/abs/core/cmake/PKGBUILD
index eb20157..7c29e73 100644
--- a/abs/core/cmake/PKGBUILD
+++ b/abs/core/cmake/PKGBUILD
@@ -1,31 +1,34 @@
-# $Id: PKGBUILD 200685 2013-12-02 11:59:05Z svenstaro $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
 # Contributor: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=cmake
-pkgver=2.8.12.1
-pkgrel=3
-pkgdesc="A cross-platform open-source make system"
+pkgver=3.3.0
+pkgrel=1
+pkgdesc='A cross-platform open-source make system'
 arch=('i686' 'x86_64')
 url="http://www.cmake.org/"
 license=('custom')
-depends=('curl' 'libarchive' 'shared-mime-info')
-makedepends=('qt' 'emacs')
-optdepends=('qt: cmake-gui')
+depends=('curl' 'libarchive' 'shared-mime-info' 'jsoncpp')
+makedepends=('python2-sphinx' 'emacs')
+optdepends=('qt5-base: cmake-gui'
+            'libxkbcommon-x11: cmake-gui')
 install="${pkgname}.install"
-source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz"
-        "findfreetype.patch")
-md5sums=('9d38cd4e2c94c3cea97d0e2924814acc'
-         '90321de1d9d46cd8d6609d0509dbd7b0')
+source=("http://www.cmake.org/files/v${pkgver%.*}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('b1d4823e3f74c961486d9f253da9825d')
 
-build() {
+prepare() {
   cd ${pkgname}-${pkgver}
+}
 
-  patch -Np1 < ${srcdir}/findfreetype.patch
+build() {
+  cd ${pkgname}-${pkgver}
 
   ./bootstrap --prefix=/usr \
     --mandir=/share/man \
     --docdir=/share/doc/cmake \
+    --sphinx-man \
     --system-libs \
     --qt-gui \
     --parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
@@ -37,12 +40,19 @@ package() {
   make DESTDIR="${pkgdir}" install
 
   vimpath="${pkgdir}/usr/share/vim/vimfiles"
-  install -Dm644 Docs/cmake-indent.vim "${vimpath}"/indent/cmake-indent.vim
-  install -Dm644 Docs/cmake-syntax.vim "${vimpath}"/syntax/cmake-syntax.vim
-
-  install -Dm644 Docs/cmake-mode.el \
-    "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
-  emacs -batch -f batch-byte-compile "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
+  install -d "${vimpath}"/{help,indent,syntax}
+  ln -s /usr/share/cmake-${pkgver%.*}/editors/vim/cmake-help.vim \
+    "${vimpath}"/help/
+  ln -s /usr/share/cmake-${pkgver%.*}/editors/vim/cmake-indent.vim \
+    "${vimpath}"/indent/
+  ln -s /usr/share/cmake-${pkgver%.*}/editors/vim/cmake-syntax.vim \
+    "${vimpath}"/syntax/
+
+  install -d "${pkgdir}"/usr/share/emacs/site-lisp/
+  emacs -batch -f batch-byte-compile \
+    "${pkgdir}"/usr/share/cmake-${pkgver%.*}/editors/emacs/cmake-mode.el
+  ln -s /usr/share/cmake-${pkgver%.*}/editors/emacs/cmake-mode.el \
+    "${pkgdir}"/usr/share/emacs/site-lisp/
 
   install -Dm644 Copyright.txt \
     "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
diff --git a/abs/core/cmake/__changelog b/abs/core/cmake/__changelog
new file mode 100644
index 0000000..40ac04b
--- /dev/null
+++ b/abs/core/cmake/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: change dep python-sphinx to python2-sphinx
+PKGBUILD: remvoe makedep qt5-base
diff --git a/abs/core/cmake/findfreetype.patch b/abs/core/cmake/findfreetype.patch
deleted file mode 100644
index 454b591..0000000
--- a/abs/core/cmake/findfreetype.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Modules/FindFreetype.cmake b/Modules/FindFreetype.cmake
-index 179dc00..0f5a2b4 100644
---- a/Modules/FindFreetype.cmake
-+++ b/Modules/FindFreetype.cmake
-@@ -62,10 +62,10 @@ find_path(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
-     ENV GTKMM_BASEPATH
-     [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
-     [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
--  PATH_SUFFIXES include/freetype2 include
-+  PATH_SUFFIXES include/freetype2 include/freetype include
- )
- 
--find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-+find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
-   HINTS
-     ENV FREETYPE_DIR
-   PATHS
-@@ -76,7 +76,7 @@ find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-     ENV GTKMM_BASEPATH
-     [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
-     [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
--  PATH_SUFFIXES include/freetype2 include
-+  PATH_SUFFIXES include/freetype2 include/freetype include include/freetype2/freetype
- )
- 
- find_library(FREETYPE_LIBRARY
diff --git a/abs/core/cmake/rebuild.list b/abs/core/cmake/rebuild.list
new file mode 100644
index 0000000..de3bb0f
--- /dev/null
+++ b/abs/core/cmake/rebuild.list
@@ -0,0 +1,5 @@
+quazip
+glm
+gluon
+sfml
+wt
-- 
cgit v0.12