From 889d40a38a413dda0263e84eba8b4c8a328376af Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 5 Feb 2023 16:46:39 -0500
Subject: linhes-system: add_storage.py: change parser

---
 linhes/linhes-system/PKGBUILD       | 4 ++--
 linhes/linhes-system/add_storage.py | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index cd5e8a9..d4863b7 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-system
 pkgver=9.0.0
-pkgrel=35
+pkgrel=36
 arch=('x86_64')
 #install=$pkgname.install
 pkgdesc="Everything that makes LinHES a system"
@@ -23,7 +23,7 @@ source=($binfiles
     '10-monitor.conf' 'x11vnc.override.conf' 'lh_lighttpd.conf' 'lh_php.ini'
     'system-sudo.rules' 'linhes-profile.sh' 'lh_sqlserver.cnf'
     'lh_system_start.sh.desktop' 'rc6_mce.toml' 'rsyslog.mythtv.conf')
-sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
+sha256sums=('7fd630d58a4268d98648eb7bdcf69a2d53ed326e3b58001d30a42305b04721ed'
             '1ec3c266cafb0c1b231e88df88b97fec1a1b7465b5d95a0c1e64c8cb727b7c47'
             '97fe9e851c782fa9f85c5b69b110ccff2817dd4fa2a6d9ff6ee225dc558677e4'
             'ff261f41efec8a9963f9f59100cbe75f015028a2ed3a863ce0cb473f2ebb7b76'
diff --git a/linhes/linhes-system/add_storage.py b/linhes/linhes-system/add_storage.py
index e880884..2d300a3 100755
--- a/linhes/linhes-system/add_storage.py
+++ b/linhes/linhes-system/add_storage.py
@@ -725,7 +725,7 @@ def reconstruct_storagegroups():
     host=gethostname()
 
     for conf_file in glob.glob('%s/*.conf' %storage_dir):
-        parser = SafeConfigParser()
+        parser = ConfigParser()
         parser.read(conf_file)
         try:
             mount_point = parser.get('storage', 'mountpoint')
@@ -816,7 +816,7 @@ def reconstruct_storagegroups():
 class reconstruct_path:
     def  __init__(self,conf_file):
         self.conf_file = conf_file
-        parser = SafeConfigParser()
+        parser = ConfigParser()
         parser.read(self.conf_file)
         self.config = configparser.RawConfigParser()
 
-- 
cgit v0.12