From 8fefa501175bdcc7d250b27bf8475b55f79e03cd Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 1 Nov 2012 15:54:38 -0500
Subject: lighttpd:  adjusted conf file to account for cgi-bin  and added an
 initial alias, so that all other include files can use alias +=

---
 abs/core/lighttpd/PKGBUILD      |   2 +-
 abs/core/lighttpd/lighttpd.conf | 177 +++++++++++++++++++++-------------------
 2 files changed, 92 insertions(+), 87 deletions(-)

diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index 809f82f..1b1316a 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -78,5 +78,5 @@ package() {
 md5sums=('586eb535d31ac299652495b058dd87c4'
          'bd690eee0d9e51857448770a151023b0'
          'e17a29ebcdac82a853389c3df468c980'
-         '1857cb0c145db64e2a5f54b79a144adb'
+         '836bc37bb1c59478052026ade7a959bb'
          'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index 7244961..ccc0403 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -12,28 +12,28 @@
 # - saves some time
 # - saves memory
 server.modules              = (
-                               "mod_rewrite",
+                            "mod_rewrite",
 #                               "mod_redirect",
-                               "mod_alias",
-                                "mod_access",
+                            "mod_alias",
+                            "mod_access",
 #                               "mod_cml",
 #                               "mod_trigger_b4_dl",
-                               "mod_auth",
-                               "mod_status",
-                               "mod_setenv",
-                               "mod_fastcgi",
-                               "mod_proxy",
+                            "mod_auth",
+                            "mod_status",
+                            "mod_setenv",
+                            "mod_fastcgi",
+                            "mod_proxy",
 #                               "mod_simple_vhost",
 #                               "mod_evhost",
 #                               "mod_userdir",
-                               "mod_cgi",
+                            "mod_cgi",
 #                               "mod_compress",
 #                               "mod_ssi",
 #                               "mod_usertrack",
 #                               "mod_expire",
 #                               "mod_secdownload",
 #                               "mod_rrdtool",
-                                "mod_accesslog" )
+                            "mod_accesslog" )
 
 ## a static document-root, for virtual-hosting take look at the
 ## server.virtual-* options
@@ -58,62 +58,62 @@ index-file.names            = ( "index.php", "index.html",
 
 # mimetype mapping
 mimetype.assign             = (
-  ".pdf"          =>      "application/pdf",
-  ".sig"          =>      "application/pgp-signature",
-  ".spl"          =>      "application/futuresplash",
-  ".class"        =>      "application/octet-stream",
-  ".ps"           =>      "application/postscript",
-  ".torrent"      =>      "application/x-bittorrent",
-  ".dvi"          =>      "application/x-dvi",
-  ".gz"           =>      "application/x-gzip",
-  ".pac"          =>      "application/x-ns-proxy-autoconfig",
-  ".swf"          =>      "application/x-shockwave-flash",
-  ".tar.gz"       =>      "application/x-tgz",
-  ".tgz"          =>      "application/x-tgz",
-  ".tar"          =>      "application/x-tar",
-  ".zip"          =>      "application/zip",
-  ".mp3"          =>      "audio/mpeg",
-  ".m3u"          =>      "audio/x-mpegurl",
-  ".wma"          =>      "audio/x-ms-wma",
-  ".wax"          =>      "audio/x-ms-wax",
-  ".ogg"          =>      "application/ogg",
-  ".wav"          =>      "audio/x-wav",
-  ".gif"          =>      "image/gif",
-  ".jar"          =>      "application/x-java-archive",
-  ".jpg"          =>      "image/jpeg",
-  ".jpeg"         =>      "image/jpeg",
-  ".png"          =>      "image/png",
-  ".xbm"          =>      "image/x-xbitmap",
-  ".xpm"          =>      "image/x-xpixmap",
-  ".xwd"          =>      "image/x-xwindowdump",
-  ".css"          =>      "text/css",
-  ".html"         =>      "text/html",
-  ".htm"          =>      "text/html",
-  ".js"           =>      "text/javascript",
-  ".asc"          =>      "text/plain",
-  ".c"            =>      "text/plain",
-  ".cpp"          =>      "text/plain",
-  ".log"          =>      "text/plain",
-  ".conf"         =>      "text/plain",
-  ".text"         =>      "text/plain",
-  ".txt"          =>      "text/plain",
-  ".dtd"          =>      "text/xml",
-  ".xml"          =>      "text/xml",
-  ".mpeg"         =>      "video/mpeg",
-  ".mpg"          =>      "video/mpeg",
-  ".mp4"          =>      "video/quicktime",
-  ".mov"          =>      "video/quicktime",
-  ".qt"           =>      "video/quicktime",
-  ".avi"          =>      "video/x-msvideo",
-  ".asf"          =>      "video/x-ms-asf",
-  ".asx"          =>      "video/x-ms-asf",
-  ".wmv"          =>      "video/x-ms-wmv",
-  ".bz2"          =>      "application/x-bzip",
-  ".tbz"          =>      "application/x-bzip-compressed-tar",
-  ".tar.bz2"      =>      "application/x-bzip-compressed-tar",
-  # default mime type
-  ""              =>      "application/octet-stream",
- )
+".pdf"          =>      "application/pdf",
+".sig"          =>      "application/pgp-signature",
+".spl"          =>      "application/futuresplash",
+".class"        =>      "application/octet-stream",
+".ps"           =>      "application/postscript",
+".torrent"      =>      "application/x-bittorrent",
+".dvi"          =>      "application/x-dvi",
+".gz"           =>      "application/x-gzip",
+".pac"          =>      "application/x-ns-proxy-autoconfig",
+".swf"          =>      "application/x-shockwave-flash",
+".tar.gz"       =>      "application/x-tgz",
+".tgz"          =>      "application/x-tgz",
+".tar"          =>      "application/x-tar",
+".zip"          =>      "application/zip",
+".mp3"          =>      "audio/mpeg",
+".m3u"          =>      "audio/x-mpegurl",
+".wma"          =>      "audio/x-ms-wma",
+".wax"          =>      "audio/x-ms-wax",
+".ogg"          =>      "application/ogg",
+".wav"          =>      "audio/x-wav",
+".gif"          =>      "image/gif",
+".jar"          =>      "application/x-java-archive",
+".jpg"          =>      "image/jpeg",
+".jpeg"         =>      "image/jpeg",
+".png"          =>      "image/png",
+".xbm"          =>      "image/x-xbitmap",
+".xpm"          =>      "image/x-xpixmap",
+".xwd"          =>      "image/x-xwindowdump",
+".css"          =>      "text/css",
+".html"         =>      "text/html",
+".htm"          =>      "text/html",
+".js"           =>      "text/javascript",
+".asc"          =>      "text/plain",
+".c"            =>      "text/plain",
+".cpp"          =>      "text/plain",
+".log"          =>      "text/plain",
+".conf"         =>      "text/plain",
+".text"         =>      "text/plain",
+".txt"          =>      "text/plain",
+".dtd"          =>      "text/xml",
+".xml"          =>      "text/xml",
+".mpeg"         =>      "video/mpeg",
+".mpg"          =>      "video/mpeg",
+".mp4"          =>      "video/quicktime",
+".mov"          =>      "video/quicktime",
+".qt"           =>      "video/quicktime",
+".avi"          =>      "video/x-msvideo",
+".asf"          =>      "video/x-ms-asf",
+".asx"          =>      "video/x-ms-asf",
+".wmv"          =>      "video/x-ms-wmv",
+".bz2"          =>      "application/x-bzip",
+".tbz"          =>      "application/x-bzip-compressed-tar",
+".tar.bz2"      =>      "application/x-bzip-compressed-tar",
+# default mime type
+""              =>      "application/octet-stream",
+)
 
 # Use the "Content-Type" extended attribute to obtain mime type if possible
 #mimetype.use-xattr        = "enable"
@@ -132,8 +132,9 @@ mimetype.assign             = (
 url.access-deny             = ( "~", ".inc" )
 
 $HTTP["url"] =~ "\.pdf$" {
-  server.range-requests = "disable"
+server.range-requests = "disable"
 }
+#first alias
 
 ##
 # which extensions should not be handle via static-file transfer
@@ -151,7 +152,6 @@ static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
 
 ## error-handler for status 404
 server.error-handler-404   = "/404.html"
-#server.error-handler-404   = "/error-handler.php"
 
 ## to help the rc.scripts
 server.pid-file            = "/var/run/lighttpd/lighttpd.pid"
@@ -218,7 +218,7 @@ server.groupname           = "http"
 #### fastcgi module
 ## read fastcgi.txt for more info
 ## for PHP don't forget to set cgi.fix_pathinfo = 1 in the php.ini
- fastcgi.server = (
+fastcgi.server = (
         ".php" => ((
             "bin-path" => "/usr/bin/php-cgi",
             "socket"   => "/var/run/lighttpd/mythtv-php-fcgi.socket",
@@ -232,24 +232,29 @@ server.groupname           = "http"
         ))
     )
 
-     setenv.add-environment = (
-             "db_server"   => "localhost",
-             "db_name"     => "mythconverg",
-             "db_login"    => "mythtv",
-             "db_password" => "mythtv"
-)	
+    setenv.add-environment = (
+            "db_server"   => "localhost",
+            "db_name"     => "mythconverg",
+            "db_login"    => "mythtv",
+            "db_password" => "mythtv"
+)
 #### CGI module
-cgi.assign                 = ( ".pl"  => "/usr/bin/perl",
-                               ".cgi" => "/usr/bin/perl",
-			       ".sh"  => "/bin/bash",
-			       ".py"  => "/usr/bin/python2")
-
-   url.rewrite-once = (
-       "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
-       "^/mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
-       "^/mythweb/(.+)$"       => "/mythweb/mythweb.php/$1",
-       "^/mythweb/(.*)$"       => "/mythweb/mythweb.php"
-   )
+cgi.assign        = ( ".pl"  => "/usr/bin/perl",
+                    ".cgi" => "/usr/bin/perl",
+                    ".sh"  => "/bin/bash",
+                    ".py"  => "/usr/bin/python2")
+alias.url = ( "/unicorn" => "/data/srv/httpd/supercorn" )
+alias.url += ( "/cgi-bin" => "/data/srv/httpd/cgi-bin/")
+$HTTP["url"] =~ "^/cgi-bin" {
+    cgi.assign = ( "" => "" )
+    }
+
+url.rewrite-once = (
+    "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
+    "^/mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
+    "^/mythweb/(.+)$"       => "/mythweb/mythweb.php/$1",
+    "^/mythweb/(.*)$"       => "/mythweb/mythweb.php"
+)
 
 
 
-- 
cgit v0.12