From 4a914dde9929428b8b05ffe6e176ef177563f329 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 7 Apr 2014 16:55:39 +0000
Subject: runit-scripts: handle stopped plymouth a bit better. refs #891

---
 abs/core/runit-scripts/PKGBUILD                              |  2 +-
 abs/core/runit-scripts/runitscripts/3                        | 12 ++++++++++++
 abs/core/runit-scripts/runitscripts/services/frontend/finish |  2 +-
 3 files changed, 14 insertions(+), 2 deletions(-)

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index ea41c96..64eeff7 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=8.1
-pkgrel=12
+pkgrel=13
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 91617e5..062f2c6 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -6,6 +6,16 @@ clear
 . /etc/rc.conf
 . /etc/rc.d/functions
 
+#continue plymouthd that was stopped in /etc/X11/Sessions/Linhes
+cp -f /run/plymouth.pid /tmp/plymouthd
+pidfile=/run/plymouth.pid
+if [ -e "$pidfile" ]; then
+    plypid=`cat "$pidfile"`
+    if [ -n "$plypid" ]; then
+        kill -s CONT "$plypid"
+    fi
+fi
+
 stat_busy "Waiting for services to stop..."
 sv -w196 force-stop /service/*
 sv exit /service/*
@@ -32,4 +42,6 @@ ethtool -s  eth0 wol g 2>/dev/null
 ethtool -s  eth1 wol g 2>/dev/null
 ethtool -s  eth2 wol g 2>/dev/null
 
+plymouth quit --retain-splash
+
 /etc/rc.shutdown
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/finish b/abs/core/runit-scripts/runitscripts/services/frontend/finish
index 702b543..d96bcf0 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/finish
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/finish
@@ -9,7 +9,7 @@ function cleanup(){
              printhl  "    Cleaning up  /etc/sv/frontend/.runtime/"
 }
 
-#unpause plymouthd that was paused in /etc/X11/Sessions/Linhes
+#continue plymouthd that was stopped in /etc/X11/Sessions/Linhes
 pidfile=/run/plymouth.pid
 if [ -e "$pidfile" ]; then
     plypid=`cat "$pidfile"`
-- 
cgit v0.12