From 473975ef60ffa95ecdf3a61e0bbff9698070d88c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 27 Aug 2012 15:06:34 -0500
Subject: LinHES-config: on install set the grub menu color scheme to
 blue/yellow

---
 abs/core/LinHES-config/PKGBUILD      |  4 ++--
 abs/core/LinHES-config/mv_install.py | 16 +++++++++++-----
 2 files changed, 13 insertions(+), 7 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index f39a180..24a6e16 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=84
+pkgrel=86
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -123,7 +123,7 @@ build() {
     install -o root -g root  -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
     install -o root -g root  -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
 }
-md5sums=('517b2065493bc07355e8e4f2963cb2fd'
+md5sums=('fe57dd29e1479073f667a5168b479d7f'
          'f33e1a6f7985091b8d47cbaf7433f90f'
          '9a942c95d2c5a4fb27713d6e2b633e89'
          '2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index 6a52468..1cb341f 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -887,17 +887,23 @@ def grub_it():
         logging.debug("    Couldn't open grub file for reading")
         pass
 
-    time_line   = "GRUB_TIMEOUT="
-    hidden_time = "GRUB_HIDDEN_TIMEOUT="
-    color_line  = "GRUB_COLOR"
+    time_line             = "GRUB_TIMEOUT="
+    hidden_time           = "GRUB_HIDDEN_TIMEOUT="
+    color_line_normal     = "GRUB_COLOR_NORMAL"
+    color_line_highlight  = "GRUB_COLOR_HIGHLIGHT"
 
     for line in oldgrub:
         new_line=line
         if line.find(time_line) != -1 :
             new_line="GRUB_TIMEOUT=0\n"
 
-        if line.find(color_line) != -1 :
-            new_line=line.lstrip('''#''')
+        if line.find(color_line_normal) != -1 :
+            #new_line=line.lstrip('''#''')
+            new_line='''GRUB_COLOR_NORMAL="white/blue"\n'''
+
+        if line.find(color_line_highlight) != -1 :
+                #new_line=line.lstrip('''#''')
+                new_line='''GRUB_COLOR_HIGHLIGHT="black/yellow"\n'''
 
         if line.find(hidden_time) != -1 :
             new_line="GRUB_HIDDEN_TIMEOUT=5\n"
-- 
cgit v0.12