From 0898b5607ecc8ba67c171cea06194d85c5afbc07 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 25 Jan 2016 20:02:20 +0000
Subject: boost: update to 1.60.0

---
 ...missing-include-to-signals2-trackable.hpp.patch | 29 ----------------------
 abs/extra/boost/PKGBUILD                           | 26 +++++++++----------
 abs/extra/boost/__changelog                        |  2 +-
 3 files changed, 14 insertions(+), 43 deletions(-)
 delete mode 100644 abs/extra/boost/0001-Add-missing-include-to-signals2-trackable.hpp.patch

diff --git a/abs/extra/boost/0001-Add-missing-include-to-signals2-trackable.hpp.patch b/abs/extra/boost/0001-Add-missing-include-to-signals2-trackable.hpp.patch
deleted file mode 100644
index d833ee8..0000000
--- a/abs/extra/boost/0001-Add-missing-include-to-signals2-trackable.hpp.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 06ccdfee76fe487a141b95848d1c866890f15d88 Mon Sep 17 00:00:00 2001
-From: Evangelos Foutras <evangelos@foutrelis.com>
-Date: Thu, 6 Nov 2014 09:19:26 +0200
-Subject: [PATCH] Add missing include to signals2/trackable.hpp
-
-boost::weak_ptr started being used in commit a0bf2d1 (Disconnect slots
-associated with signals2::trackable immediately) but the matching header
-wasn't included.
-
-https://svn.boost.org/trac/boost/ticket/10100#comment:7
----
- include/boost/signals2/trackable.hpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/boost/signals2/trackable.hpp b/include/boost/signals2/trackable.hpp
-index dba001d..64e8489 100644
---- a/include/boost/signals2/trackable.hpp
-+++ b/include/boost/signals2/trackable.hpp
-@@ -18,6 +18,7 @@
- 
- #include <boost/assert.hpp>
- #include <boost/shared_ptr.hpp>
-+#include <boost/weak_ptr.hpp>
- 
- namespace boost {
-   namespace signals2 {
--- 
-2.1.3
-
diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
index 17d4995..cb7b3b7 100644
--- a/abs/extra/boost/PKGBUILD
+++ b/abs/extra/boost/PKGBUILD
@@ -1,5 +1,6 @@
 # $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
 # Contributor: kevin <kevin@archlinux.org>
 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
@@ -8,23 +9,22 @@
 
 pkgbase=boost
 pkgname=('boost-libs' 'boost')
-pkgver=1.57.0
+pkgver=1.60.0
 _boostver=${pkgver//./_}
-pkgrel=3
+pkgrel=2
 url='http://www.boost.org/'
 arch=('i686' 'x86_64')
 license=('custom')
-makedepends=('icu>=53.1' 'python2' 'bzip2' 'zlib' 'openmpi')
+makedepends=('icu>=55.1' 'python2' 'bzip2' 'zlib' 'openmpi')
 source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
-        0001-Add-missing-include-to-signals2-trackable.hpp.patch)
-sha1sums=('e151557ae47afd1b43dc3fac46f8b04a8fe51c12'
-          '35bc8ad7493a641ec708a691036fe5319aec70cd')
+        cuda_float128.patch::"https://github.com/boostorg/config/commit/a332112317450457c715675686386ec81214b863.patch")
+sha1sums=('7f56ab507d3258610391b47fef6b11635861175a'
+          'bdc6486e0d90368bbfd872fed8ee3d3c73483933')
 
 prepare() {
-   cd ${pkgbase}_${_boostver}
-
-   # https://github.com/boostorg/signals2/pull/8
-   patch -Np2 -i ../0001-Add-missing-include-to-signals2-trackable.hpp.patch
+  cd ${pkgbase}_${_boostver}
+  # fix https://svn.boost.org/trac/boost/ticket/11852
+  patch -p2 -i ../cuda_float128.patch
 }
 
 build() {
@@ -41,7 +41,7 @@ build() {
 
    # Add an extra python version. This does not replace anything and python 2.x
    # need to be the default.
-   #echo "using python : 3.4 : /usr/bin/python3 : /usr/include/python3.4m : /usr/lib ;" \
+   #echo "using python : 3.5 : /usr/bin/python3 : /usr/include/python3.5m : /usr/lib ;" \
    #   >> project-config.jam
 
    # Support for OpenMPI
@@ -65,7 +65,7 @@ build() {
       link=shared,static \
       toolset=gcc \
       python=2.7 \
-      cflags="${CPPFLAGS} ${CFLAGS} -O3" linkflags="${LDFLAGS}" \
+      cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" linkflags="${LDFLAGS}" \
       --layout=system \
       --prefix="${_stagedir}" \
       ${JOBS} \
diff --git a/abs/extra/boost/__changelog b/abs/extra/boost/__changelog
index 36e53c0..f11e775 100644
--- a/abs/extra/boost/__changelog
+++ b/abs/extra/boost/__changelog
@@ -1 +1 @@
-PKGBUILD: remove python dep and comment out python 3.4 line
+PKGBUILD: remove python dep and comment out python 3.5 line
-- 
cgit v0.12