From 40c97d4ccad2d9c7dc6df0ea12ddb3c5b6a7b66f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 7 Feb 2017 22:25:08 +0000
Subject: libfastjson: initial commit; dep of rsyslog

---
 abs/extra/libfastjson/PKGBUILD | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 abs/extra/libfastjson/PKGBUILD

diff --git a/abs/extra/libfastjson/PKGBUILD b/abs/extra/libfastjson/PKGBUILD
new file mode 100644
index 0000000..ab137ad
--- /dev/null
+++ b/abs/extra/libfastjson/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id$
+# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer: Bob Gregory <pathogenix@gmail.com>
+
+pkgname=libfastjson
+pkgver=0.99.4
+pkgrel=1
+pkgdesc="A performance-focused json library for C"
+arch=('i686' 'x86_64')
+url="https://github.com/rsyslog/libfastjson"
+license=('GPL')
+depends=()
+source=($pkgname-$pkgver.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('03ef63dcc88417e71c19ce4436804159e3397e3a20d3529efef6a43c3bef5c8d')
+
+build() {
+  cd "$pkgname-$pkgver"
+  autoreconf -fvi
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+  make DESTDIR="$pkgdir/" install
+}
-- 
cgit v0.12