From 9a9de8a9747fb3aeaeebb39327cf00b5f3bd49a3 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Fri, 3 Dec 2010 03:27:08 +0000
Subject: libtorrent-rasterbar: inital include for deluge

---
 abs/extra/community/libtorrent-rasterbar/PKGBUILD  | 30 ++++++++++++++++++++++
 .../community/libtorrent-rasterbar/__changelog     |  1 +
 2 files changed, 31 insertions(+)
 create mode 100644 abs/extra/community/libtorrent-rasterbar/PKGBUILD
 create mode 100644 abs/extra/community/libtorrent-rasterbar/__changelog

diff --git a/abs/extra/community/libtorrent-rasterbar/PKGBUILD b/abs/extra/community/libtorrent-rasterbar/PKGBUILD
new file mode 100644
index 0000000..dc719f9
--- /dev/null
+++ b/abs/extra/community/libtorrent-rasterbar/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 100316 2010-11-22 16:29:19Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
+
+pkgname=libtorrent-rasterbar
+pkgver=0.15.4
+pkgrel=3
+pkgdesc="A C++ library that aims to be a good alternative to all the other bittorrent implementations around"
+url="http://www.rasterbar.com/products/libtorrent/"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('boost-libs>=1.44.0' 'python2')
+makedepends=('boost')
+source=(http://libtorrent.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+md5sums=('58750b3a246d056335745f9e805bb949')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr --enable-python-binding \
+              --with-boost-filesystem=mt \
+              --with-boost-thread=mt
+  make
+}
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+  install -D COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/abs/extra/community/libtorrent-rasterbar/__changelog b/abs/extra/community/libtorrent-rasterbar/__changelog
new file mode 100644
index 0000000..6528095
--- /dev/null
+++ b/abs/extra/community/libtorrent-rasterbar/__changelog
@@ -0,0 +1 @@
+change boost-lib dep to >=1.44
-- 
cgit v0.12