From 5a289b2c00bb7df836e945162cb693eea02c1e62 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 8 Mar 2018 20:06:59 +0000
Subject: icu: update 60.2

---
 abs/extra/icu/PKGBUILD                      |  29 +++----
 abs/extra/icu/icu.8198.revert.icu5431.patch | 129 ----------------------------
 2 files changed, 13 insertions(+), 145 deletions(-)
 delete mode 100644 abs/extra/icu/icu.8198.revert.icu5431.patch

diff --git a/abs/extra/icu/PKGBUILD b/abs/extra/icu/PKGBUILD
index 90fb89b..a262359 100644
--- a/abs/extra/icu/PKGBUILD
+++ b/abs/extra/icu/PKGBUILD
@@ -3,25 +3,22 @@
 # Contributor: Art Gramlich <art@gramlich-net.com>
 
 pkgname=icu
-pkgver=56.1
-pkgrel=2
+pkgver=60.2
+pkgrel=1
 pkgdesc="International Components for Unicode library"
-arch=(i686 x86_64)
+arch=(x86_64)
 url="http://www.icu-project.org/"
 license=('custom:icu')
-depends=('gcc-libs>=4.7.1-5' 'sh')
+depends=('gcc-libs' 'sh')
 #makedepends=('clang')
+# no https available
 source=(#http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
-	    http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
-	    icu.8198.revert.icu5431.patch)
-md5sums=('c4a2d71ff56aec5ebfab2a3f059be99d'
-         'ebd5470fc969c75e52baf4af94a9ee82')
-
-prepare() {
-  cd icu/source
-  # fix Malayalam encoding https://bugzilla.redhat.com/show_bug.cgi?id=654200
-  patch -Rp3 -i ${srcdir}/icu.8198.revert.icu5431.patch
-}
+        https://ssl.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz{,.asc})
+# upstream offers md5sum checks, only asc file for md5sum check
+md5sums=('43861b127744b3c0b9d7f386f4b9fa40'
+         'SKIP')
+validpgpkeys=('BA90283A60D67BA0DD910A893932080F4FB419E3') #  "Steven R. Loomis (filfla-signing) <srloomis@us.ibm.com>" 
+validpgpkeys+=('9731166CD8E23A83BEE7C6D3ACA5DBE1FD8FABF1') #  "Steven R. Loomis (ICU Project) <srl@icu-project.org>" 
 
 build() {
   cd icu/source
@@ -34,7 +31,7 @@ build() {
 
 check() {
   cd icu/source
-  make -k check # passes all
+  make -k check
 }
 
 package() {
@@ -42,5 +39,5 @@ package() {
   make -j1 DESTDIR=${pkgdir} install
 
   # Install license
-  install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/icu/license.html
+  install -Dm644 ${srcdir}/icu/LICENSE ${pkgdir}/usr/share/licenses/icu/LICENSE
 }
diff --git a/abs/extra/icu/icu.8198.revert.icu5431.patch b/abs/extra/icu/icu.8198.revert.icu5431.patch
deleted file mode 100644
index 4c3e78b..0000000
--- a/abs/extra/icu/icu.8198.revert.icu5431.patch
+++ /dev/null
@@ -1,129 +0,0 @@
-Index: icu/trunk/source/layout/IndicReordering.cpp
-===================================================================
---- icu/trunk/source/layout/IndicReordering.cpp	(revision 25772)
-+++ icu/trunk/source/layout/IndicReordering.cpp	(revision 26090)
-@@ -126,4 +126,8 @@
-     FeatureMask fSMFeatures;
- 
-+    LEUnicode   fPreBaseConsonant;
-+    LEUnicode   fPreBaseVirama;
-+    le_int32    fPBCIndex;
-+    FeatureMask fPBCFeatures;
- 
-     void saveMatra(LEUnicode matra, le_int32 matraIndex, IndicClassTable::CharClass matraClass)
-@@ -172,5 +176,6 @@
-           fMatraFeatures(0), fMPreOutIndex(-1), fMPreFixups(mpreFixups),
-           fVMabove(0), fVMpost(0), fVMIndex(0), fVMFeatures(0),
--          fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0)
-+          fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0),
-+          fPreBaseConsonant(0), fPreBaseVirama(0), fPBCIndex(0), fPBCFeatures(0)
-     {
-         // nothing else to do...
-@@ -191,4 +196,6 @@
-         fVMabove = fVMpost  = 0;
-         fSMabove = fSMbelow = 0;
-+
-+        fPreBaseConsonant = fPreBaseVirama = 0;
-     }
- 
-@@ -386,4 +393,12 @@
-     }
- 
-+    void notePreBaseConsonant(le_uint32 index,LEUnicode PBConsonant, LEUnicode PBVirama, FeatureMask features)
-+    {
-+        fPBCIndex = index;
-+        fPreBaseConsonant = PBConsonant;
-+        fPreBaseVirama = PBVirama;
-+        fPBCFeatures = features;
-+    }
-+
-     void noteBaseConsonant()
-     {
-@@ -465,4 +480,20 @@
-     }
-     
-+    void writePreBaseConsonant()
-+    {
-+        // The TDIL spec says that consonant + virama + RRA should produce a rakar in Malayalam.  However,
-+        // it seems that almost none of the fonts for Malayalam are set up to handle this.
-+        // So, we're going to force the issue here by using the rakar as defined with RA in most fonts.
-+
-+        if (fPreBaseConsonant == 0x0d31) { // RRA
-+            fPreBaseConsonant = 0x0d30; // RA
-+        }
-+        
-+        if (fPreBaseConsonant != 0) {
-+            writeChar(fPreBaseConsonant, fPBCIndex, fPBCFeatures);
-+            writeChar(fPreBaseVirama,fPBCIndex-1,fPBCFeatures);
-+        }
-+    }
-+
-     le_int32 getOutputIndex()
-     {
-@@ -723,4 +754,5 @@
-             }
- 
-+            
-             IndicClassTable::CharClass charClass = CC_RESERVED;
-             IndicClassTable::CharClass nextClass = CC_RESERVED;
-@@ -730,7 +762,9 @@
-             le_bool  seenVattu = FALSE;
-             le_bool  seenBelowBaseForm = FALSE;
-+            le_bool  seenPreBaseForm = FALSE;
-             le_bool  hasNukta = FALSE;
-             le_bool  hasBelowBaseForm = FALSE;
-             le_bool  hasPostBaseForm = FALSE;
-+            le_bool  hasPreBaseForm = FALSE;
- 
-             if (postBase < markStart && classTable->isNukta(chars[postBase])) {
-@@ -746,12 +780,20 @@
-                 hasBelowBaseForm = IndicClassTable::hasBelowBaseForm(charClass) && !hasNukta;
-                 hasPostBaseForm  = IndicClassTable::hasPostBaseForm(charClass)  && !hasNukta;
-+                hasPreBaseForm = IndicClassTable::hasPreBaseForm(charClass) && !hasNukta;
- 
-                 if (IndicClassTable::isConsonant(charClass)) {
-                     if (postBaseLimit == 0 || seenVattu ||
-                         (baseConsonant > baseLimit && !classTable->isVirama(chars[baseConsonant - 1])) ||
--                        !(hasBelowBaseForm || hasPostBaseForm)) {
-+                        !(hasBelowBaseForm || hasPostBaseForm || hasPreBaseForm)) {
-                         break;
-                     }
- 
-+                    // Note any pre-base consonants
-+                    if ( baseConsonant == lastConsonant && lastConsonant > 0 && 
-+                         hasPreBaseForm && classTable->isVirama(chars[baseConsonant - 1])) {
-+                        output.notePreBaseConsonant(lastConsonant,chars[lastConsonant],chars[lastConsonant-1],tagArray2);
-+                        seenPreBaseForm = TRUE;
-+   
-+                    }
-                     // consonants with nuktas are never vattus
-                     seenVattu = IndicClassTable::isVattu(charClass) && !hasNukta;
-@@ -786,10 +828,12 @@
- 
-             // write any pre-base consonants
-+            output.writePreBaseConsonant();
-+
-             le_bool supressVattu = TRUE;
- 
-             for (i = baseLimit; i < baseConsonant; i += 1) {
-                 LEUnicode ch = chars[i];
--                // Don't put 'blwf' on first consonant.
--                FeatureMask features = (i == baseLimit? tagArray2 : tagArray1);
-+                // Don't put 'pstf' or 'blwf' on anything before the base consonant.
-+                FeatureMask features = tagArray1 & ~( pstfFeatureMask | blwfFeatureMask );
- 
-                 charClass = classTable->getCharClass(ch);
-@@ -842,5 +886,5 @@
- 
-             // write below-base consonants
--            if (baseConsonant != lastConsonant) {
-+            if (baseConsonant != lastConsonant && !seenPreBaseForm) {
-                 for (i = bcSpan + 1; i < postBase; i += 1) {
-                     output.writeChar(chars[i], i, tagArray1);
-@@ -872,5 +916,5 @@
-             // write post-base consonants
-             // FIXME: does this put the right tags on post-base consonants?
--            if (baseConsonant != lastConsonant) {
-+            if (baseConsonant != lastConsonant && !seenPreBaseForm) {
-                 if (postBase <= lastConsonant) {
-                     for (i = postBase; i <= lastConsonant; i += 1) {
-- 
cgit v0.12