From 8a19439495bce7280affce7919ebced7880bc0b6 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 24 Jan 2017 16:06:22 +0000
Subject: xymon: make memmbe & memmfe work again

update storage graph names
---
 abs/core/xymon/PKGBUILD           |  6 +++---
 abs/core/xymon/graphs.cfg.diff    | 18 ++++++++++--------
 abs/core/xymon/hobbit-mem-myth.sh | 15 +++++----------
 3 files changed, 18 insertions(+), 21 deletions(-)

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index e69afd4..e207b5e 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.28
-pkgrel=1
+pkgrel=2
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license=('GPL')
 arch=('i686' 'x86_64')
@@ -183,11 +183,11 @@ md5sums=('14501ab2cfce9a332c1590543dfcbd0f'
          '0469d775db9fdd18ea95dd41937ada82'
          'c9a31ea9ae131fb351db913e922c25aa'
          '31ac5c1f6dcc9408b64c4107b325a9a6'
-         '92bd5e8279c688fd854d514443bc733c'
+         '1eee1cf4ded13fcef9f3b43faa20dbe1'
          '80d9cfac86c6d96836e6f406e35e7cf5'
          'df77d1de72157d23a301a72288fbf7e5'
          'b1d5592fa92ef71303621964e84c2b9e'
-         '0757294eec13771f8e63da23cf066796'
+         'f1146cc034f6d11e7d7e68f24bc89dff'
          '2a509d81ee1655130ce40bf970719e0a'
          '313b11e7a22c3c08fb2afaadbfb46d87'
          'a0fbb9cbeb3600a40943e6205790f22f'
diff --git a/abs/core/xymon/graphs.cfg.diff b/abs/core/xymon/graphs.cfg.diff
index 8b1b438..f4d755c 100755
--- a/abs/core/xymon/graphs.cfg.diff
+++ b/abs/core/xymon/graphs.cfg.diff
@@ -1,21 +1,23 @@
---- graphs.cfg.orig	2015-03-04 21:46:31.493387574 +0000
-+++ graphs.cfg	2015-03-04 21:47:26.972936010 +0000
-@@ -2100,4 +2100,60 @@
+--- graphs.cfg.orig	2017-01-24 15:11:38.763486866 +0000
++++ graphs.cfg	2017-01-24 15:10:53.558992118 +0000
+@@ -2111,4 +2111,62 @@
  	GPRINT:qlen@RRDIDX@:AVERAGE: %6.1lf (avg)\n
  
  ########### end of ifmib graphs ###########
 +[storage]
 +       TITLE Storage Groups
-+       YAXIS  recordings
++       YAXIS recordings
 +       DEF:storage1=storage.rrd:rectvtotal:AVERAGE
-+       LINE2:storage1#00CCCC:current recorded
++       LINE2:storage1#00CCCC:recorded total
  
 +       DEF:rectime=storage.rrd:rectvtime:AVERAGE
-+       LINE2:rectime#000000:current recorded time
++       LINE2:rectime#000000:recorded time (hrs)
 +
-+       DEF:livetime=storage.rrd:livetvtime:AVERAGE
-+       LINE2:livetime#00CC11:current live  time
++       DEF:storage2=storage.rrd:livetvtotal:AVERAGE
++       LINE2:storage2#FFA500:live total
 +
++       DEF:livetime=storage.rrd:livetvtime:AVERAGE
++       LINE2:livetime#00CC11:live time (hrs)
 +
 +[memmbe]
 +       TITLE Memory usage for MythBackend
diff --git a/abs/core/xymon/hobbit-mem-myth.sh b/abs/core/xymon/hobbit-mem-myth.sh
index 663e2e3..a373b84 100644
--- a/abs/core/xymon/hobbit-mem-myth.sh
+++ b/abs/core/xymon/hobbit-mem-myth.sh
@@ -1,9 +1,9 @@
 #!/bin/bash
+
 MBEPID=`ps -fU mythtv |grep mythbackend |grep -v runsv|grep -v grep|grep -v logger|awk '{print $2 }'`
 MFEPID=`ps -ef|grep mythfrontend |grep -v runsv|grep -v grep|grep -v logger|grep -v mythfrontend-start|awk '{print $2 }'`
 
 
-
 COLOR=green      # By default, everything is OK
 
    # Do whatever you need to test for something
@@ -19,13 +19,12 @@ MSGMBE="
 	"
 #	echo $MSGMBE
  # Tell Hobbit about it
-   $BB $BBDISP "data $MACHINE.memmbe $COLOR `date`
+   $BB $BBDISP "status $MACHINE.memmbe $COLOR `date`
 
    ${MSGMBE}
 
-   " 
+   "
 fi
-   
 
 
 if [ ! x$MFEPID = x ]
@@ -40,13 +39,9 @@ MSGMBE="
 	"
 #	echo $MSGMBE
  # Tell Hobbit about it
-   $BB $BBDISP "data $MACHINE.memmfe $COLOR `date`
+   $BB $BBDISP "status $MACHINE.memmfe $COLOR `date`
 
    ${MSGMBE}
 
-   " 
+   "
 fi
-   
-
-
-
-- 
cgit v0.12