From 75dedfe8a94866829f02e6a60bfcef6843756ae3 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 26 Mar 2018 17:20:18 +0000
Subject: pyopengl: update to 3.1.0

---
 abs/core/python_modules/pyopengl/LICENSE       | 30 +++++++++++++++
 abs/core/python_modules/pyopengl/PKGBUILD      | 51 ++++++++++++++++++++++++++
 abs/core/python_modules/python-opengl/LICENSE  | 30 ---------------
 abs/core/python_modules/python-opengl/PKGBUILD | 27 --------------
 4 files changed, 81 insertions(+), 57 deletions(-)
 create mode 100644 abs/core/python_modules/pyopengl/LICENSE
 create mode 100644 abs/core/python_modules/pyopengl/PKGBUILD
 delete mode 100644 abs/core/python_modules/python-opengl/LICENSE
 delete mode 100644 abs/core/python_modules/python-opengl/PKGBUILD

diff --git a/abs/core/python_modules/pyopengl/LICENSE b/abs/core/python_modules/pyopengl/LICENSE
new file mode 100644
index 0000000..11d88fb
--- /dev/null
+++ b/abs/core/python_modules/pyopengl/LICENSE
@@ -0,0 +1,30 @@
+# Copyright (c) 2006-2008 Alex Holkner
+# All rights reserved.
+# 
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions 
+# are met:
+#
+#  * Redistributions of source code must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#  * Redistributions in binary form must reproduce the above copyright 
+#    notice, this list of conditions and the following disclaimer in
+#    the documentation and/or other materials provided with the
+#    distribution.
+#  * Neither the name of pyglet nor the names of its
+#    contributors may be used to endorse or promote products
+#    derived from this software without specific prior written
+#    permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+# ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
diff --git a/abs/core/python_modules/pyopengl/PKGBUILD b/abs/core/python_modules/pyopengl/PKGBUILD
new file mode 100644
index 0000000..dbb05c9
--- /dev/null
+++ b/abs/core/python_modules/pyopengl/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Josh Taylor <joshtaylor.mail@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgbase=pyopengl
+pkgname=('python2-opengl' 'python-opengl')
+pkgver=3.1.0
+pkgrel=3
+pkgdesc="The cross platform Python binding to OpenGL and related APIs"
+url="http://pyopengl.sourceforge.net/"
+license=('BSD')
+arch=('any')
+makedepends=('freeglut' 'python2-setuptools' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/P/PyOpenGL/PyOpenGL-${pkgver}.tar.gz"
+        'LICENSE')
+md5sums=('0de021941018d46d91e5a8c11c071693'
+         '0b53c508a63e5dbaf44cdfb0fa103b3a')\
+
+prepare() {
+    cp -a PyOpenGL-${pkgver} python-PyOpenGL-${pkgver}
+
+    # Fix the shebang
+    sed -i 's|#!/usr/bin/env python|#!/usr/bin/python2|' \
+        PyOpenGL-${pkgver}/OpenGL/Tk/__init__.py
+    sed -i 's|#! /usr/bin/env python|#!/usr/bin/python2|' \
+        PyOpenGL-${pkgver}/OpenGL/arrays/{_,}buffers.py
+}
+
+package_python2-opengl() {
+    depends=('python2' 'freeglut')
+	conflicts=('python-pyopengl' 'python-opengl<=3.0.1-4')
+	replaces=('python-pyopengl' 'python-opengl<=3.0.1-4')
+
+    cd PyOpenGL-${pkgver}
+	python2 setup.py install --root="${pkgdir}" --optimize=1
+	install -Dm644 "${srcdir}/LICENSE" \
+		"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python-opengl() {
+    depends=('python' 'freeglut')
+ 
+    cd python-PyOpenGL-${pkgver}
+ 	python setup.py install --root="${pkgdir}" --optimize=1
+	install -Dm644 "${srcdir}/LICENSE" \
+		"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/abs/core/python_modules/python-opengl/LICENSE b/abs/core/python_modules/python-opengl/LICENSE
deleted file mode 100644
index 11d88fb..0000000
--- a/abs/core/python_modules/python-opengl/LICENSE
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright (c) 2006-2008 Alex Holkner
-# All rights reserved.
-# 
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions 
-# are met:
-#
-#  * Redistributions of source code must retain the above copyright
-#    notice, this list of conditions and the following disclaimer.
-#  * Redistributions in binary form must reproduce the above copyright 
-#    notice, this list of conditions and the following disclaimer in
-#    the documentation and/or other materials provided with the
-#    distribution.
-#  * Neither the name of pyglet nor the names of its
-#    contributors may be used to endorse or promote products
-#    derived from this software without specific prior written
-#    permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
-# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
-# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
-# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
-# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
-# ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
diff --git a/abs/core/python_modules/python-opengl/PKGBUILD b/abs/core/python_modules/python-opengl/PKGBUILD
deleted file mode 100644
index 57f77fd..0000000
--- a/abs/core/python_modules/python-opengl/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# $Id: PKGBUILD 150966 2012-02-24 10:19:17Z pierre $
-# Contributor: Josh Taylor <joshtaylor.mail@gmail.com>
-# Contributor: simo <simo@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
-pkgname=python-opengl
-pkgver=3.0.1
-pkgrel=3
-pkgdesc="The cross platform Python binding to OpenGL and related APIs"
-url="http://pyopengl.sourceforge.net"
-license=('BSD')
-arch=('any')
-depends=('python2' 'tk' 'freeglut' 'setuptools')
-provides=('pyopengl' 'python-pyopengl')
-conflicts=('pyopengl' 'python-pyopengl')
-source=("http://downloads.sourceforge.net/pyopengl/PyOpenGL-${pkgver}.tar.gz"
-        'LICENSE')
-md5sums=('221d4a6a0928fcfeef26751370ec5f52'
-         '0b53c508a63e5dbaf44cdfb0fa103b3a')
-
-package() {
-	cd ${srcdir}/PyOpenGL-${pkgver}
-	python2 setup.py install --root=${pkgdir}
-	install -Dm644 ${srcdir}/LICENSE \
-		${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-}
-- 
cgit v0.12