From 482462cef6bfacf60e2bdf9bea5501047872f073 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 5 Dec 2014 15:18:39 +0000
Subject: pinentry: update to 0.9.0

---
 abs/core/pinentry/PKGBUILD                  | 22 +++++++++-------------
 abs/core/pinentry/qt4-pinentry-window.patch | 28 ----------------------------
 2 files changed, 9 insertions(+), 41 deletions(-)
 delete mode 100644 abs/core/pinentry/qt4-pinentry-window.patch

diff --git a/abs/core/pinentry/PKGBUILD b/abs/core/pinentry/PKGBUILD
index 072a2b2..2da4a57 100644
--- a/abs/core/pinentry/PKGBUILD
+++ b/abs/core/pinentry/PKGBUILD
@@ -1,26 +1,24 @@
-# $Id: PKGBUILD 160802 2012-06-06 10:36:53Z tpowa $
+# $Id$
 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
 pkgname=pinentry
-pkgver=0.8.1
-pkgrel=4
+pkgver=0.9.0
+pkgrel=1
 pkgdesc="a collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
 arch=('i686' 'x86_64')
 license=('GPL')
-url="http://www.gnupg.org/aegypten2"
+url="http://gnupg.org/related_software/pinentry/"
 depends=('ncurses' 'libcap>=2.16')
-makedepends=('gtk2' 'qt')
+makedepends=('gtk2' 'qt4')
 optdepends=('gtk2: for gtk2 backend'
-            'qt: for qt4 backend')  
-source=(ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
-        qt4-pinentry-window.patch)
+            'qt4: for qt4 backend')  
+source=(ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2)
 install=pinentry.install
+md5sums=('40a05856cb3accf6679987b7899b0f5a')
 
 build() {
   cd $srcdir/$pkgname-$pkgver
-  #fix: https://bugs.archlinux.org/task/29998
-  patch -Np1 -i ../qt4-pinentry-window.patch
   for file in qt4/*.moc; do
-       /usr/bin/moc ${file/.moc/.h} > ${file}
+       moc-qt4 ${file/.moc/.h} > ${file}
    done
   ./configure --prefix=/usr \
 	--enable-pinentry-curses \
@@ -36,5 +34,3 @@ package() {
   cd $srcdir/$pkgname-$pkgver
   make DESTDIR=${pkgdir} install 
 }
-md5sums=('81f99904daee5331eb6738408bb024b6'
-         '450b8713fe42f1bd93311ef84767c3d8')
diff --git a/abs/core/pinentry/qt4-pinentry-window.patch b/abs/core/pinentry/qt4-pinentry-window.patch
deleted file mode 100644
index 8f9faae..0000000
--- a/abs/core/pinentry/qt4-pinentry-window.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From c2ab12b3742c929a225c3753439438edc27bfa81 Mon Sep 17 00:00:00 2001
-From: Stanislav Ochotnicky <sochotnicky@redhat.com>
-Date: Tue, 1 Feb 2011 14:42:27 +0100
-Subject: [PATCH] Fix qt4 pinentry window created in the background
-
-This is probably just a workaround. Proper fix is being investigated.
-See:
-https://bugzilla.redhat.com/show_bug.cgi?id=589532
-http://stackoverflow.com/questions/2788518/calling-activatewindow-on-qdialog-sends-window-to-background
----
- qt4/pinentrydialog.cpp |    1 -
- 1 files changed, 0 insertions(+), 1 deletions(-)
-
-diff --git a/qt4/pinentrydialog.cpp b/qt4/pinentrydialog.cpp
-index 541baf4..d634eb6 100644
---- a/qt4/pinentrydialog.cpp
-+++ b/qt4/pinentrydialog.cpp
-@@ -69,7 +69,6 @@ void raiseWindow( QWidget* w )
-     SetForegroundWindow( w->winId() );
- #endif
-     w->raise();
--    w->activateWindow();
- }
- 
- QPixmap icon( QStyle::StandardPixmap which )
--- 
-1.7.3.5
-
-- 
cgit v0.12