From 85133ec7a9c4b9b9e3f57ac5b25ca21a588e48a1 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Feb 2019 14:19:20 +0000
Subject: opam: dep of ocaml-integers

---
 abs/extra/opam/PKGBUILD | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 abs/extra/opam/PKGBUILD

diff --git a/abs/extra/opam/PKGBUILD b/abs/extra/opam/PKGBUILD
new file mode 100644
index 0000000..0db29ee
--- /dev/null
+++ b/abs/extra/opam/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Vincent B. <vb@luminar.eu.org>
+
+pkgname=opam
+pkgver=2.0.3
+pkgrel=1
+pkgdesc='OCaml package manager'
+arch=(x86_64)
+url='https://opam.ocaml.org/'
+license=(GPL)
+depends=(bubblewrap ocaml-compiler-libs unzip)
+optdepends=('darcs: For downloading packages with darcs'
+            'git: For downloading packages with git'
+            'mercurial: For downloading packages with mercurial'
+            'rsync: For downloading packages with rsync')
+source=("https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz")
+sha256sums=('0589da4da184584a5445d59385009536534f60bc0e27772245b2f49e5fa8f0e2')
+
+build() {
+  cd "opam-full-$pkgver"
+  ./configure --prefix=/usr
+  make lib-ext all -j1 \
+    OCAMLC='ocamlc -unsafe-string' \
+    OCAMLOPT='ocamlopt -unsafe-string'
+}
+
+package() {
+  make -C "opam-full-$pkgver" DESTDIR="$pkgdir" install
+
+  install -d "$pkgdir/usr/share/doc"
+  mv "$pkgdir/usr/doc/opam-installer" "$pkgdir/usr/share/doc/opam"
+  rmdir "$pkgdir/usr/doc"
+}
+
+# getver: opam.ocaml.org
+# vim: ts=2 sw=2 et:
-- 
cgit v0.12