From 0ee2824a5f1c1cfe961310f5cd645716bbb43861 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 18 Sep 2011 14:05:44 -0500
Subject: wget: Bump to latest

---
 abs/core/wget/PKGBUILD                    | 36 ++++++++++++++++++++++---------
 abs/core/wget/wget-1.12-2-i686.pkg.tar.gz |  1 -
 abs/core/wget/wget.install                |  2 +-
 3 files changed, 27 insertions(+), 12 deletions(-)
 delete mode 120000 abs/core/wget/wget-1.12-2-i686.pkg.tar.gz

diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index eb13f03..44a6477 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 75183 2010-04-01 01:40:17Z pierre $
+# $Id$
 # Maintainer: Allan McRae <allan@archlinux.org>
 # Contributor: Judd Vinet <jvinet@zeroflux.org>
 
 pkgname=wget
-pkgver=1.12
-pkgrel=3
+pkgver=1.13.4
+pkgrel=1
 pkgdesc="A network utility to retrieve files from the Web"
 arch=('i686' 'x86_64')
 url="http://www.gnu.org/software/wget/wget.html"
@@ -14,16 +14,32 @@ depends=('glibc' 'openssl')
 optdepends=('ca-certificates: HTTPS downloads')
 backup=('etc/wgetrc')
 install=wget.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('141461b9c04e454dc8933c9d1f2abf83')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
+md5sums=('7f518b3a71e9efd330e9a0c3714f8463')
 
 build() {
-  cd ${srcdir}/$pkgname-$pkgver
-  ./configure --prefix=/usr --sysconfdir=/etc
-  make || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  # Note : We do not build with --enable-nls, because there is a bug in wget causing
+  # international domain names to be not properly converted to punycode if
+  # the current locale is a UTF-8 one
+  # See : http://lists.gnu.org/archive/html/bug-wget/2011-02/msg00026.html
+
+  ./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc
+  make
 }
 
 package() {
-  cd ${srcdir}/$pkgname-$pkgver
-  make DESTDIR=${pkgdir} install
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+
+  cat >> "$pkgdir/etc/wgetrc" <<EOF
+
+# default root certs location
+ca_certificate=/etc/ssl/certs/ca-certificates.crt
+EOF
+
+  # remove IRI option from wgetrc as it does not work (see above)
+  sed -i '118,120d' $pkgdir/etc/wgetrc
+
 }
diff --git a/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz b/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz
deleted file mode 120000
index 6fc2266..0000000
--- a/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz
+++ /dev/null
@@ -1 +0,0 @@
-/data/pkg_repo/packages/wget-1.12-2-i686.pkg.tar.gz
\ No newline at end of file
diff --git a/abs/core/wget/wget.install b/abs/core/wget/wget.install
index 1715333..8eb6a2c 100644
--- a/abs/core/wget/wget.install
+++ b/abs/core/wget/wget.install
@@ -1,4 +1,4 @@
-infodir=/usr/share/info
+infodir=usr/share/info
 filelist=(wget.info)
 
 post_install() {
-- 
cgit v0.12