From 672eb4dee98c99f5da7f77d026968b6cbadcb905 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 7 Jun 2020 02:36:01 +0000
Subject: libuv: update to 1.38.0

---
 abs/extra/libuv/PKGBUILD    | 21 ++++++++-------------
 abs/extra/libuv/__changelog |  1 -
 2 files changed, 8 insertions(+), 14 deletions(-)
 delete mode 100644 abs/extra/libuv/__changelog

diff --git a/abs/extra/libuv/PKGBUILD b/abs/extra/libuv/PKGBUILD
index 9cc9991..f432623 100644
--- a/abs/extra/libuv/PKGBUILD
+++ b/abs/extra/libuv/PKGBUILD
@@ -1,35 +1,32 @@
-# $Id$
 # Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
 
 pkgname=libuv
-pkgver=1.9.0
+pkgver=1.38.0
 pkgrel=1
 pkgdesc="Multi-platform support library with a focus on asynchronous I/O"
-arch=('i686' 'x86_64')
+arch=('x86_64')
 url="https://github.com/libuv/libuv"
 license=('custom')
-depends=('glibc')
-makedepends=('python2-sphinx')
+depends=('glibc' 'libnsl')
+makedepends=('python-sphinx')
 source=("https://github.com/libuv/libuv/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('da9af33ec17f46f2390661f84e942115c442e665cb63ba5637eb12d2cb0b034889e0d816f261abe7fff3b4d0b44ab8bb63c81f3ec1917325cf0ca93e01921641')
 
 build() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd $pkgname-$pkgver
 	./autogen.sh
 	./configure --prefix=/usr
 	make
 	make man -C docs
-
-	# skip failing get_passwd test
-	sed '/pwd\.homedir/d' -i test/test-get-passwd.c
 }
 
 check() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd $pkgname-$pkgver
 	make check
 }
 
 package() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd $pkgname-$pkgver
 
 	make DESTDIR="$pkgdir" install
 
@@ -44,5 +41,3 @@ package() {
 	install -Dm644 docs/build/man/libuv.1 \
 		"$pkgdir"/usr/share/man/man1/libuv.1
 }
-
-sha256sums=('f8b8272a0d80138b709d38fad2baf771899eed61e7f9578d17898b07a1a2a5eb')
diff --git a/abs/extra/libuv/__changelog b/abs/extra/libuv/__changelog
deleted file mode 100644
index 1f97308..0000000
--- a/abs/extra/libuv/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: change dep python-sphinx to python2-sphinx
-- 
cgit v0.12