From e28e87dcbd836bd2d4611e0461e96c751f262d28 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 12 Dec 2012 11:43:12 -0600
Subject: fluxbox_settings:   default_fluxbox settings

---
 abs/core/fluxbox_settings/PKGBUILD                 |  19 +++++
 abs/core/fluxbox_settings/fluxbox-settings/apps    |   5 ++
 abs/core/fluxbox_settings/fluxbox-settings/init    |  35 +++++++++
 abs/core/fluxbox_settings/fluxbox-settings/menu    |  81 +++++++++++++++++++++
 .../fluxbox_settings/fluxbox-settings/menuconfig   |  65 +++++++++++++++++
 .../fluxbox-settings/wallpaper.png                 | Bin 0 -> 107688 bytes
 abs/core/fluxbox_settings/fluxbox_settings.install |  64 ++++++++++++++++
 7 files changed, 269 insertions(+)
 create mode 100644 abs/core/fluxbox_settings/PKGBUILD
 create mode 100755 abs/core/fluxbox_settings/fluxbox-settings/apps
 create mode 100755 abs/core/fluxbox_settings/fluxbox-settings/init
 create mode 100755 abs/core/fluxbox_settings/fluxbox-settings/menu
 create mode 100755 abs/core/fluxbox_settings/fluxbox-settings/menuconfig
 create mode 100644 abs/core/fluxbox_settings/fluxbox-settings/wallpaper.png
 create mode 100644 abs/core/fluxbox_settings/fluxbox_settings.install

diff --git a/abs/core/fluxbox_settings/PKGBUILD b/abs/core/fluxbox_settings/PKGBUILD
new file mode 100644
index 0000000..8f7623d
--- /dev/null
+++ b/abs/core/fluxbox_settings/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=fluxbox_settings
+pkgver=1.0
+pkgrel=1
+pkgdesc="Default settings for fluxbox"
+depends=('fluxbox')
+source=()
+arch=('i686' 'x86_64')
+groups=(alt_wm)
+install=fluxbox_settings.install
+configdir=/usr/share/fluxbox_settings
+
+build() {
+	echo $startdir
+  	mkdir -p $pkgdir/$configdir
+    rsync -arp --exclude=.svn $startdir/fluxbox-settings/*  $pkgdir/$configdir
+
+}
+
+md5sums=()
diff --git a/abs/core/fluxbox_settings/fluxbox-settings/apps b/abs/core/fluxbox_settings/fluxbox-settings/apps
new file mode 100755
index 0000000..78f66bd
--- /dev/null
+++ b/abs/core/fluxbox_settings/fluxbox-settings/apps
@@ -0,0 +1,5 @@
+#Uncomment below if you are using firewire
+#[startup] {/usr/bin/plugctl -n 0 "oPCR[0].n_p2pconnections=1"}
+#[startup] {feh --bg-scale ~/.fluxbox/wallpaper.png}
+[startup] {wmsetbg  ~/.fluxbox/wallpaper.png}
+#[startup] {/usr/LH/bin/LinHES-run}
diff --git a/abs/core/fluxbox_settings/fluxbox-settings/init b/abs/core/fluxbox_settings/fluxbox-settings/init
new file mode 100755
index 0000000..9791a7f
--- /dev/null
+++ b/abs/core/fluxbox_settings/fluxbox-settings/init
@@ -0,0 +1,35 @@
+session.screen0.slit.placement:	BottomRight
+session.screen0.slit.direction:	Vertical
+session.screen0.slit.onTop:	False
+session.screen0.slit.autoHide:  True
+session.screen0.tab.placement:	Top
+session.screen0.toolbar.onTop:	False
+session.screen0.toolbar.visible:	False
+session.screen0.toolbar.autoHide:	False
+session.screen0.toolbar.placement:	BottomCenter
+session.screen0.toolbar.widthPercent:	66
+session.screen0.workspaceNames:	one,two,three,four
+session.screen0.strftimeFormat:	%k:%M
+session.screen0.focusNewWindows:	True
+session.screen0.focusModel:	ClickToFocus
+session.screen0.fullMaximization:	False
+session.screen0.edgeSnapThreshold:	0
+session.screen0.rowPlacementDirection:	LeftToRight
+session.screen0.workspaces:	4
+session.screen0.focusLastWindow:	True
+session.screen0.colPlacementDirection:	TopToBottom
+session.screen0.windowPlacement:	RowSmartPlacement
+session.screen0.tab.width:	64
+session.screen0.tab.height:	16
+session.screen0.showwindowposition: true
+session.opaqueMove:	False
+session.autoRaiseDelay:	250
+session.menuFile:	~/.fluxbox/menu
+session.cacheLife:	5
+session.styleFile:	/usr/share/fluxbox/styles/Artwiz
+session.keyFile: ~/.fluxbox/keys
+session.colorsPerChannel:	4
+session.doubleClickInterval:	250
+session.cacheMax:	200
+session.imageDither:	True
+session.configVersion:	1
diff --git a/abs/core/fluxbox_settings/fluxbox-settings/menu b/abs/core/fluxbox_settings/fluxbox-settings/menu
new file mode 100755
index 0000000..858090e
--- /dev/null
+++ b/abs/core/fluxbox_settings/fluxbox-settings/menu
@@ -0,0 +1,81 @@
+# Generated by fluxbox-generate_menu
+#
+# If you read this it means you want to edit this file manually, so here
+# are some useful tips:
+#
+# - You can add your own menu-entries to ~/.fluxbox/usermenu
+#
+# - If you miss apps please let me know and I will add them for the next
+#   release.
+#
+# - The -r option prevents removing of empty menu entries and lines which
+#   makes things much more readable.
+#
+# - To prevent any other app from overwriting your menu
+#   you can change the menu name in .fluxbox/init to:
+#     session.menuFile: /home/mythtv/.fluxbox/my-menu
+[begin] (Fluxbox)
+[encoding] {UTF-8}
+      [exec] (xterm) {xterm} 
+      [exec] () {} execname is NULL; cannot lookup
+      [exec]   (Run) {fbrun } 
+[submenu] (Terminals)
+      [exec]   (xterm) {xterm} 
+[end]
+[submenu] (Editors)
+      [exec]   (xedit) {xedit} 
+      [exec]   (nano) {xterm -e nano} 
+      [exec]   (vi) {xterm -e vi} 
+[end]
+[submenu] (Multimedia)
+[submenu] (Audio)
+      [exec]   (alsamixer) {xterm -e alsamixer} 
+[end]
+[submenu] (Video)
+      [exec]   (gmplayer) {gmplayer} 
+[end]
+[submenu] (X-utils)
+      [exec]   (xfontsel) {xfontsel} 
+      [exec]   (xman) {xman} 
+      [exec]   (xload) {xload} 
+      [exec]   (xbiff) {xbiff} 
+      [exec]   (xclock) {xclock} 
+      [exec]   (xmag) {xmag} 
+      [exec] (Reload .Xdefaults) {xrdb -load /home/mythtv/.Xdefaults} 
+[end]
+[end]
+[submenu] (Office)
+      [exec]   (xclock) {xclock} 
+      [exec]   (xcalc) {xcalc} 
+[end]
+[submenu] (Games)
+      [exec]   (xeyes) {xeyes} 
+[end]
+[submenu] (System Tools)
+      [exec]   (top) {xterm -e top} 
+[end]
+[submenu] (fluxbox menu)
+      [config] (Configure) 
+[submenu] (System Styles) {Choose a style...}
+      [stylesdir] (/usr/share/fluxbox/styles) 
+[end]
+[submenu] (User Styles) {Choose a style...}
+      [stylesdir] (~/.fluxbox/styles) 
+[end]
+      [workspaces] (Workspace List) 
+[submenu] (Tools)
+      [exec] (Window name) {xprop WM_CLASS|cut -d \" -f 2|xmessage -file - -center} 
+      [exec] (Screenshot - JPG) {import screenshot.jpg && display -resize 50% screenshot.jpg} 
+      [exec] (Screenshot - PNG) {import screenshot.png && display -resize 50% screenshot.png} 
+      [exec] (Run) {fbrun } 
+      [exec] (Regen Menu) {/usr/bin/fluxbox-generate_menu } 
+[end]
+      [commanddialog] (Fluxbox Command) 
+      [reconfig] (Reload config) 
+      [restart] (Restart) 
+      [exec] (About) {(fluxbox -v; fluxbox -info | sed 1d) 2> /dev/null | xmessage -file - -center} 
+      [separator] 
+      [exit] (Exit) 
+[end]
+[endencoding]
+[end]
diff --git a/abs/core/fluxbox_settings/fluxbox-settings/menuconfig b/abs/core/fluxbox_settings/fluxbox-settings/menuconfig
new file mode 100755
index 0000000..ef5b398
--- /dev/null
+++ b/abs/core/fluxbox_settings/fluxbox-settings/menuconfig
@@ -0,0 +1,65 @@
+# This file is read by fluxbox-generate_menu.  If you don't like a
+# default you can change it here.  Don't forget to remove the # in front
+# of the line.
+
+# Your favourite terminal. Put the command in quotes if you want to use
+# options. Put a backslash in before odd chars
+# MY_TERM='Eterm --tint \#123456'
+# MY_TERM='aterm -tint $(random_color)'
+
+# Your favourite browser. You can also specify options.
+# MY_BROWSER=mozilla
+
+# Name of the outputfile
+# MENUFILENAME=/home/mythtv/.fluxbox/menu
+
+# MENUTITLE=`fluxbox -version|cut -d " " -f-2`
+
+# standard url for console-browsers
+# HOMEPAGE=fluxbox.org
+
+# location with your own menu-entries
+# USERMENU=~/.fluxbox/usermenu
+
+# Put the launcher you would like to use here
+# LAUNCHER=fbrun
+# LAUNCHER=fbgm
+
+# Options for fbrun
+# FBRUNOPTIONS='-font 10x20 -fg grey -bg black -title run'
+
+# --- PREFIX'es
+# These are prefixes; So if fluxbox is installed in /usr/bin/fluxbox
+# your prefix is: /usr
+
+# fluxbox-generate already looks in /usr/X11R6, /usr, /usr/local and /opt so
+# there should be no need to specify them.
+#
+# PREFIX=/usr
+# GNOME_PREFIX=/opt/gnome
+# KDE_PREFIX=/opt/kde
+
+
+# Sepparate the list of background-dirs with semicolumns ':'
+# BACKGROUND_DIRS="/home/mythtv/.fluxbox/backgrounds/:/usr/share/fluxbox/backgrounds/:/usr/share/wallpapers"
+
+
+# --- Boolean variables.
+# Setting a variable to no'' won't help. Comment them out if you don't
+# want them.  Setting are overruled by the command-line options.
+
+# Include all backgrounds in your backgrounds-directory
+# BACKGROUNDMENUITEM=yes
+
+# Include kde-menus
+# KDEMENU=yes
+
+# Include gnome-menus
+# GNOMEMENU=yes
+
+# enable sudo commands
+# DOSUDO=yes
+
+# Don't cleanup the menu
+# REMOVE=no
+
diff --git a/abs/core/fluxbox_settings/fluxbox-settings/wallpaper.png b/abs/core/fluxbox_settings/fluxbox-settings/wallpaper.png
new file mode 100644
index 0000000..bd9590c
Binary files /dev/null and b/abs/core/fluxbox_settings/fluxbox-settings/wallpaper.png differ
diff --git a/abs/core/fluxbox_settings/fluxbox_settings.install b/abs/core/fluxbox_settings/fluxbox_settings.install
new file mode 100644
index 0000000..3def6a2
--- /dev/null
+++ b/abs/core/fluxbox_settings/fluxbox_settings.install
@@ -0,0 +1,64 @@
+# This is a default template for a post-install scriptlet.  You can
+# remove any functions you don't need (and this header).
+configdir=/usr/share/fluxbox_settings
+
+# arg 1:  the new package version
+pre_install() {
+	/bin/true
+}
+
+
+# arg 1:  the new package version
+post_install() {
+    . /usr/MythVantage/bin/install_functions.sh
+    home_check
+    if [ "x$MYTHHOME" != "x" ]
+    then
+        if [ ! -e $MYTHHOME/.fluxbox ]
+        then
+	        ln -s $configdir $MYTHHOME/.fluxbox
+        fi
+    fi
+
+    if [ ! -e /root/.fluxbox ]
+    then
+       ln -s $configdir /root/.fluxbox
+    fi
+
+
+
+
+
+   chown -R 1000:100 $configdir
+   setfacl -d -R -m u:1000:rwx $configdir
+   setfacl -R -m u:1000:rwx $configdir
+   setfacl -d -R -m o::rwx $configdir
+   setfacl  -R -m o::rwx $configdir
+
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_upgrade() {
+   pre_install
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12