From 9615d3ade53f12653f37a74b2e8231d32d230164 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 4 Jan 2012 14:30:55 -0600
Subject: mythplugins: mythburn.py: change croppixels calculation

Change dep fftw to fftw2 for mythmusic
---
 abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD          | 6 +++---
 abs/core/mythtv/stable-0.24/mythplugins/mythburn.py.patch | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
index 83168af..1f83ec4 100644
--- a/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythplugins/PKGBUILD
@@ -13,12 +13,12 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=0.24
-pkgrel=18
+pkgrel=19
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
 conflicts=('mythmovies')
-makedepends=("mythtv>=${pkgver}" 'mplayer' 'fftw' 'dvdauthor' 'libexif'
+makedepends=("mythtv>=${pkgver}" 'mplayer' 'fftw2' 'dvdauthor' 'libexif'
              'python-imaging' 'libcdaudio' 'taglib' 'perl-xml-simple' 'dcraw'
              'libvisual' 'perl-xml-xpath' 'perl-image-size'
              'perl-class-inspector' 'perl-datetime-format-iso8601'
@@ -126,4 +126,4 @@ package_mythzoneminder() {
   make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 md5sums=('91488a6b1b05d14c5c5c601908b699e5'
-         'adce485c4765e8d49b91b3ce9c9963ac')
+         'cc7e6887acda167fcc5336af33f29411')
diff --git a/abs/core/mythtv/stable-0.24/mythplugins/mythburn.py.patch b/abs/core/mythtv/stable-0.24/mythplugins/mythburn.py.patch
index 770119a..abac7df 100644
--- a/abs/core/mythtv/stable-0.24/mythplugins/mythburn.py.patch
+++ b/abs/core/mythtv/stable-0.24/mythplugins/mythburn.py.patch
@@ -161,7 +161,7 @@
 +                else:
 +                    videoheight = 576
 +        
-+                croppixels = videoheight - int(videores.split("x")[1])
++                croppixels = videoheight - (720 / float(videoAR))
 +                write("CropPixels Total: %s" % croppixels)
 +                value = "720x%d -vf pad=720:%d:0:%d:black" % (videoheight - croppixels, videoheight, croppixels / 2)
  
-- 
cgit v0.12