From 1dc6d4cbbdd30b1054b2a09237cb04ce9e8bd63c Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 17:32:34 -0800
Subject: glew:initial inclusion. Needed by mesa-demos.

---
 abs/extra/glew/PKGBUILD | 27 ++++++++++++++++-----------
 1 file changed, 16 insertions(+), 11 deletions(-)

diff --git a/abs/extra/glew/PKGBUILD b/abs/extra/glew/PKGBUILD
index 1db995d..291abce 100644
--- a/abs/extra/glew/PKGBUILD
+++ b/abs/extra/glew/PKGBUILD
@@ -1,23 +1,28 @@
-# $Id: PKGBUILD 27226 2009-02-17 05:43:56Z eric $
-# AUR-Maintainer: William Rea <sillywilly@gmail.com>
+# $Id: PKGBUILD 98297 2010-11-06 17:51:38Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
 # Contributor: SleepyDog
 
 pkgname=glew
-pkgver=1.5.5
+pkgver=1.5.7
 pkgrel=1
-pkgdesc="A cross-platform C/C++ extension loading library"
+pkgdesc="The OpenGL Extension Wrangler Library"
 arch=('i686' 'x86_64')
 url="http://glew.sourceforge.net"
 license=('BSD' 'MIT' 'GPL')
 depends=('libxmu' 'libxi' 'mesa')
-makedepends=('hd2u')
 source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tgz)
+sha1sums=('4adc816afbfb65a4969484d10343a88c117ca989')
 
 build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}
-  dos2unix config/config.guess
-  make || return 1
-  make GLEW_DEST=${startdir}/pkg/usr LIBDIR=${startdir}/pkg/usr/lib install || return 1
-  install -D -m644 LICENSE.txt ${startdir}/pkg/usr/share/licenses/${pkgname}/LICENSE.txt || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  sed -i 's|lib64|lib|' config/Makefile.linux
+  make
 }
-md5sums=('3621f27cfd3e33d5dbcc1111ecb5b762')
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make GLEW_DEST="${pkgdir}/usr" install
+  install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
-- 
cgit v0.12


From e251674e7f213c43829202425a4dfc97515683d2 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 17:33:21 -0800
Subject: mesa-demos:Initial inclusion.

---
 abs/extra/mesa-demos/LICENSE  | 82 +++++++++++++++++++++++++++++++++++++++++++
 abs/extra/mesa-demos/PKGBUILD | 30 ++++++++++++++++
 2 files changed, 112 insertions(+)
 create mode 100644 abs/extra/mesa-demos/LICENSE
 create mode 100644 abs/extra/mesa-demos/PKGBUILD

diff --git a/abs/extra/mesa-demos/LICENSE b/abs/extra/mesa-demos/LICENSE
new file mode 100644
index 0000000..ae33d27
--- /dev/null
+++ b/abs/extra/mesa-demos/LICENSE
@@ -0,0 +1,82 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components.  Different copyrights
+and licenses apply to different components.  For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors.  See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component         Location               Primary Author      License
+----------------------------------------------------------------------------
+Main Mesa code    src/mesa/              Brian Paul          Mesa (MIT)
+
+Device drivers    src/mesa/drivers/*     See drivers         See drivers
+
+Ext headers       include/GL/glext.h     SGI                 SGI Free B
+                  include/GL/glxext.h
+
+GLUT              src/glut/              Mark Kilgard        Mark's copyright
+
+Mesa GLU library  src/glu/mesa/          Brian Paul          GNU-LGPL
+
+SGI GLU library   src/glu/sgi/           SGI                 SGI Free B
+
+demo programs     progs/demos/           various             see source files
+
+X demos           progs/xdemos/          Brian Paul          see source files
+
+SGI demos         progs/samples/         SGI                 SGI copyright
+
+RedBook demos     progs/redbook/         SGI                 SGI copyright
diff --git a/abs/extra/mesa-demos/PKGBUILD b/abs/extra/mesa-demos/PKGBUILD
new file mode 100644
index 0000000..8fabad0
--- /dev/null
+++ b/abs/extra/mesa-demos/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 94667 2010-10-09 11:21:35Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=('mesa-demos')
+pkgver=8.0.1
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="Mesa demos and tools"
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+depends=('glew>=1.5.6')
+conflicts=('mesa<7.9')
+source=(ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2
+        LICENSE)
+md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
+         '5c65a0fe315dd347e09b1f2826a1df5a')
+
+build() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
+  install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
+}
-- 
cgit v0.12


From a4aacb8385185ffcc0fa33ee7d9b752821b1e0c6 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 17:34:17 -0800
Subject: xbmc:mea culpa

---
 abs/extra/xbmc/PKGBUILD    | 4 ++--
 abs/extra/xbmc/__changelog | 1 -
 2 files changed, 2 insertions(+), 3 deletions(-)
 delete mode 100644 abs/extra/xbmc/__changelog

diff --git a/abs/extra/xbmc/PKGBUILD b/abs/extra/xbmc/PKGBUILD
index 13ca0c9..214b609 100644
--- a/abs/extra/xbmc/PKGBUILD
+++ b/abs/extra/xbmc/PKGBUILD
@@ -11,7 +11,7 @@ _prefix=/usr
 
 pkgname=xbmc
 pkgver=10.0
-pkgrel=3
+pkgrel=4
 pkgdesc="XBMC Media Center"
 arch=('i686' 'x86_64')
 url="http://xbmc.org"
@@ -20,7 +20,7 @@ depends=( 'bzip2' 'curl' 'enca' 'faac' 'faad2' 'fontconfig' 'fribidi'
           'glew' 'jasper' 'libcdio' 'libgl' 'libmad' 'libmms'
 	  'libmpeg2' 'libmysqlclient' 'libsamplerate' 'libxinerama'
 	  'libxrandr' 'libxtst' 'lzo2' 'sdl_image' 'sdl_mixer'
-	  'smbclient' 'wavpack' 'mesa' 'xorg-utils' 'libmicrohttpd'
+	  'smbclient' 'wavpack' 'mesa-demos' 'xorg-utils' 'libmicrohttpd'
 	  'libssh' 'libva' 'libmodplug' 'rtmpdump')
 if [ "$_ext_python" != "disable" ]; then
   depends=( '${depends[@]}' 'python2' )
diff --git a/abs/extra/xbmc/__changelog b/abs/extra/xbmc/__changelog
deleted file mode 100644
index b2533c9..0000000
--- a/abs/extra/xbmc/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-1/2/11 - chw - change mesa-demo dep to just mesa (since we are still on 7.9).
-- 
cgit v0.12


From 45dafde3f3a20c0797d9646242df69b91d4b684d Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 18:23:24 -0800
Subject: glew:initial inclusion.

---
 abs/extra/glew/PKGBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 abs/extra/glew/PKGBUILD

diff --git a/abs/extra/glew/PKGBUILD b/abs/extra/glew/PKGBUILD
new file mode 100644
index 0000000..291abce
--- /dev/null
+++ b/abs/extra/glew/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 98297 2010-11-06 17:51:38Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: SleepyDog
+
+pkgname=glew
+pkgver=1.5.7
+pkgrel=1
+pkgdesc="The OpenGL Extension Wrangler Library"
+arch=('i686' 'x86_64')
+url="http://glew.sourceforge.net"
+license=('BSD' 'MIT' 'GPL')
+depends=('libxmu' 'libxi' 'mesa')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tgz)
+sha1sums=('4adc816afbfb65a4969484d10343a88c117ca989')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  sed -i 's|lib64|lib|' config/Makefile.linux
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make GLEW_DEST="${pkgdir}/usr" install
+  install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
-- 
cgit v0.12


From f69fa98539041de35d5fe6d90ad62da80e5bd49b Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 18:23:39 -0800
Subject: mesa-demos:initial inclusion.

---
 abs/extra/mesa-demos/LICENSE  | 82 +++++++++++++++++++++++++++++++++++++++++++
 abs/extra/mesa-demos/PKGBUILD | 30 ++++++++++++++++
 2 files changed, 112 insertions(+)
 create mode 100644 abs/extra/mesa-demos/LICENSE
 create mode 100644 abs/extra/mesa-demos/PKGBUILD

diff --git a/abs/extra/mesa-demos/LICENSE b/abs/extra/mesa-demos/LICENSE
new file mode 100644
index 0000000..ae33d27
--- /dev/null
+++ b/abs/extra/mesa-demos/LICENSE
@@ -0,0 +1,82 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components.  Different copyrights
+and licenses apply to different components.  For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors.  See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component         Location               Primary Author      License
+----------------------------------------------------------------------------
+Main Mesa code    src/mesa/              Brian Paul          Mesa (MIT)
+
+Device drivers    src/mesa/drivers/*     See drivers         See drivers
+
+Ext headers       include/GL/glext.h     SGI                 SGI Free B
+                  include/GL/glxext.h
+
+GLUT              src/glut/              Mark Kilgard        Mark's copyright
+
+Mesa GLU library  src/glu/mesa/          Brian Paul          GNU-LGPL
+
+SGI GLU library   src/glu/sgi/           SGI                 SGI Free B
+
+demo programs     progs/demos/           various             see source files
+
+X demos           progs/xdemos/          Brian Paul          see source files
+
+SGI demos         progs/samples/         SGI                 SGI copyright
+
+RedBook demos     progs/redbook/         SGI                 SGI copyright
diff --git a/abs/extra/mesa-demos/PKGBUILD b/abs/extra/mesa-demos/PKGBUILD
new file mode 100644
index 0000000..8fabad0
--- /dev/null
+++ b/abs/extra/mesa-demos/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 94667 2010-10-09 11:21:35Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=('mesa-demos')
+pkgver=8.0.1
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="Mesa demos and tools"
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+depends=('glew>=1.5.6')
+conflicts=('mesa<7.9')
+source=(ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2
+        LICENSE)
+md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
+         '5c65a0fe315dd347e09b1f2826a1df5a')
+
+build() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
+  install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
+}
-- 
cgit v0.12


From 08f45b8db181b19041b7d75e417ff5040df54922 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 3 Jan 2011 22:40:07 -0800
Subject: v4l-dvb:Latest mercurial (doesn't compile at present).

---
 abs/core/v4l-dvb/PKGBUILD   | 10 +++++-----
 abs/core/v4l-dvb/hdpvr.diff |  6 ++++--
 2 files changed, 9 insertions(+), 7 deletions(-)

diff --git a/abs/core/v4l-dvb/PKGBUILD b/abs/core/v4l-dvb/PKGBUILD
index 610472b..c5b96fc 100644
--- a/abs/core/v4l-dvb/PKGBUILD
+++ b/abs/core/v4l-dvb/PKGBUILD
@@ -2,9 +2,9 @@
 # Maintainer: Cecil Watson<knoppmyth@gmail.com>
 
 pkgname=v4l-dvb
-_kernver=2.6.28-LinHES
+_kernver=2.6.36-LinHES
 pkgver=1
-pkgrel=17
+pkgrel=18
 pkgdesc="V4L-DVB drivers from mercurial"
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -16,7 +16,7 @@ source=('http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.gz' 'hdpvr.diff')
 
 build() {
   cd $startdir/src/v4l-dvb*/
-#  patch -p1 < ../hdpvr.diff
+  patch -p1 < ../hdpvr.diff
   make KERNDIR=/lib/modules/$_kernver/build \
   DESTDIR=$startdir/pkg KERNELRELEASE=$_kernver all || return 1
   make KERNDIR=/lib/modules/$_kernver/build \
@@ -24,5 +24,5 @@ build() {
   rm -fr $startdir/pkg/lib/modules/$_kernver/modules*
 }
 
-md5sums=('e0c4eb1f436d44118e0bf0757516310c'
-         'd50c96211d23fba48ebc4c5e2d1e6102')
+md5sums=('d2631ec2051bb00bc3f379f35b002450'
+         '336b14da668a7b79d55624a769b28f63')
diff --git a/abs/core/v4l-dvb/hdpvr.diff b/abs/core/v4l-dvb/hdpvr.diff
index bf465e5..257ce05 100644
--- a/abs/core/v4l-dvb/hdpvr.diff
+++ b/abs/core/v4l-dvb/hdpvr.diff
@@ -5,7 +5,8 @@ diff -ruaN v4l-dvb-31eaa9423f98.orig/linux/drivers/media/video/hdpvr/hdpvr-core.
  	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID) },
  	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID1) },
  	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID2) },
-+	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID3) },
+	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID3) },
++	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID4) },
  	{ }					/* Terminating entry */
  };
  MODULE_DEVICE_TABLE(usb, hdpvr_table);
@@ -16,7 +17,8 @@ diff -ruaN v4l-dvb-31eaa9423f98.orig/linux/drivers/media/video/hdpvr/hdpvr.h v4l
  #define HD_PVR_PRODUCT_ID	0x4900
  #define HD_PVR_PRODUCT_ID1	0x4901
  #define HD_PVR_PRODUCT_ID2	0x4902
-+#define HD_PVR_PRODUCT_ID3	0x4982
+ #define HD_PVR_PRODUCT_ID3	0x4982
++#define HD_PVR_PRODUCT_ID4	0x4903
  
  #define UNSET    (-1U)
  
-- 
cgit v0.12


From 7c860c250fff97bb77088a70dc53478a44a24f05 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 4 Jan 2011 00:35:55 -0800
Subject: kernel26:Updated to latest.  Fixes muted audio w/ PVR 2/350.  Added
 patch for all known HDPVRs and fbcondecor.

---
 abs/core/kernel26/PKGBUILD      | 22 ++++++++++++----------
 abs/core/kernel26/config        | 14 ++++++--------
 abs/core/kernel26/config.x86_64 | 16 +++++++---------
 abs/core/kernel26/hdpvr.patch   | 24 ++++++++++++++++++++++++
 4 files changed, 49 insertions(+), 27 deletions(-)
 create mode 100644 abs/core/kernel26/hdpvr.patch

diff --git a/abs/core/kernel26/PKGBUILD b/abs/core/kernel26/PKGBUILD
index 69cb6af..4b96810 100644
--- a/abs/core/kernel26/PKGBUILD
+++ b/abs/core/kernel26/PKGBUILD
@@ -6,31 +6,31 @@ pkgname=('kernel26' 'kernel26-headers' 'kernel26-docs') # Build stock -ARCH kern
 #pkgname=kernel26-LINHES       # Build kernel with a different name
 _kernelname=${pkgname#kernel26}
 _basekernel=2.6.36
-pkgver=${_basekernel}
-pkgrel=3
+pkgver=${_basekernel}.2
+pkgrel=1
 makedepends=('xmlto' 'docbook-xsl')
 _patchname="patch-${pkgver}-${pkgrel}-ARCH"
 #_patchname="patch-${pkgver}-1-ARCH"
+_fbpatchname="fbcondecor-0.9.6-2.6.36-rc8.patch"
 arch=(i686 x86_64)
 license=('GPL2')
 url="http://www.kernel.org"
 source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
         ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
+	http://dev.gentoo.org/~spock/projects/fbcondecor/archive/${_fbpatchname}
+	hdpvr.patch
         # the main kernel config files
         config config.x86_64
         # standard config files for mkinitcpio ramdisk
         kernel26.preset)
-md5sums=('61f3739a73afb6914cb007f37fb09b62'
-         '5b3c66f93c0de79aacd986a545f863b6'
-         '1ed53b9b64b8889563502177b0b428b5'
-         '89ba24b9c346a930378ca22cf377c75f'
-         '25584700a0a679542929c4bed31433b6')
 
 build() {
   cd ${srcdir}/linux-$_basekernel
   # Add -ARCH patches
   # See http://projects.archlinux.org/linux-2.6-ARCH.git/
   patch -Np1 -i ${srcdir}/${_patchname}
+  patch -Np1 -i ${srcdir}/${_fbpatchname}
+  patch -Np1 -i ${srcdir}/hdpvr.patch
 
   if [ "$CARCH" = "x86_64" ]; then
     cat ../config.x86_64 >./.config
@@ -237,7 +237,9 @@ find $pkgdir -type d -exec chmod 755 {} \;
 rm -f $pkgdir/usr/src/linux-$_kernver/Documentation/DocBook/Makefile
 }
 md5sums=('61f3739a73afb6914cb007f37fb09b62'
-         '5b3c66f93c0de79aacd986a545f863b6'
-         'ccfe0d9145188eaee4aa956e01fb92f7'
-         '89ba24b9c346a930378ca22cf377c75f'
+         '998b597b8659f1ac2667bbc13d1905b8'
+         'c361ff66dcf4bb0efaa1e653e6604402'
+         '46ba5b98c1a830dc0e7a2efa2c1fae42'
+         'b13742601ad3842a977eb661ff7a7bc8'
+         'c171acbcff1c013c5c9bafbe1531bd3b'
          '25584700a0a679542929c4bed31433b6')
diff --git a/abs/core/kernel26/config b/abs/core/kernel26/config
index dfbf378..3f27252 100644
--- a/abs/core/kernel26/config
+++ b/abs/core/kernel26/config
@@ -3563,11 +3563,11 @@ CONFIG_FB_SYS_IMAGEBLIT=m
 # CONFIG_FB_FOREIGN_ENDIAN is not set
 CONFIG_FB_SYS_FOPS=m
 CONFIG_FB_DEFERRED_IO=y
-CONFIG_FB_SVGALIB=m
+# CONFIG_FB_SVGALIB is not set
 # CONFIG_FB_MACMODES is not set
 CONFIG_FB_BACKLIGHT=y
 CONFIG_FB_MODE_HELPERS=y
-CONFIG_FB_TILEBLITTING=y
+# CONFIG_FB_TILEBLITTING is not set
 
 #
 # Frame buffer hardware drivers
@@ -3610,7 +3610,7 @@ CONFIG_FB_ATY_CT=y
 CONFIG_FB_ATY_GENERIC_LCD=y
 CONFIG_FB_ATY_GX=y
 CONFIG_FB_ATY_BACKLIGHT=y
-CONFIG_FB_S3=m
+# CONFIG_FB_S3 is not set
 CONFIG_FB_SAVAGE=m
 CONFIG_FB_SAVAGE_I2C=y
 CONFIG_FB_SAVAGE_ACCEL=y
@@ -3625,7 +3625,7 @@ CONFIG_FB_3DFX=m
 CONFIG_FB_3DFX_ACCEL=y
 CONFIG_FB_3DFX_I2C=y
 CONFIG_FB_VOODOO1=m
-CONFIG_FB_VT8623=m
+# CONFIG_FB_VT8623 is not set
 CONFIG_FB_TRIDENT=m
 # CONFIG_FB_ARK is not set
 # CONFIG_FB_PM3 is not set
@@ -3675,6 +3675,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_FRAMEBUFFER_CONSOLE=y
 # CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY is not set
 CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y
+CONFIG_FB_CON_DECOR=y
 CONFIG_FONTS=y
 # CONFIG_FONT_8x8 is not set
 CONFIG_FONT_8x16=y
@@ -3686,10 +3687,7 @@ CONFIG_FONT_8x16=y
 # CONFIG_FONT_SUN8x16 is not set
 # CONFIG_FONT_SUN12x22 is not set
 # CONFIG_FONT_10x18 is not set
-CONFIG_LOGO=y
-CONFIG_LOGO_LINUX_MONO=y
-CONFIG_LOGO_LINUX_VGA16=y
-CONFIG_LOGO_LINUX_CLUT224=y
+# CONFIG_LOGO is not set
 CONFIG_SOUND=m
 CONFIG_SOUND_OSS_CORE=y
 # CONFIG_SOUND_OSS_CORE_PRECLAIM is not set
diff --git a/abs/core/kernel26/config.x86_64 b/abs/core/kernel26/config.x86_64
index a756fe2..53981bd 100644
--- a/abs/core/kernel26/config.x86_64
+++ b/abs/core/kernel26/config.x86_64
@@ -70,7 +70,7 @@ CONFIG_EXPERIMENTAL=y
 CONFIG_LOCK_KERNEL=y
 CONFIG_INIT_ENV_ARG_LIMIT=32
 CONFIG_CROSS_COMPILE=""
-CONFIG_LOCALVERSION="-ARCH"
+CONFIG_LOCALVERSION="-LinHES"
 CONFIG_LOCALVERSION_AUTO=y
 CONFIG_HAVE_KERNEL_GZIP=y
 CONFIG_HAVE_KERNEL_BZIP2=y
@@ -3384,11 +3384,11 @@ CONFIG_FB_SYS_IMAGEBLIT=m
 # CONFIG_FB_FOREIGN_ENDIAN is not set
 CONFIG_FB_SYS_FOPS=m
 CONFIG_FB_DEFERRED_IO=y
-CONFIG_FB_SVGALIB=m
+# CONFIG_FB_SVGALIB is not set
 # CONFIG_FB_MACMODES is not set
 CONFIG_FB_BACKLIGHT=y
 CONFIG_FB_MODE_HELPERS=y
-CONFIG_FB_TILEBLITTING=y
+# CONFIG_FB_TILEBLITTING is not set
 
 #
 # Frame buffer hardware drivers
@@ -3429,7 +3429,7 @@ CONFIG_FB_ATY_CT=y
 CONFIG_FB_ATY_GENERIC_LCD=y
 CONFIG_FB_ATY_GX=y
 CONFIG_FB_ATY_BACKLIGHT=y
-CONFIG_FB_S3=m
+# CONFIG_FB_S3 is not set
 CONFIG_FB_SAVAGE=m
 CONFIG_FB_SAVAGE_I2C=y
 CONFIG_FB_SAVAGE_ACCEL=y
@@ -3444,7 +3444,7 @@ CONFIG_FB_3DFX=m
 CONFIG_FB_3DFX_ACCEL=y
 CONFIG_FB_3DFX_I2C=y
 CONFIG_FB_VOODOO1=m
-CONFIG_FB_VT8623=m
+# CONFIG_FB_VT8623 is not set
 CONFIG_FB_TRIDENT=m
 # CONFIG_FB_ARK is not set
 # CONFIG_FB_PM3 is not set
@@ -3494,6 +3494,7 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_FRAMEBUFFER_CONSOLE=y
 # CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY is not set
 CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y
+CONFIG_FB_CON_DECOR=y
 CONFIG_FONTS=y
 # CONFIG_FONT_8x8 is not set
 CONFIG_FONT_8x16=y
@@ -3505,10 +3506,7 @@ CONFIG_FONT_8x16=y
 # CONFIG_FONT_SUN8x16 is not set
 # CONFIG_FONT_SUN12x22 is not set
 # CONFIG_FONT_10x18 is not set
-CONFIG_LOGO=y
-CONFIG_LOGO_LINUX_MONO=y
-CONFIG_LOGO_LINUX_VGA16=y
-CONFIG_LOGO_LINUX_CLUT224=y
+# CONFIG_LOGO is not set
 CONFIG_SOUND=m
 CONFIG_SOUND_OSS_CORE=y
 # CONFIG_SOUND_OSS_CORE_PRECLAIM is not set
diff --git a/abs/core/kernel26/hdpvr.patch b/abs/core/kernel26/hdpvr.patch
new file mode 100644
index 0000000..5de88ab
--- /dev/null
+++ b/abs/core/kernel26/hdpvr.patch
@@ -0,0 +1,24 @@
+diff -ruaN linux-2.6.36.orig/drivers/media/video/hdpvr/hdpvr-core.c linux-2.6.36/drivers/media/video/hdpvr/hdpvr-core.c
+--- linux-2.6.36.orig/drivers/media/video/hdpvr/hdpvr-core.c	2010-10-20 20:30:22.000000000 +0000
++++ linux-2.6.36/drivers/media/video/hdpvr/hdpvr-core.c	2011-01-04 06:34:52.000000000 +0000
+@@ -60,6 +60,7 @@
+ 	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID1) },
+ 	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID2) },
+ 	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID3) },
++	{ USB_DEVICE(HD_PVR_VENDOR_ID, HD_PVR_PRODUCT_ID4) },
+ 	{ }					/* Terminating entry */
+ };
+ MODULE_DEVICE_TABLE(usb, hdpvr_table);
+diff -ruaN linux-2.6.36.orig/drivers/media/video/hdpvr/hdpvr.h linux-2.6.36/drivers/media/video/hdpvr/hdpvr.h
+--- linux-2.6.36.orig/drivers/media/video/hdpvr/hdpvr.h	2010-10-20 20:30:22.000000000 +0000
++++ linux-2.6.36/drivers/media/video/hdpvr/hdpvr.h	2011-01-04 06:35:14.000000000 +0000
+@@ -30,7 +30,8 @@
+ #define HD_PVR_PRODUCT_ID	0x4900
+ #define HD_PVR_PRODUCT_ID1	0x4901
+ #define HD_PVR_PRODUCT_ID2	0x4902
+-#define HD_PVR_PRODUCT_ID3	0x4982
++#define HD_PVR_PRODUCT_ID3	0x4903
++#define HD_PVR_PRODUCT_ID4	0x4982
+ 
+ #define UNSET    (-1U)
+ 
-- 
cgit v0.12


From a776204c62a2c0711e9834492bdd5d37a1104cc3 Mon Sep 17 00:00:00 2001
From: James Meyer <jams@linhes.org>
Date: Wed, 5 Jan 2011 15:59:13 +0000
Subject: mesa-demos: remove extra copy

---
 abs/extra/mesa-demos/LICENSE  | 82 -------------------------------------------
 abs/extra/mesa-demos/PKGBUILD | 30 ----------------
 2 files changed, 112 deletions(-)
 delete mode 100644 abs/extra/mesa-demos/LICENSE
 delete mode 100644 abs/extra/mesa-demos/PKGBUILD

diff --git a/abs/extra/mesa-demos/LICENSE b/abs/extra/mesa-demos/LICENSE
deleted file mode 100644
index ae33d27..0000000
--- a/abs/extra/mesa-demos/LICENSE
+++ /dev/null
@@ -1,82 +0,0 @@
-Disclaimer
-
-Mesa is a 3-D graphics library with an API which is very similar to
-that of OpenGL*
-To the extent that Mesa utilizes the OpenGL command syntax or state
-machine, it is being used with authorization from Silicon Graphics,
-Inc.(SGI). However, the author does not possess an OpenGL license
-from SGI, and makes no claim that Mesa is in any way a compatible
-replacement for OpenGL or associated with SGI. Those who want a
-licensed implementation of OpenGL should contact a licensed
-vendor.
-
-Please do not refer to the library as MesaGL (for legal
-reasons). It's just Mesa or The Mesa 3-D graphics
-library
-
-* OpenGL is a trademark of Silicon Graphics Incorporated.
-
-License / Copyright Information
-
-The Mesa distribution consists of several components.  Different copyrights
-and licenses apply to different components.  For example, GLUT is copyrighted
-by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
-device drivers are copyrighted by their authors.  See below for a list of
-Mesa's main components and the license for each.
-
-The core Mesa library is licensed according to the terms of the MIT license.
-This allows integration with the XFree86, Xorg and DRI projects.
-
-The default Mesa license is as follows:
-
-Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.
-
-Permission is hereby granted, free of charge, to any person obtaining a
-copy of this software and associated documentation files (the "Software"),
-to deal in the Software without restriction, including without limitation
-the rights to use, copy, modify, merge, publish, distribute, sublicense,
-and/or sell copies of the Software, and to permit persons to whom the
-Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included
-in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
-OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
-BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
-AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
-CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-Attention, Contributors
-
-When contributing to the Mesa project you must agree to the licensing terms
-of the component to which you're contributing.
-The following section lists the primary components of the Mesa distribution
-and their respective licenses.
-
-
-Mesa Component Licenses
-
-Component         Location               Primary Author      License
-----------------------------------------------------------------------------
-Main Mesa code    src/mesa/              Brian Paul          Mesa (MIT)
-
-Device drivers    src/mesa/drivers/*     See drivers         See drivers
-
-Ext headers       include/GL/glext.h     SGI                 SGI Free B
-                  include/GL/glxext.h
-
-GLUT              src/glut/              Mark Kilgard        Mark's copyright
-
-Mesa GLU library  src/glu/mesa/          Brian Paul          GNU-LGPL
-
-SGI GLU library   src/glu/sgi/           SGI                 SGI Free B
-
-demo programs     progs/demos/           various             see source files
-
-X demos           progs/xdemos/          Brian Paul          see source files
-
-SGI demos         progs/samples/         SGI                 SGI copyright
-
-RedBook demos     progs/redbook/         SGI                 SGI copyright
diff --git a/abs/extra/mesa-demos/PKGBUILD b/abs/extra/mesa-demos/PKGBUILD
deleted file mode 100644
index 8fabad0..0000000
--- a/abs/extra/mesa-demos/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id: PKGBUILD 94667 2010-10-09 11:21:35Z andyrtr $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-
-pkgname=('mesa-demos')
-pkgver=8.0.1
-pkgrel=1
-arch=(i686 x86_64)
-pkgdesc="Mesa demos and tools"
-url="http://mesa3d.sourceforge.net"
-license=('custom')
-depends=('glew>=1.5.6')
-conflicts=('mesa<7.9')
-source=(ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2
-        LICENSE)
-md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
-         '5c65a0fe315dd347e09b1f2826a1df5a')
-
-build() {
-  cd "${srcdir}/mesa-demos-${pkgver}"
-  ./configure --prefix=/usr
-  make
-}
-
-package() {
-  cd "${srcdir}/mesa-demos-${pkgver}"
-  make DESTDIR="${pkgdir}" install
-  install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
-  install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
-}
-- 
cgit v0.12


From 11e85b2f03ba217fe01d17763bb6832c536d768a Mon Sep 17 00:00:00 2001
From: James Meyer <jams@linhes.org>
Date: Wed, 5 Jan 2011 15:59:59 +0000
Subject: mesa-demos: added for xbmc This includes the patch to avoid having
 the name conflict with line and clear.

---
 abs/core/mesa-demos/PKGBUILD    | 2 ++
 abs/core/mesa-demos/__changelog | 4 ++++
 2 files changed, 6 insertions(+)
 create mode 100644 abs/core/mesa-demos/__changelog

diff --git a/abs/core/mesa-demos/PKGBUILD b/abs/core/mesa-demos/PKGBUILD
index 2f71ce6..8476db5 100644
--- a/abs/core/mesa-demos/PKGBUILD
+++ b/abs/core/mesa-demos/PKGBUILD
@@ -25,6 +25,8 @@ package() {
   make DESTDIR="${pkgdir}" install
   install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
   install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
+  mv ${pkgdir}/usr/bin/clear ${pkgdir}/usr/bin/glxclear
+  mv ${pkgdir}/usr/bin/line ${pkgdir}/usr/bin/glxline
 }
 
 md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
diff --git a/abs/core/mesa-demos/__changelog b/abs/core/mesa-demos/__changelog
new file mode 100644
index 0000000..7b2e5a6
--- /dev/null
+++ b/abs/core/mesa-demos/__changelog
@@ -0,0 +1,4 @@
+--renamed conflicting files
+  mv ${pkgdir}/usr/bin/clear ${pkgdir}/usr/bin/glxclear
+  mv ${pkgdir}/usr/bin/line ${pkgdir}/usr/bin/glxline
+
-- 
cgit v0.12