From 42b8b3173f9d29f42b77b5a63336b3cb22a9852f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 9 Mar 2012 18:17:16 -0600
Subject: LinHES-config: mv_ir.py: add remote.run for specific remote starting
 commands. refs #821

---
 abs/core/LinHES-config/PKGBUILD |  4 ++--
 abs/core/LinHES-config/mv_ir.py | 24 +++++++++++++++++++++---
 2 files changed, 23 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 1c26f9b..0c51ef0 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=61
+pkgrel=62
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -125,7 +125,7 @@ md5sums=('64fad755c12f8eb12940e216e403354e'
          '5f3259afe031fda189edae41dd1458f0'
          'dc150c1e2c915a55a616d1af5bb1f6de'
          'b845de3e05c1734cce4b9ac5e8f1baaf'
-         '8f58093cc2bbf92c95e54090cf243117'
+         'e7b94023461c52a692bfa67c647deedd'
          '5e69839659d65ddda35b8a9982dc29e9'
          '62b4ce94277c32f525db5c1480670acd'
          'ec6a9961e4d1b53ec1240c5979efff11'
diff --git a/abs/core/LinHES-config/mv_ir.py b/abs/core/LinHES-config/mv_ir.py
index 0e54f92..a4c3bed 100755
--- a/abs/core/LinHES-config/mv_ir.py
+++ b/abs/core/LinHES-config/mv_ir.py
@@ -44,7 +44,7 @@ def setup_lirc_links(mythhome):
         else:
             logging.debug("    %s/.lircrc already present",mythhome)
     else:
-        logging.debug("    /etc/lircrc does not exisit, can not link it")
+        logging.debug("    /etc/lircrc does not exist, can not link it")
 
 def scrub_modules(filename,module):
     logging.debug("    scrubbing %s from %s",module,filename)
@@ -92,6 +92,8 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
         mv_common.runcmd(cmd)
         cmd = "mv /etc/lircrc /etc/lircrc-%s" %currenttime
         mv_common.runcmd(cmd)
+        cmd = "mv /etc/remote.run /etc/remote.run-%s" %currenttime
+        mv_common.runcmd(cmd)
 
 
         if os.path.isdir(mythhome+"/remotes/"+Remotetype):
@@ -113,6 +115,14 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
                     logging.debug("    %s is a dir, skipping",filename)
                     continue
                 include_file("/etc/lircrc",filename)
+            files = mythhome + "/remotes/" + Remotetype + "/remote.run*"
+            logging.debug("    Using %s",files)
+            for filename in glob.glob(files):
+                # Ignore subfolders
+                if os.path.isdir (filename):
+                    logging.debug("    %s is a dir, skipping",filename)
+                    continue
+                include_file("/etc/remote.run",filename)
         else:
             #template dir
             files = templates + "/remotes/" + Remotetype + "/lircd*"
@@ -131,9 +141,17 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
                     logging.debug("    %s is a dir, skipping",filename)
                     continue
                 include_file("/etc/lircrc",filename)
+            files = templates + "/remotes/" + Remotetype + "/remote.run*"
+            logging.debug("    Using %s",files)
+            for filename in glob.glob(files):
+                # Ignore subfolders
+                if os.path.isdir (filename):
+                    logging.debug("    %s is a dir, skipping",filename)
+                    continue
+                include_file("/etc/remote.run",filename)
 
 
-        cmd =  "chmod 755 /etc/lircrc"
+        cmd =  "chmod 755 /etc/lircrc /etc/remote.run"
         mv_common.runcmd(cmd)
         mv_common.add_service("lircd")
 
@@ -365,4 +383,4 @@ def setup_ir(systemconfig, data_config):
     else:
         logging.debug("    LCD not defined")
     logging.info("__End IR\n")
-    return rc
\ No newline at end of file
+    return rc
-- 
cgit v0.12