From e72be4a2132baf7ae7ef3116a0ab2247a93bd0d0 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 16 Mar 2017 13:26:10 +0000
Subject: mythtv & mythplugins: update to latest fixes

mythtv: move string changes to en_us translation so as not to affect other languages
---
 abs/core/mythtv/stable-0.28/git_src/git_hash       |   2 +-
 abs/core/mythtv/stable-0.28/mythplugins/PKGBUILD   |   2 +-
 abs/core/mythtv/stable-0.28/mythtv/PKGBUILD        |  17 +-
 .../mythtv/autoskip_reduce_commskip_jumpback.patch |  58 +---
 .../stable-0.28/mythtv/change_msg_types.patch      |  59 +---
 .../mythtv/mythfrontend_en_us.ts_Title_Case.patch  | 374 +++++++++++++++++++++
 .../stable-0.28/mythtv/tv.cpp_fix_caps.patch       |  13 -
 7 files changed, 396 insertions(+), 129 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.28/mythtv/mythfrontend_en_us.ts_Title_Case.patch
 delete mode 100644 abs/core/mythtv/stable-0.28/mythtv/tv.cpp_fix_caps.patch

diff --git a/abs/core/mythtv/stable-0.28/git_src/git_hash b/abs/core/mythtv/stable-0.28/git_src/git_hash
index d5f2f62..a6dbc61 100644
--- a/abs/core/mythtv/stable-0.28/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.28/git_src/git_hash
@@ -1 +1 @@
-299dbaee22795d09503f028670f8bbc891c42c5b
+044b22b95734ee607806ff8cea04e84c5112438d
diff --git a/abs/core/mythtv/stable-0.28/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.28/mythplugins/PKGBUILD
index f6d8e73..226088a 100644
--- a/abs/core/mythtv/stable-0.28/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.28/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=0.28.1
-pkgrel=2
+pkgrel=3
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
diff --git a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
index 77ce196..d98a045 100644
--- a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.28.1
-pkgrel=2
+pkgrel=3
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ depends=('avahi' 'exiv2' 'faad2' 'fftw' 'glew' 'lame' 'libass' 'libavc1394' 'lib
          'perl-net-upnp' 'perl-soap-lite' 'perl-xml-sax' 'python2-pycurl'
          'python2-lxml' 'qt5-script' 'qt5-webkit' 'sdl' 'taglib' 'urlgrabber' 'wget'
          'xmltv')
-makedepends=('mesa' 'mesa-libgl' 'yasm' 'x264' 'git' 'rsync')
+makedepends=('mesa' 'mesa-libgl' 'yasm' 'x264' 'git' 'rsync' 'qt5-tools')
 replaces=()
 groups=('pvr')
 backup=()
@@ -28,10 +28,10 @@ patches=(
          'change_msg_types.patch'
          'disable_mythnotification_tuner_failure.patch'
          'disable_subtitle_cutdown_in_recording_options.patch'
-         'tv.cpp_fix_caps.patch'
          'searchMetatdataSelectedGrabber.patch'
          'addDamagedToProgDetails.patch'
          'defaultThemeLinHES.patch'
+         'mythfrontend_en_us.ts_Title_Case.patch'
          )
 
 optdepends=()
@@ -59,6 +59,11 @@ build() {
     done
     msg "--------------------------done applying patches-------------------------"
 
+    msg "Updating translations"
+    cd ${srcdir}/$pkgname/i18n
+    lrelease -removeidentical translate.pro
+    cd ${srcdir}/$pkgname
+
     msg "Configuring mythtv"
     ARCH=${CARCH/_/-}
     #disable mythlogserver due to http://code.mythtv.org/trac/ticket/11230
@@ -110,12 +115,12 @@ package() {
 
 md5sums=('e30b482dcd5f3e71c6419fd753bab2b1'
          '41098e898361a5a3cde3eaae358482a8'
-         '0bf5e92c0609a7eda8f253bf2e032590'
-         'f8a56ac814722b110dc9859169b9bda9'
+         '2f983590a8a3cf81f386cc65b9628e13'
+         'f764758832f8e9068ffda1ac0c8aacba'
          '1cd668136deea20efb79cf3e6310effc'
          '3420d15014274b5bf8083355af71304b'
-         '62c42b1043ebf65959fa9eced9ca3ed8'
          '0f674b9cad031ba1e03aaf6b5ee1499f'
          '6add9c16bbb988067e82029327e567b2'
          '6f916ebc2b1d0ca75c9aa6cec62c6fbb'
+         '1ea2f3bb6805ae733a6d8a36f7f7c860'
          'e73bb7c5036e44a68b6f6aa2f1bac077')
diff --git a/abs/core/mythtv/stable-0.28/mythtv/autoskip_reduce_commskip_jumpback.patch b/abs/core/mythtv/stable-0.28/mythtv/autoskip_reduce_commskip_jumpback.patch
index b1c90ed..b6815ef 100644
--- a/abs/core/mythtv/stable-0.28/mythtv/autoskip_reduce_commskip_jumpback.patch
+++ b/abs/core/mythtv/stable-0.28/mythtv/autoskip_reduce_commskip_jumpback.patch
@@ -1,61 +1,13 @@
---- src/mythtv/libs/libmythtv/commbreakmap.cpp	2016-04-08 13:35:22.657983969 +0000
-+++ src/mythtv/libs/libmythtv/commbreakmap.cpp	2016-04-13 21:42:51.461959071 +0000
-@@ -233,7 +233,7 @@
-     if (kCommSkipOn == autocommercialskip)
+--- src/mythtv/libs/libmythtv/commbreakmap.cpp.orig	2017-03-15 20:34:21.722746111 +0000
++++ src/mythtv/libs/libmythtv/commbreakmap.cpp	2017-03-15 20:35:21.531732684 +0000
+@@ -271,8 +271,8 @@
      {
-         //: %1 is the skip time
--        comm_msg = tr("Skip %1").arg(skipTime);
-+        comm_msg = tr("Skip Commercial: %1").arg(skipTime);
-     }
-     else
-     {
-@@ -269,10 +269,9 @@
-     if ((skipcommercials == (0 - lastCommSkipDirection)) &&
-         ((time(NULL) - lastCommSkipTime) <= 5))
-     {
--        comm_msg = tr("Skipping Back.");
--
+         comm_msg = tr("Skipping Back.");
+ 
 -        if (lastCommSkipStart > (2.0 * video_frame_rate))
 -            lastCommSkipStart -= (long long) (2.0 * video_frame_rate);
-+        comm_msg = tr("Skipping Back");
 +        if (lastCommSkipStart > (video_frame_rate))
 +            lastCommSkipStart -= (long) (video_frame_rate);
          lastCommSkipDirection = 0;
          lastCommSkipTime = time(NULL);
          jumpToFrame = lastCommSkipStart;
-@@ -287,7 +286,7 @@
-     if ((commBreakIter == commBreakMap.begin()) &&
-         (skipcommercials < 0))
-     {
--        comm_msg = tr("Start of program.");
-+        comm_msg = tr("Start of Program");
-         jumpToFrame = 0;
-         return true;
-     }
-@@ -297,7 +296,7 @@
-          ((totalFrames) &&
-           ((commBreakIter.key() + (10 * video_frame_rate)) > totalFrames))))
-     {
--        comm_msg = tr("At End, cannot Skip.");
-+        comm_msg = tr("At End, Cannot Skip");
-         return false;
-     }
- 
-@@ -313,7 +312,7 @@
-         {
-             if (commBreakIter == commBreakMap.begin())
-             {
--                comm_msg = tr("Start of program.");
-+                comm_msg = tr("Start of Program");
-                 jumpToFrame = 0;
-                 return true;
-             }
-@@ -341,7 +340,7 @@
-                  ((commBreakIter.key() + (10 * video_frame_rate)) >
-                                                                 totalFrames)))
-             {
--                comm_msg = tr("At End, cannot Skip.");
-+                comm_msg = tr("At End, Cannot Skip");
-                 return false;
-             }
-         }
diff --git a/abs/core/mythtv/stable-0.28/mythtv/change_msg_types.patch b/abs/core/mythtv/stable-0.28/mythtv/change_msg_types.patch
index 5db23c9..029dd9a 100644
--- a/abs/core/mythtv/stable-0.28/mythtv/change_msg_types.patch
+++ b/abs/core/mythtv/stable-0.28/mythtv/change_msg_types.patch
@@ -1,37 +1,6 @@
---- src/mythtv/libs/libmythtv/tv_play.cpp.orig	2016-04-12 21:18:14.577336824 +0000
-+++ src/mythtv/libs/libmythtv/tv_play.cpp	2016-04-14 20:18:44.680018060 +0000
-@@ -10905,7 +10905,7 @@
-     else if (action == ACTION_TOGGLEOSDDEBUG)
-         ToggleOSDDebug(actx);
-     else if (action == "TOGGLEMANUALZOOM")
--        SetManualZoom(actx, true, tr("Zoom Mode ON"));
-+        SetManualZoom(actx, true, tr("Zoom Mode On"));
-     else if (action == "TOGGLESTRETCH")
-         ToggleTimeStretch(actx);
-     else if (action == ACTION_ENABLEUPMIX)
-@@ -12228,7 +12228,7 @@
-             {
-                 active = m_tvm_is_on;
-                 BUTTON2(actionName,
--                        tr("Turn Auto-Expire OFF"), tr("Turn Auto-Expire ON"));
-+                        tr("Turn Auto-Expire Off"), tr("Turn Auto-Expire On"));
-             }
-         }
-         else if (actionName == "QUEUETRANSCODE")
-@@ -12705,18 +12705,18 @@
-     if (ctx->playingInfo->QueryAutoExpire() != kDisableAutoExpire)
-     {
-         ctx->playingInfo->SaveAutoExpire(kDisableAutoExpire);
--        desc = tr("Auto-Expire OFF");
-+        desc = tr("Auto-Expire Off");
-     }
-     else
-     {
-         ctx->playingInfo->SaveAutoExpire(kNormalAutoExpire);
--        desc = tr("Auto-Expire ON");
-+        desc = tr("Auto-Expire On");
-     }
- 
+--- src/mythtv/libs/libmythtv/tv_play.cpp.orig	2017-03-15 20:27:51.672833870 +0000
++++ src/mythtv/libs/libmythtv/tv_play.cpp	2017-03-15 20:29:10.646025774 +0000
+@@ -12714,7 +12714,7 @@
      ctx->UnlockPlayingInfo(__FILE__, __LINE__);
  
      if (!desc.isEmpty())
@@ -40,7 +9,7 @@
  }
  
  void TV::SetAutoCommercialSkip(const PlayerContext *ctx,
-@@ -12733,7 +12733,7 @@
+@@ -12731,7 +12731,7 @@
      ctx->UnlockDeletePlayer(__FILE__, __LINE__);
  
      if (!desc.isEmpty())
@@ -49,23 +18,3 @@
  }
  
  void TV::SetManualZoom(const PlayerContext *ctx, bool zoomON, QString desc)
---- ../git_src/mythtv/mythtv/libs/libmythtv/mythplayer.cpp	2016-04-12 21:18:14.574003917 +0000
-+++ src/mythtv/libs/libmythtv/mythplayer.cpp	2016-04-14 20:05:49.146211278 +0000
-@@ -4267,7 +4267,7 @@
-         else if (action == ACTION_SELECT)
-         {
-             deleteMap.NewCut(frame);
--            SetOSDMessage(tr("New cut added."), kOSDTimeout_Short);
-+            SetOSDMessage(tr("New Cut Added"), kOSDTimeout_Short);
-             refresh = true;
-         }
-         else if (action == "DELETE")
-@@ -4303,7 +4303,7 @@
-             if (handled && (action == "CUTTOBEGINNING" ||
-                 action == "CUTTOEND" || action == "NEWCUT"))
-             {
--                SetOSDMessage(tr("New cut added."), kOSDTimeout_Short);
-+                SetOSDMessage(tr("New Cut Added"), kOSDTimeout_Short);
-             }
-             else if (handled && action == "UNDO")
-             {
diff --git a/abs/core/mythtv/stable-0.28/mythtv/mythfrontend_en_us.ts_Title_Case.patch b/abs/core/mythtv/stable-0.28/mythtv/mythfrontend_en_us.ts_Title_Case.patch
new file mode 100644
index 0000000..0c92b5a
--- /dev/null
+++ b/abs/core/mythtv/stable-0.28/mythtv/mythfrontend_en_us.ts_Title_Case.patch
@@ -0,0 +1,374 @@
+--- src/mythtv/i18n/mythfrontend_en_us.ts.orig	2017-03-15 19:27:04.165403020 +0000
++++ src/mythtv/i18n/mythfrontend_en_us.ts	2017-03-15 21:02:58.588551407 +0000
+@@ -3349,12 +3349,12 @@
+     <message>
+         <location filename="../programs/mythfrontend/main.cpp" line="206"/>
+         <source>Play from bookmark</source>
+-        <translation>Play from bookmark</translation>
++        <translation>Play from Bookmark</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/main.cpp" line="207"/>
+         <source>Play from beginning</source>
+-        <translation>Play from beginning</translation>
++        <translation>Play from Beginning</translation>
+     </message>
+ </context>
+ <context>
+@@ -3388,14 +3388,14 @@
+         <location filename="../libs/libmythtv/videosource.cpp" line="3817"/>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3852"/>
+         <source>Yes, delete capture cards</source>
+-        <translation>Yes, delete capture cards</translation>
++        <translation>Yes, Delete Capture Cards</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3818"/>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3853"/>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3876"/>
+         <source>No, don&apos;t</source>
+-        <translation>No, don&apos;t</translation>
++        <translation>No, Keep</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3834"/>
+@@ -3420,7 +3420,7 @@
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3875"/>
+         <source>Yes, delete capture card</source>
+-        <translation>Yes, delete capture card</translation>
++        <translation>Yes, Delete Capture Card</translation>
+     </message>
+ </context>
+ <context>
+@@ -3674,12 +3674,12 @@
+     <message>
+         <location filename="../libs/libmythtv/channelgroupsettings.cpp" line="186"/>
+         <source>Yes, delete group</source>
+-        <translation>Yes, delete group</translation>
++        <translation>Yes, Delete Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/channelgroupsettings.cpp" line="187"/>
+         <source>No, Don&apos;t delete group</source>
+-        <translation>No, Don&apos;t delete group</translation>
++        <translation>No, Keep Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/channelgroupsettings.cpp" line="239"/>
+@@ -4116,7 +4116,7 @@
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="368"/>
+         <source>Skip %1</source>
+         <extracomment>%1 is the skip time</extracomment>
+-        <translation>Skip %1</translation>
++        <translation>Skip Commercial %1</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="241"/>
+@@ -4127,19 +4127,19 @@
+     <message>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="272"/>
+         <source>Skipping Back.</source>
+-        <translation>Skipping Back.</translation>
++        <translation>Skipping Back</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="290"/>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="316"/>
+         <source>Start of program.</source>
+-        <translation>Start of program.</translation>
++        <translation>Start of Program</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="300"/>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="344"/>
+         <source>At End, cannot Skip.</source>
+-        <translation>At End, cannot Skip.</translation>
++        <translation>At End, Cannot Skip</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/commbreakmap.cpp" line="362"/>
+@@ -5611,7 +5611,7 @@
+     <message>
+         <location filename="../programs/mythfrontend/exitprompt.cpp" line="227"/>
+         <source>Yes, Exit now</source>
+-        <translation>Yes, Exit now</translation>
++        <translation>Yes, Exit</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/exitprompt.cpp" line="229"/>
+@@ -11873,7 +11873,7 @@
+         <location filename="../libs/libmythtv/mythplayer.cpp" line="4270"/>
+         <location filename="../libs/libmythtv/mythplayer.cpp" line="4306"/>
+         <source>New cut added.</source>
+-        <translation>New cut added.</translation>
++        <translation>New Cut Added</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/mythplayer.cpp" line="4275"/>
+@@ -12303,12 +12303,12 @@
+     <message>
+         <location filename="../libs/libmythui/myththemedmenu.cpp" line="322"/>
+         <source>Enter standby mode</source>
+-        <translation>Enter standby mode</translation>
++        <translation>Standby</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythui/myththemedmenu.cpp" line="326"/>
+         <source>Exit application</source>
+-        <translation>Exit application</translation>
++        <translation>Exit</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythui/myththemedmenu.cpp" line="333"/>
+@@ -12896,12 +12896,12 @@
+     <message>
+         <location filename="../libs/libmythtv/playgroup.cpp" line="288"/>
+         <source>Yes, delete group</source>
+-        <translation>Yes, delete group</translation>
++        <translation>Yes, Delete Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/playgroup.cpp" line="289"/>
+         <source>No, Don&apos;t delete group</source>
+-        <translation>No, Don&apos;t delete group</translation>
++        <translation>No, Keep Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/playgroup.cpp" line="312"/>
+@@ -13022,38 +13022,38 @@
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2623"/>
+         <source>Yes, and allow re-record</source>
+-        <translation>Yes, and allow re-record</translation>
++        <translation>Yes, Delete and Allow Re-record</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2631"/>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2635"/>
+         <source>Yes, delete it</source>
+-        <translation>Yes, delete it</translation>
++        <translation>Yes, Delete</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2639"/>
+         <source>Yes, stop recording</source>
+-        <translation>Yes, stop recording</translation>
++        <translation>Yes, Stop Recording</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2653"/>
+         <source>Yes, delete it and the remaining %1 list items</source>
+-        <translation>Yes, delete it and the remaining %1 list items</translation>
++        <translation>Yes, Delete Recording and the Remaining %1 List Items</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2663"/>
+         <source>No, keep it</source>
+-        <translation>No, keep it</translation>
++        <translation>No, Keep</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2667"/>
+         <source>No, continue recording</source>
+-        <translation>No, continue recording</translation>
++        <translation>No, Continue Recording</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2675"/>
+         <source>No, and keep the remaining %1 list items</source>
+-        <translation>No, and keep the remaining %1 list items</translation>
++        <translation>No, Keep the Remaining %1 List Items</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/playbackbox.cpp" line="2695"/>
+@@ -14340,12 +14340,12 @@
+     <message>
+         <location filename="../libs/libmythtv/profilegroup.cpp" line="360"/>
+         <source>Yes, delete group</source>
+-        <translation>Yes, delete group</translation>
++        <translation>Yes, Delete Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/profilegroup.cpp" line="361"/>
+         <source>No, Don&apos;t delete group</source>
+-        <translation>No, Don&apos;t delete group</translation>
++        <translation>No, Keep Group</translation>
+     </message>
+ </context>
+ <context>
+@@ -14576,7 +14576,7 @@
+     <message>
+         <location filename="../programs/mythfrontend/progdetails.cpp" line="633"/>
+         <source>Auto-expire off</source>
+-        <translation>Auto-expire off</translation>
++        <translation>Auto-Expire Off</translation>
+     </message>
+     <message>
+         <location filename="../programs/mythfrontend/progdetails.cpp" line="636"/>
+@@ -17786,12 +17786,12 @@
+     <message>
+         <location filename="../libs/libmythtv/tv.cpp" line="85"/>
+         <source>Auto-Skip OFF</source>
+-        <translation>Auto-Skip OFF</translation>
++        <translation>Auto-Skip Off</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv.cpp" line="86"/>
+         <source>Auto-Skip ON</source>
+-        <translation>Auto-Skip ON</translation>
++        <translation>Auto-Skip On</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv.cpp" line="87"/>
+@@ -21988,12 +21988,12 @@
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="165"/>
+         <source>Yes, remove directory</source>
+-        <translation>Yes, remove directory</translation>
++        <translation>Yes, Remove Directory</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="166"/>
+         <source>No, Don&apos;t remove directory</source>
+-        <translation>No, Don&apos;t remove directory</translation>
++        <translation>No, Keep Directory</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="223"/>
+@@ -22052,12 +22052,12 @@
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="323"/>
+         <source>Yes, delete group</source>
+-        <translation>Yes, delete group</translation>
++        <translation>Yes, Delete Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="324"/>
+         <source>No, Don&apos;t delete group</source>
+-        <translation>No, Don&apos;t delete group</translation>
++        <translation>No, Keep Group</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmyth/storagegroupeditor.cpp" line="437"/>
+@@ -22733,7 +22733,7 @@
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="10903"/>
+         <source>Zoom Mode ON</source>
+-        <translation>Zoom Mode ON</translation>
++        <translation>Zoom Mode On</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="11500"/>
+@@ -23030,12 +23030,12 @@
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12226"/>
+         <source>Turn Auto-Expire OFF</source>
+-        <translation>Turn Auto-Expire OFF</translation>
++        <translation>Turn Auto-Expire Off</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12226"/>
+         <source>Turn Auto-Expire ON</source>
+-        <translation>Turn Auto-Expire ON</translation>
++        <translation>Turn Auto-Expire On</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12185"/>
+@@ -23436,12 +23436,12 @@
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12703"/>
+         <source>Auto-Expire OFF</source>
+-        <translation>Auto-Expire OFF</translation>
++        <translation>Auto-Expire Off</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12708"/>
+         <source>Auto-Expire ON</source>
+-        <translation>Auto-Expire ON</translation>
++        <translation>Auto-Expire On</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="12951"/>
+@@ -23491,7 +23491,7 @@
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13245"/>
+         <source>this recording</source>
+-        <translation>this recording</translation>
++        <translation>this Recording</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13251"/>
+@@ -23541,27 +23541,27 @@
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13373"/>
+         <source>Delete it, but allow it to re-record</source>
+-        <translation>Delete it, but allow it to re-record</translation>
++        <translation>Delete Recording, and Allow Re-record</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13375"/>
+         <source>Delete it</source>
+-        <translation>Delete it</translation>
++        <translation>Delete Recording</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13377"/>
+         <source>Save it so I can watch it again</source>
+-        <translation>Save it so I can watch it again</translation>
++        <translation>Keep Recording</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13382"/>
+         <source>Yes, and allow re-record</source>
+-        <translation>Yes, and allow re-record</translation>
++        <translation>Yes, Delete and Allow Re-record</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/tv_play.cpp" line="13384"/>
+         <source>Yes, delete it</source>
+-        <translation>Yes, delete it</translation>
++        <translation>Yes, Delete Recording</translation>
+     </message>
+ </context>
+ <context>
+@@ -30107,12 +30107,12 @@
+     <message>
+         <location filename="../libs/libmythtv/transporteditor.cpp" line="325"/>
+         <source>Yes, delete the transport</source>
+-        <translation>Yes, delete the transport</translation>
++        <translation>Yes, Delete Transport</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/transporteditor.cpp" line="326"/>
+         <source>No, don&apos;t</source>
+-        <translation>No, don&apos;t</translation>
++        <translation>No, Keep Transport</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/transporteditor.cpp" line="360"/>
+@@ -31302,13 +31302,13 @@
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3950"/>
+         <source>Yes, delete video sources</source>
+-        <translation>Yes, delete video sources</translation>
++        <translation>Yes, Delete Video Sources</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3951"/>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3975"/>
+         <source>No, don&apos;t</source>
+-        <translation>No, don&apos;t</translation>
++        <translation>No, Keep</translation>
+     </message>
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3972"/>
+@@ -31318,7 +31318,7 @@
+     <message>
+         <location filename="../libs/libmythtv/videosource.cpp" line="3974"/>
+         <source>Yes, delete video source</source>
+-        <translation>Yes, delete video source</translation>
++        <translation>Yes, Delete Video Source</translation>
+     </message>
+ </context>
+ <context>
diff --git a/abs/core/mythtv/stable-0.28/mythtv/tv.cpp_fix_caps.patch b/abs/core/mythtv/stable-0.28/mythtv/tv.cpp_fix_caps.patch
deleted file mode 100644
index dbe9553..0000000
--- a/abs/core/mythtv/stable-0.28/mythtv/tv.cpp_fix_caps.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/mythtv/libs/libmythtv/tv.cpp.orig	2016-04-15 16:11:21.498478075 +0000
-+++ src/mythtv/libs/libmythtv/tv.cpp	2016-04-15 16:11:49.338228155 +0000
-@@ -82,8 +82,8 @@
- {
-     const QString kCommSkipTitles[] =
-     {
--        QObject::tr("Auto-Skip OFF"),
--        QObject::tr("Auto-Skip ON"),
-+        QObject::tr("Auto-Skip Off"),
-+        QObject::tr("Auto-Skip On"),
-         QObject::tr("Auto-Skip Notify"),
-     };
- 
-- 
cgit v0.12