From 5081e889507b4ad24d6601ca55c975e25b2ab361 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 19 Jul 2011 00:56:17 -0700
Subject: nvidia-173xx:Bumped to latest.

---
 abs/core/nvidia-173xx/PKGBUILD                     |  19 ++--
 abs/core/nvidia-173xx/nvidia-96.43.11-2.6.30.patch | 103 ---------------------
 abs/core/nvidia-173xx/nvidia.install               |   4 +-
 3 files changed, 13 insertions(+), 113 deletions(-)
 delete mode 100644 abs/core/nvidia-173xx/nvidia-96.43.11-2.6.30.patch

diff --git a/abs/core/nvidia-173xx/PKGBUILD b/abs/core/nvidia-173xx/PKGBUILD
index 46145dd..bda6165 100644
--- a/abs/core/nvidia-173xx/PKGBUILD
+++ b/abs/core/nvidia-173xx/PKGBUILD
@@ -2,22 +2,23 @@
 # Maintainer : Thomas Baechler <thomas@archlinux.org>
 
 pkgname=nvidia-173xx
-pkgver=173.14.28
-_kernver='2.6.37-LinHES'
+pkgver=173.14.30
+_kernver='2.6.39-LinHES'
 pkgrel=3
 pkgdesc="NVIDIA drivers for kernel26, 173xx branch."
 arch=('i686' 'x86_64')
 [ "$CARCH" = "i686"   ] && ARCH=x86
 [ "$CARCH" = "x86_64" ] && ARCH=x86_64
 url="http://www.nvidia.com/"
-depends=('kernel26>=2.6.37' 'kernel26<2.6.38' 'nvidia-173xx-utils')
-makedepends=('kernel26-headers>=2.6.37' 'kernel26-headers<2.6.38')
+depends=('kernel26>=2.6.39' 'kernel26<2.6.40' 'nvidia-173xx-utils')
+makedepends=('kernel26-headers>=2.6.39' 'kernel26-headers<2.6.40')
 conflicts=('nvidia-96xx' 'nvidia')
 license=('custom')
 install=nvidia.install
 source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run")
-md5sums=('3b2085ffc2047e701a01b3163129f763')
-[ "$CARCH" = "x86_64" ] && md5sums=('8f48430f2b759d4efbf022cb415ecc5d')
+options=(!strip)
+md5sums=('665f9f730c18ab24a997e0e14b863262')
+[ "$CARCH" = "x86_64" ] && md5sums=('8c47463ae14a2f742d0fa00160456745')
 
 build() {
 	cd $srcdir
@@ -25,7 +26,7 @@ build() {
 	cd NVIDIA-Linux-$ARCH-${pkgver}-pkg0
 	cd usr/src/nv/
 	ln -s Makefile.kbuild Makefile
-	make SYSSRC=/lib/modules/${_kernver}/build module || return 1
+	make SYSSRC=/lib/modules/${_kernver}/build module
 }
 
 package() {
@@ -33,6 +34,8 @@ package() {
 	mkdir -p $pkgdir/lib/modules/${_kernver}/kernel/drivers/video/
 	install -m644 nvidia.ko $pkgdir/lib/modules/${_kernver}/kernel/drivers/video/
         mkdir -p $pkgdir/etc/modprobe.d
-        echo "blacklist nouveau" >> $pkgdir/etc/modprobe.d/nouveau_blacklist.conf || return 1
+        echo "blacklist nouveau" >> $pkgdir/etc/modprobe.d/nouveau_blacklist.conf
 	sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/nvidia.install
+        # gzip -9 module
+        find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
 }
diff --git a/abs/core/nvidia-173xx/nvidia-96.43.11-2.6.30.patch b/abs/core/nvidia-173xx/nvidia-96.43.11-2.6.30.patch
deleted file mode 100644
index 44d44fd..0000000
--- a/abs/core/nvidia-173xx/nvidia-96.43.11-2.6.30.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- usr/src/nv/nv.c.orig 
-+++ usr/src/nv/nv.c 
-@@ -15,6 +15,7 @@
- #include "nv_compiler.h"
- #include "os-agp.h"
- #include "nv-vm.h"
-+#include <linux/version.h>
- 
- #ifdef MODULE_ALIAS_CHARDEV_MAJOR
- MODULE_ALIAS_CHARDEV_MAJOR(NV_MAJOR_DEVICE_NUMBER);
-@@ -499,10 +500,12 @@
-      * Set the module owner to ensure that the reference
-      * count reflects accesses to the proc files.
-      */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-     proc_nvidia->owner = THIS_MODULE;
-     proc_nvidia_cards->owner = THIS_MODULE;
-     proc_nvidia_warnings->owner = THIS_MODULE;
- 
-+#endif
-     for (j = 0; j < num_nv_devices; j++)
-     {
-         nvl = &nv_linux_devices[j];
-@@ -521,7 +524,9 @@
- 
-         entry->data = nv;
-         entry->read_proc = nv_kern_read_cardinfo;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-         entry->owner = THIS_MODULE;
-+#endif
- 
-         if (nvos_find_agp_capability(dev)) {
-             /*
-@@ -534,7 +539,9 @@
-                 goto failed;
-             }
- 
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-             entry->owner = THIS_MODULE;
-+#endif
-             proc_nvidia_agp = entry;
- 
-             entry = create_proc_entry("status", flags, proc_nvidia_agp);
-@@ -545,7 +552,9 @@
- 
-             entry->data = nv;
-             entry->read_proc = nv_kern_read_status;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-             entry->owner = THIS_MODULE;
-+#endif
- 
-             entry = create_proc_entry("host-bridge", flags, proc_nvidia_agp);
-             if (!entry) {
-@@ -555,8 +564,9 @@
- 
-             entry->data = NULL;
-             entry->read_proc = nv_kern_read_agpinfo;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-             entry->owner = THIS_MODULE;
--
-+#endif
-             entry = create_proc_entry("card", flags, proc_nvidia_agp);
-             if (!entry) {
-                 NV_PCI_DEV_PUT(dev);
-@@ -565,7 +575,9 @@
- 
-             entry->data = nv;
-             entry->read_proc = nv_kern_read_agpinfo;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-             entry->owner = THIS_MODULE;
-+#endif
-         }
- 
-         NV_PCI_DEV_PUT(dev);
-@@ -576,14 +588,18 @@
-         goto failed;
- 
-     entry->read_proc = nv_kern_read_version;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-     entry->owner = THIS_MODULE;
-+#endif
- 
-     entry = create_proc_entry("registry", flags, proc_nvidia);
-     if (!entry)
-         goto failed;
- 
-     entry->read_proc = nv_kern_read_registry;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-     entry->owner = THIS_MODULE;
-+#endif
- 
-     return;
- 
-@@ -610,7 +626,9 @@
- 
-     entry->data = (void *)message;
-     entry->read_proc = nv_kern_read_warning;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
-     entry->owner = THIS_MODULE;
-+#endif
- #endif
- }
- 
diff --git a/abs/core/nvidia-173xx/nvidia.install b/abs/core/nvidia-173xx/nvidia.install
index f7ecde6..aea2fbb 100644
--- a/abs/core/nvidia-173xx/nvidia.install
+++ b/abs/core/nvidia-173xx/nvidia.install
@@ -1,5 +1,5 @@
 post_install() {
-	KERNEL_VERSION='2.6.37-LinHES'
+	KERNEL_VERSION='2.6.39-LinHES'
 	depmod $KERNEL_VERSION
 }
 
@@ -9,6 +9,6 @@ post_upgrade() {
 }
 
 post_remove() {
-	KERNEL_VERSION='2.6.37-LinHES'
+	KERNEL_VERSION='2.6.39-LinHES'
 	depmod $KERNEL_VERSION
 }
-- 
cgit v0.12