From cfdfbef30ac3891b5a463b861b8719364222ca56 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 16 Dec 2014 19:53:37 +0000
Subject: dolphin-emu: update to 4.0.2

---
 abs/extra/dolphin-emu/Dolphin_Logo.png        | Bin 62052 -> 0 bytes
 abs/extra/dolphin-emu/PKGBUILD                |  89 +++++++++-----------------
 abs/extra/dolphin-emu/__changelog             |   8 +--
 abs/extra/dolphin-emu/dolphin-emu-gcc49.patch |  17 +++++
 abs/extra/dolphin-emu/dolphin-emu.desktop     |  11 ----
 abs/extra/dolphin-emu/dolphin_emu.confcd      |   0
 abs/extra/dolphin-emu/unistd.diff             |  11 ----
 7 files changed, 51 insertions(+), 85 deletions(-)
 delete mode 100644 abs/extra/dolphin-emu/Dolphin_Logo.png
 create mode 100755 abs/extra/dolphin-emu/dolphin-emu-gcc49.patch
 delete mode 100644 abs/extra/dolphin-emu/dolphin-emu.desktop
 delete mode 100644 abs/extra/dolphin-emu/dolphin_emu.confcd
 delete mode 100644 abs/extra/dolphin-emu/unistd.diff

diff --git a/abs/extra/dolphin-emu/Dolphin_Logo.png b/abs/extra/dolphin-emu/Dolphin_Logo.png
deleted file mode 100644
index 63450da..0000000
Binary files a/abs/extra/dolphin-emu/Dolphin_Logo.png and /dev/null differ
diff --git a/abs/extra/dolphin-emu/PKGBUILD b/abs/extra/dolphin-emu/PKGBUILD
index 04547f2..040eb48 100644
--- a/abs/extra/dolphin-emu/PKGBUILD
+++ b/abs/extra/dolphin-emu/PKGBUILD
@@ -1,91 +1,62 @@
 # Maintainer: schuay <jakob.gruber@gmail.com>
 # Contributor: Jeremy Newton (Mystro256)
-# Special thanks to the contributors of dolphin-emu-svn: for the icon, desktop file and some lines from the PKGBUILD
-# Thanks to all that contributed! :)
 
 pkgname=dolphin-emu
-pkgver=3.0
-pkgrel=12
+pkgver=4.0.2
+pkgrel=6
 epoch=1
-pkgdesc="A GameCube and Wii emulator (stable git branch)"
+pkgdesc='A Gamecube / Wii / Triforce emulator'
 arch=('i686' 'x86_64')
-url="http://www.dolphin-emulator.com/"
+url='http://dolphin-emu.org'
 license=('GPL2')
 
-makedepends=('git' 'cmake' 'glproto' 'opencl-headers')
-depends=('sdl' 'libxxf86vm' 'libao' 'wxgtk' 'wiiuse' 'nvidia-cg-toolkit' \
-         'glew' 'mesa' 'libgl' 'openal'  'lzo2')
-         #'glew' 'mesa' 'libgl' 'openal' 'portaudio' 'lzo2')
+makedepends=('cmake' 'git' 'opencl-headers')
+depends=('bluez-libs' 'ffmpeg' 'glew' 'libao' 'libusbx' 'miniupnpc' 'openal' 'sdl2' 'soundtouch' 'wxgtk')
+#optdepends=('pulseaudio: PulseAudio backend')
 
-# Cannot be BUILT with sfml later than 1.6
-# IF YOU NEED SFML>=1.7 FOR SOMETHING ELSE, TRY REMOVING THE CONFLICT
-# BELOW AND ONLY TEMPORARY UNINSTALLING SFML TO BUILD/INSTALL DOLPHIN
-conflicts=('dolphin-emu-git' 'sfml>=1.7' 'sfml-git')
+options=('!emptydirs')
 install="${pkgname}.install"
-source=('dolphin-emu.desktop'
-        'unistd.diff'
-        'Dolphin_Logo.png'
-	'dolphin-emu.xml'
-	'dolphin-emu_games.xml'
-	'dolphin-emu_scan.sh'
-	'gen_lib_dolphin-emu.conf')
+source=("${pkgname%-*}::git+https://code.google.com/p/dolphin-emu/#tag=${pkgver}"
+        'dolphin-emu-gcc49.patch'
+        'dolphin-emu.xml'
+        'dolphin-emu_games.xml'
+        'dolphin-emu_scan.sh'
+        'gen_lib_dolphin-emu.conf')
 
-_gitroot=https://code.google.com/p/dolphin-emu/
-_gitname=dolphin-emu-3.0
+prepare() {
+  cd "${srcdir}/${pkgname%-*}"
+
+  patch -Np1 -i ../dolphin-emu-gcc49.patch
+}
 
 build() {
-  cd "$srcdir"
-  msg "Connecting to GIT server...."
+  cd "${srcdir}/${pkgname%-*}"
 
-  if [[ -d "$_gitname" ]]; then
-    cd "$_gitname" && git pull origin 3.0
-    msg "The local files are updated."
+  mkdir build && cd build
+  if [[ $CARCH == x86_64 ]]; then
+    cmake .. -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_CXX_FLAGS='-fno-inline-functions'
   else
-    git clone "$_gitroot" "$_gitname"
+    cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
   fi
-
-  msg "GIT checkout done or server timeout"
-  msg "Starting build..."
-
-  rm -rf "$srcdir/$_gitname-build"
-  git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
-  cd "$srcdir/$_gitname-build"
-
-#  msg "Checking out at stable 3.0 branch"
-#  git checkout 3.0
-
-  msg "GIT checkout done or server timeout"
-
-  patch -Np2 < ${srcdir}/unistd.diff
-
-  mkdir build && cd build
-  export CXXFLAGS="$CXXFLAGS -fpermissive"
-  cmake .. -DCMAKE_INSTALL_PREFIX=/usr
   make
 }
 
 package() {
-  cd "${srcdir}/dolphin-emu-3.0-build/build"
-
-  make DESTDIR=${pkgdir} install
+  cd "${srcdir}/${pkgname%-*}/build"
 
+  #LinHES Stuff
   mkdir -p "${pkgdir}"/usr/share/mythtv/themes/defaultmenu
   mkdir -p "${pkgdir}"/usr/LH/bin
-
-  install -Dm644 "${srcdir}/dolphin-emu.desktop" "${pkgdir}/usr/share/applications/dolphin-emu.desktop"
-  install -Dm644 "${srcdir}/Dolphin_Logo.png" "${pkgdir}/usr/share/pixmaps/dolphin-emu.png"
   cp "${srcdir}/dolphin-emu.xml" "${pkgdir}/usr/share/mythtv/themes/defaultmenu"
   cp "${srcdir}/dolphin-emu_games.xml" "${pkgdir}/usr/share/mythtv/themes/defaultmenu"
   install -m755 "${srcdir}/dolphin-emu_scan.sh" "${pkgdir}/usr/LH/bin"
   #add in file for gen_game.xml
   install -D -m0744 ${srcdir}/gen_lib_dolphin-emu.conf ${pkgdir}/etc/gen_game_xml.d/dolphin-emu.conf
-}
-
-# vim:set ts=2 sw=2 et:
 
-md5sums=('feed4580c2e6bfbc7f6c67dad861daae'
-         'a463b96d02462b5f6b0894f6ced821ab'
-         'd15c51f547b4bd47e510faac40bcc9d6'
+  make DESTDIR="${pkgdir}" install
+}
+md5sums=('SKIP'
+         '5fead49fc3a0ff9a9d1435368b5df1f9'
          'ab7a9b9cfe03db65c881134c0f02bda0'
          '1d03499e0abab56285bc97176d311bf1'
          'af44dd20626ce26d0a07dadc37c20233'
diff --git a/abs/extra/dolphin-emu/__changelog b/abs/extra/dolphin-emu/__changelog
index 113934d..3d186d7 100644
--- a/abs/extra/dolphin-emu/__changelog
+++ b/abs/extra/dolphin-emu/__changelog
@@ -1,5 +1,5 @@
-6/9/12 -chw-
-Added install file, and mythtv menu files.
-removed portaudio because it drug in jack
-
+PKGBUILD: remove portaudio dep
+PKGBUILD: remove pulseaudio opt dep
+PKGBUILD: add .install file
+PKGBUILD: Add LinHES Stuff
 --converted .install file to use gen_game_xml.py
diff --git a/abs/extra/dolphin-emu/dolphin-emu-gcc49.patch b/abs/extra/dolphin-emu/dolphin-emu-gcc49.patch
new file mode 100755
index 0000000..7431ce6
--- /dev/null
+++ b/abs/extra/dolphin-emu/dolphin-emu-gcc49.patch
@@ -0,0 +1,17 @@
+diff -rupN dolphin.orig/Source/Core/Common/Src/CommonFuncs.h dolphin/Source/Core/Common/Src/CommonFuncs.h
+--- dolphin.orig/Source/Core/Common/Src/CommonFuncs.h	2014-08-19 02:36:05.555642000 +0200
++++ dolphin/Source/Core/Common/Src/CommonFuncs.h	2014-08-19 02:38:44.301036700 +0200
+@@ -30,7 +30,12 @@ struct ArraySizeImpl : public std::exten
+ #define b32(x)  (b16(x) | (b16(x) >>16) )
+ #define ROUND_UP_POW2(x)	(b32(x - 1) + 1)
+ 
+-#if defined __GNUC__ && !defined __SSSE3__ && !defined _M_GENERIC
++#ifndef __GNUC_PREREQ
++	#define __GNUC_PREREQ(a, b) 0
++#endif
++
++#if (defined __GNUC__ && !__GNUC_PREREQ(4,9)) && \
++	!defined __SSSE3__ && defined _M_X86
+ #include <emmintrin.h>
+ static __inline __m128i __attribute__((__always_inline__))
+ _mm_shuffle_epi8(__m128i a, __m128i mask)
diff --git a/abs/extra/dolphin-emu/dolphin-emu.desktop b/abs/extra/dolphin-emu/dolphin-emu.desktop
deleted file mode 100644
index 96317d1..0000000
--- a/abs/extra/dolphin-emu/dolphin-emu.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Dolphin
-Categories=Game;Emulator;GTK;
-GenericName=GameCube and Wii Emulator
-Comment=An emulator for the GameCube and Wii consoles
-Exec=dolphin-emu
-Icon=dolphin-emu
-StartupNotify=false
-Name[en_US]=Dolphin
diff --git a/abs/extra/dolphin-emu/dolphin_emu.confcd b/abs/extra/dolphin-emu/dolphin_emu.confcd
deleted file mode 100644
index e69de29..0000000
diff --git a/abs/extra/dolphin-emu/unistd.diff b/abs/extra/dolphin-emu/unistd.diff
deleted file mode 100644
index 2b39063..0000000
--- a/abs/extra/dolphin-emu/unistd.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dolphin-emu-3.0/Source/Core/Common/Src/CommonFuncs.h	2012-04-07 10:47:47.595151504 +0200
-+++ src/dolphin-emu-3.0-build/Source/Core/Common/Src/CommonFuncs.h	2012-04-07 10:53:25.371113081 +0200
-@@ -18,6 +18,8 @@
- #ifndef _COMMONFUNCS_H_
- #define _COMMONFUNCS_H_
- 
-+#include <unistd.h>
-+
- #ifdef _WIN32
- #define SLEEP(x) Sleep(x)
- #else
-- 
cgit v0.12