From 6f920153a05f27e1d50613a80534e1650355e0aa Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 5 Dec 2017 20:25:49 +0000
Subject: linhes-theme: standardsettings-ui.xml: add terminal window; Add OK
 button for settings.

config-ui.xml: add guistart and backendselection window.

base.xml: adjust popup window buttons size and add scrolling.
---
 abs/core/linhes-theme/PKGBUILD                 |  10 +-
 abs/core/linhes-theme/base.xml.patch           | 115 +++++---
 abs/core/linhes-theme/config-ui.xml.patch      | 374 ++++++++++++++++++++++++-
 abs/core/linhes-theme/mytharchive-ui.xml.patch |  13 +-
 abs/core/linhes-theme/standardsetting-ui.xml   | 124 ++++++--
 5 files changed, 573 insertions(+), 63 deletions(-)

diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index d3b77c8..4210690 100755
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-theme
 pkgver=8.5
-pkgrel=2
+pkgrel=3
 pkgdesc="Default LinHES MythTV theme"
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -99,15 +99,15 @@ package() {
 }
 md5sums=('2dca856c2a4d1f959473512c94e43b60'
          '3fc2c8838a9e331a2d19c114760a5acb'
-         'f9ed8fe7ccb8e11a1c933e42c6c204ac'
+         'b534a456304ed75d0082e04e4fd7a965'
          'd1d54968a2297924673d9653f707df33'
-         'def0a86ce722ef819c3c19ac370f895b'
+         'b7ab73f7e445b617b1ea293ca40ef4e4'
          '26a6db272dee225b9e4dc282f1494e51'
          'b90b745c72a057c78ebd0b6f2c5530b9'
          'a0ea2d3e386c0b483b31aa1a2703f9eb'
          '8f8c27146e11954f60913da6d1fce073'
          '09806f2e1d1e6050cc0d10cc6c5daf36'
-         '128984d8de805e3227a4de279f292f46'
+         'cf259052229f42646d7f37023ec55f44'
          '52bb1c1a6c693adc8c04227fb124955a'
          '643e7d548587b8742ed5accb6d736257'
          '80bb72994eca59ca6dc9034ac185e7cc'
@@ -131,6 +131,6 @@ md5sums=('2dca856c2a4d1f959473512c94e43b60'
          'e8ac15e38b3dc99c9e889e439ba356de'
          'e8cf0d3a55ba3be47deae55c05432141'
          '3f600b966bd813dd27f620762ddb3ac8'
-         '9b2e2def02127a5722f46c42ef6fc600'
+         'a2d7c855d78b4fa5e9714509891a6cb9'
          'b51ef0cbf8ed2d3a8c1a8257a89aceff'
          '09ad14842f828b7a8d24070ec8214fe5')
diff --git a/abs/core/linhes-theme/base.xml.patch b/abs/core/linhes-theme/base.xml.patch
index 3de8de5..fb6091f 100644
--- a/abs/core/linhes-theme/base.xml.patch
+++ b/abs/core/linhes-theme/base.xml.patch
@@ -1,5 +1,5 @@
---- base.xml.orig	2016-12-13 20:41:54.779274682 +0000
-+++ base.xml	2017-10-26 17:04:02.966374691 +0000
+--- base.xml.orig	2017-12-01 19:19:20.906194024 +0000
++++ base.xml	2017-12-01 19:13:11.344053140 +0000
 @@ -3,55 +3,55 @@
  <mythuitheme>
  
@@ -233,7 +233,7 @@
          <font state="normal">basesmallverylightgrey</font>
          <font state="running">basesmallgreen</font>
          <cutdown>yes</cutdown>
-@@ -392,7 +396,7 @@
+@@ -392,9 +396,10 @@
  
      <!-- Base heading definition. -->
      <textarea name="base_heading">
@@ -241,8 +241,11 @@
 +        <area>486,0,308,22</area>
          <font>baseextrasmall</font>
          <align>allcenter</align>
++        <scroll direction="horizontal" />
          <value>Heading</value>
-@@ -411,7 +415,7 @@
+     </textarea>
+ 
+@@ -411,7 +416,7 @@
          <area>283,436,50,11</area>
          <type>roundbox</type>
          <fill color="#000000" alpha="200" />
@@ -251,7 +254,7 @@
      </shape>
  
      <shape name="base_backdrop_line">
-@@ -424,7 +428,7 @@
+@@ -424,7 +429,7 @@
  
      <!-- Base definition of a base popup backdrop -->
      <shape name="base_popup_backdrop" from="base_backdrop">
@@ -260,7 +263,7 @@
      </shape>
  
      <!-- Base definition of a heading group -->
-@@ -481,7 +485,7 @@
+@@ -481,7 +486,7 @@
  
      <!-- Base denfinition of a clock -->
      <clock name="base_clock">
@@ -269,7 +272,7 @@
          <font>baseextrasmall</font>
          <template>%DATE%, %TIME%</template>
          <align>allcenter</align>
-@@ -535,10 +539,10 @@
+@@ -535,10 +540,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -284,7 +287,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -547,10 +551,10 @@
+@@ -547,10 +552,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -299,7 +302,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -667,10 +671,10 @@
+@@ -667,10 +672,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -314,7 +317,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -679,10 +683,10 @@
+@@ -679,10 +684,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -329,7 +332,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -700,10 +704,10 @@
+@@ -700,10 +705,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -344,7 +347,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -712,10 +716,10 @@
+@@ -712,10 +717,10 @@
              <type>box</type>
              <fill style="gradient">
                  <gradient direction="horizontal" alpha="50">
@@ -359,7 +362,7 @@
                  </gradient>
              </fill>
          </shape>
-@@ -863,7 +867,7 @@
+@@ -863,7 +868,7 @@
              <type>roundbox</type>
              <fill color="#1a1a1a" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -368,7 +371,7 @@
          </shape>
          <shape name="select_bar_top_highlight">
              <area>0,0,100%,2</area>
-@@ -956,7 +960,7 @@
+@@ -956,7 +961,7 @@
              <type>roundbox</type>
              <fill color="#333333" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -377,7 +380,7 @@
          </shape>
       </group>
  
-@@ -967,7 +971,7 @@
+@@ -967,7 +972,7 @@
              <type>roundbox</type>
              <fill color="#1a1a1a" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -386,7 +389,7 @@
          </shape>
          <shape name="select_bar_top_highlight">
              <area>0,0,100%,2</area>
-@@ -1060,7 +1064,7 @@
+@@ -1060,7 +1065,7 @@
              <type>roundbox</type>
              <fill color="#333333" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -395,7 +398,7 @@
          </shape>
       </group>
  
-@@ -1071,7 +1075,7 @@
+@@ -1071,7 +1076,7 @@
              <type>roundbox</type>
              <fill color="#1a1a1a" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -404,7 +407,7 @@
          </shape>
          <shape name="select_bar_top_highlight">
              <area>0,0,100%,2</area>
-@@ -1164,7 +1168,7 @@
+@@ -1164,7 +1169,7 @@
              <type>roundbox</type>
              <fill color="#1a1a1a" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -413,7 +416,7 @@
          </shape>
      </group>
  
-@@ -1233,7 +1237,7 @@
+@@ -1233,7 +1238,7 @@
              <type>roundbox</type>
              <fill color="#333333" alpha="175" />
              <line color="#454545" alpha="180" width="2" />
@@ -422,7 +425,7 @@
          </shape>
       </group>
  
-@@ -1455,7 +1459,7 @@
+@@ -1455,7 +1460,7 @@
                      <area>0,0,100%,100%</area>
                  </group>
                  <textarea name="buttontext">
@@ -431,7 +434,7 @@
                  </textarea>
              </state>
              <state name="selectedinactive" from="active">
-@@ -1564,6 +1568,9 @@
+@@ -1564,6 +1569,9 @@
                  <group name="select_bar" from="base_select_bar_selectedinactive_group">
                      <area>0,0,100%,100%</area>
                  </group>
@@ -441,7 +444,7 @@
                  <imagetype name="buttonarrow">
                      <filename>images/lists_right_arrow.png</filename>
                      <alpha>0</alpha>
-@@ -1664,6 +1671,7 @@
+@@ -1664,6 +1672,7 @@
                          </state>
                      </statetype>
                  <textarea name="buttontext" from="base_text_font_state_small">
@@ -449,7 +452,7 @@
                  </textarea>
                  <statetype name="buttoncheck">
                      <state type="off">
-@@ -1732,7 +1740,7 @@
+@@ -1732,7 +1741,7 @@
                      <area>15,1,100%-15,100%</area>
                      <align>allcenter</align>
                      <font>basemedium</font>
@@ -458,7 +461,7 @@
                      <font state="disabled">basemediumdarkgrey</font>
                  </textarea>
              </state>
-@@ -1831,16 +1839,20 @@
+@@ -1831,16 +1840,20 @@
          <area>0,0,30,30</area>
          <statetype name="checkstate">
              <state type="off">
@@ -482,7 +485,7 @@
          </statetype>
          <statetype name="background">
              <state name="active" />
-@@ -2186,7 +2198,7 @@
+@@ -2186,7 +2199,7 @@
          </shape>
  
          <shape name="popup-seperator-line" from="base_line">
@@ -491,7 +494,7 @@
          </shape>
  
          <shape name="popup-third-line" from="base_highlight_line">
-@@ -2202,18 +2214,18 @@
+@@ -2202,23 +2215,23 @@
          </shape>
  
          <shape name="popup-arrows-backdrop" from="base_arrows_backdrop">
@@ -514,7 +517,32 @@
              <statetype name="buttonitem">
                  <state name="active">
                      <area>0,0,100%,34</area>
-@@ -2244,10 +2256,10 @@
+                     <textarea name="buttontext">
+-                        <area>8,0,586,34</area>
++                        <area>8,0,570,34</area>
+                     </textarea>
+                     <imagetype name="buttonarrow">
+                         <position>560,8</position>
+@@ -2227,7 +2240,8 @@
+                 <state name="selectedactive">
+                     <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>8,0,586,34</area>
++                        <area>8,0,570,34</area>
++                        <scroll direction="horizontal" />
+                     </textarea>
+                     <imagetype name="buttonarrow">
+                         <position>560,8</position>
+@@ -2236,7 +2250,7 @@
+                 <state name="selectedinactive">
+                     <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>8,0,586,34</area>
++                        <area>8,0,570,34</area>
+                     </textarea>
+                     <imagetype name="buttonarrow">
+                         <position>560,8</position>
+@@ -2244,10 +2258,10 @@
                  </state>
              </statetype>
          <statetype name="upscrollarrow">
@@ -527,7 +555,7 @@
          </statetype>
          </buttonlist>
      </window>
-@@ -2299,7 +2311,7 @@
+@@ -2299,7 +2313,7 @@
          </shape>
  
          <shape name="large-dialogbox-arrows-backdrop" from="base_arrows_backdrop">
@@ -536,7 +564,7 @@
          </shape>
  
          <textarea name="messagearea" from="basetextarea">
-@@ -2332,10 +2344,10 @@
+@@ -2332,10 +2346,10 @@
                  </state>
              </statetype>
              <statetype name="upscrollarrow">
@@ -549,7 +577,24 @@
              </statetype>
          </buttonlist>
      </window>
-@@ -2630,12 +2642,12 @@
+@@ -2486,7 +2500,7 @@
+ 
+         <textarea name="message" from="basetextarea">
+             <area>8,8,571,127</area>
+-            <font>basesmalldarkyellow</font>
++            <font>basesmall</font>
+             <align>allcenter</align>
+             <multiline>yes</multiline>
+             <cutdown>no</cutdown>
+@@ -2501,6 +2515,7 @@
+             <area>338,151,150,35</area>
+             <value>OK</value>
+         </button>
++
+     </window>
+ 
+     <!-- Popup search dialog used to search button lists -->
+@@ -2630,12 +2645,12 @@
  
          <textarea name="message" from="basetextarea">
              <area>10,14,567,36</area>
@@ -564,7 +609,7 @@
          </textedit>
  
          <button name="ok" from="base_button">
-@@ -2708,6 +2720,63 @@
+@@ -2708,6 +2723,63 @@
  
      </window>
  
@@ -628,7 +673,7 @@
      <window name="MythSearchDialog">
          <area>-1,-1,602,488</area>
  
-@@ -2795,10 +2864,10 @@
+@@ -2795,10 +2867,10 @@
                  </state>
              </statetype>
              <statetype name="upscrollarrow">
@@ -641,7 +686,7 @@
              </statetype>
          </buttonlist>
  
-@@ -2819,7 +2888,7 @@
+@@ -2819,7 +2891,7 @@
          <group name="fanart-group" from="base_fanart_group" />
  
          <textarea name="heading" from="base_heading">
@@ -650,7 +695,7 @@
          </textarea>
  
          <shape name="fullpath-backdrop" from="base_backdrop">
-@@ -2836,87 +2905,85 @@
+@@ -2836,87 +2908,85 @@
          </shape>
  
          <shape name="file-browser-preview-backdrop" from="base_backdrop">
@@ -759,7 +804,7 @@
              <statetype name="buttonitem">
                  <state name="active">
                      <area>0,0,599,54</area>
-@@ -3029,52 +3096,53 @@
+@@ -3029,52 +3099,53 @@
          </buttonlist>
  
          <textedit name="location" from="base_textedit">
diff --git a/abs/core/linhes-theme/config-ui.xml.patch b/abs/core/linhes-theme/config-ui.xml.patch
index de81a12..0ce47cf 100644
--- a/abs/core/linhes-theme/config-ui.xml.patch
+++ b/abs/core/linhes-theme/config-ui.xml.patch
@@ -1,5 +1,5 @@
---- config-ui.xml.orig	2017-10-26 17:17:36.860480362 +0000
-+++ config-ui.xml	2017-10-26 17:04:02.966374691 +0000
+--- config-ui.xml.orig	2017-12-01 19:19:08.627784142 +0000
++++ config-ui.xml	2017-12-01 19:10:38.513844323 +0000
 @@ -645,7 +645,7 @@
          <textarea name="helptext" from="basetextarea">
              <area>231,372,818,227</area>
@@ -36,3 +36,373 @@
              <align>allcenter</align>
          </textarea>
  
+@@ -1016,4 +1016,369 @@
+ 
+     </window>
+ 
++    <window name="backendselection">
++
++        <textarea name="heading" from="base_heading">
++            <value>MythTV Servers</value>
++        </textarea>
++
++        <shape name="beconnect-backdrop" from="base_backdrop">
++            <area>115,36,1050,649</area>
++        </shape>
++
++        <shape name="beconnect-backdrop-line" from="base_backdrop_line">
++            <area>116,37,1048,500</area>
++        </shape>
++
++        <shape name="beconnect-top-line" from="base_highlight_line">
++            <area>117,38,1046,2</area>
++        </shape>
++
++        <shape name="beconnect-bottom-line" from="base_highlight_line">
++            <area>117,534,1046,2</area>
++        </shape>
++
++        <shape name="beconnect-left-line" from="base_highlight_vertical_line">
++            <area>117,40,2,494</area>
++        </shape>
++
++        <shape name="beconnect-right-line" from="base_highlight_vertical_line">
++            <area>1161,40,2,494</area>
++        </shape>
++
++        <shape name="beconnect-bottom-backdrop-line" from="base_backdrop_line">
++            <area>116,547,1048,137</area>
++        </shape>
++
++        <shape name="beconnect-bottom-top-line" from="base_highlight_line">
++            <area>117,548,1046,2</area>
++        </shape>
++
++        <shape name="beconnect-bottom-bottom-line" from="base_highlight_line">
++            <area>117,681,1046,2</area>
++        </shape>
++
++        <shape name="beconnect-bottom-left-line" from="base_highlight_vertical_line">
++            <area>117,550,2,131</area>
++        </shape>
++
++        <shape name="beconnect-bottom-right-line" from="base_highlight_vertical_line">
++            <area>1161,550,2,131</area>
++        </shape>
++
++        <shape name="beconnect-bottom-seperator-first-line" from="base_line">
++            <area>138,620,1004,2</area>
++        </shape>
++
++        <buttonlist name="backends" from="base_list_state">
++            <area>123,44,1034,494</area>
++            <statetype name="buttonitem">
++                <state name="active">
++                    <area>0,0,1034,30</area>
++                    <group name="select_bar" from="base_select_bar_active_group">
++                        <area>0,0,100%,100%</area>
++                    </group>
++                    <textarea name="buttontext" from="basetextarea">
++                        <area>8,0,420,100%</area>
++                        <align>left,vcenter</align>
++                    </textarea>
++                    <textarea name="modelname" from="buttontext" /> <!-- Workaround for vanishing buttontext bug -->
++                    <textarea name="protocollabel" from="buttontext" depends="protocolversion">
++                        <area>432,0,100,100%</area>
++                        <cutdown>yes</cutdown>
++                        <align>right,vcenter</align>
++                        <value>Protocol:</value>
++                        <font>basesmallerblue</font>
++                    </textarea>
++                    <textarea name="protocolversion" from="buttontext">
++                        <area>538,0,50,100%</area>
++                        <cutdown>yes</cutdown>
++                        <align>left,vcenter</align>
++                        <font>basesmaller</font>
++                    </textarea>
++                    <textarea name="versionlabel" from="protocollabel" depends="version">
++                        <area>596,0,100,100%</area>
++                        <value>Version:</value>
++                    </textarea>
++                    <textarea name="version" from="protocolversion">
++                        <area>704,0,242,100%</area>
++                    </textarea>
++                    <statetype name="connection">
++                        <area>8,0,100%-8,100%</area>
++                        <state name="good">
++                            <area>0,0,100%,100%</area>
++                        </state>
++                        <state name="protocolmismatch">
++                            <area>0,0,100%,100%</area>
++                            <textarea name="description">
++                                <area>0,0,100%,100%</area>
++                                <align>allcenter</align>
++                                <value>Version Mismatch Between Client and Server</value>
++                                <font>basesmallred</font>
++                            </textarea>
++                        </state>
++                        <state name="blocked" from="protocolmismatch">
++                            <textarea name="description">
++                                <area>0,0,100%,100%</area>
++                                <align>allcenter</align>
++                                <value>Firewall is Blocking the Server</value>
++                                <font>basesmallred</font>
++                            </textarea>
++                        </state>
++                    </statetype>
++                    <statetype name="securitypin">
++                        <area>946,0,80,100%</area>
++                        <state name="yes">
++                            <area>0,0,80,100%</area>
++                            <textarea name="description">
++                                <area>0,0,80,100%</area>
++                                <align>allcenter</align>
++                                <value>LOCKED</value>
++                                <font>basesupersmallred</font>
++                            </textarea>
++                        </state>
++                        <state name="no" from="yes">
++                            <textarea name="description">
++                                <value>UNLOCKED</value>
++                                <font>basesupersmallgreen</font>
++                            </textarea>
++                        </state>
++                    </statetype>
++                </state>
++                <state name="inactive" from="active" />
++                <state name="selectedactive" from="active">
++                    <area>0,0,1034,64</area>
++                    <group name="select_bar" from="base_select_bar_selectedactive_group">
++                        <area>0,0,100%,100%</area>
++                    </group>
++                    <textarea name="buttontext" from="basetextarea">
++                        <area>8,0,420,100%</area>
++                        <align>left,vcenter</align>
++                        <font>basesmallyellow</font>
++                    </textarea>
++                    <textarea name="modelname" from="buttontext" /> <!-- Workaround for vanishing buttontext bug -->
++                    <textarea name="protocolversion" from="buttontext">
++                        <area>538,0,50,100%</area>
++                        <cutdown>yes</cutdown>
++                        <align>left,vcenter</align>
++                        <font>basesmalleryellow</font>
++                    </textarea>
++                    <textarea name="version" from="protocolversion">
++                        <area>704,0,242,100%</area>
++                    </textarea>
++                </state>
++                <state name="selectedinactive" from="selectedactive">
++                    <group name="select_bar" from="base_select_bar_selectedinactive_group">
++                        <area>0,0,100%,100%</area>
++                    </group>
++                </state>
++            </statetype>
++            <statetype name="upscrollarrow">
++                <position>998,494</position>
++            </statetype>
++            <statetype name="downscrollarrow">
++                <position>1018,494</position>
++            </statetype>
++            <helptext>Select a server.</helptext>
++        </buttonlist>
++
++        <textarea name="helptext" from="basetextarea">
++            <area>139,552,1003,66</area>
++            <font>basesmaller</font>
++            <cutdown>yes</cutdown>
++            <align>allcenter</align>
++            <multiline>yes</multiline>
++        </textarea>
++        <button name="cancel" from="base_button">
++            <area>265,632,150,40</area>
++            <value>Cancel</value>
++            <helptext>Close without saving the selected server.</helptext>
++        </button>
++        <button name="manual" from="base_button">
++            <area>565,632,150,40</area>
++            <value>Manual</value>
++            <helptext>Manually select a server.</helptext>
++        </button>
++        <button name="save" from="base_button">
++            <area>865,632,150,40</area>
++            <value>Save</value>
++            <helptext>Save the selected server.</helptext>
++        </button>
++    </window>
++
++    <window name="guistartup">
++
++        <textarea name="heading" from="base_heading">
++            <value>MythTV Startup Status</value>
++        </textarea>
++
++        <shape name="startup-backdrop" from="base_backdrop">
++            <area>115,36,1050,649</area>
++        </shape>
++
++        <shape name="startup-backdrop-line" from="base_backdrop_line">
++            <area>116,37,1048,506</area>
++        </shape>
++
++        <shape name="startup-top-line" from="base_highlight_line">
++            <area>117,38,1046,2</area>
++        </shape>
++
++        <shape name="startup-bottom-line" from="base_highlight_line">
++            <area>117,540,1046,2</area>
++        </shape>
++
++        <shape name="startup-left-line" from="base_highlight_vertical_line">
++            <area>117,40,2,500</area>
++        </shape>
++
++        <shape name="startup-right-line" from="base_highlight_vertical_line">
++            <area>1161,40,2,500</area>
++        </shape>
++
++        <shape name="startup-bottom-backdrop-line" from="base_backdrop_line">
++            <area>116,547,1048,137</area>
++        </shape>
++
++        <shape name="startup-bottom-top-line" from="base_highlight_line">
++            <area>117,548,1046,2</area>
++        </shape>
++
++        <shape name="startup-bottom-bottom-line" from="base_highlight_line">
++            <area>117,681,1046,2</area>
++        </shape>
++
++        <shape name="startup-bottom-left-line" from="base_highlight_vertical_line">
++            <area>117,550,2,131</area>
++        </shape>
++
++        <shape name="startup-bottom-right-line" from="base_highlight_vertical_line">
++            <area>1161,550,2,131</area>
++        </shape>
++
++        <shape name="startup-bottom-seperator-first-line" from="base_line">
++            <area>138,620,1004,2</area>
++        </shape>
++
++        <progressbar name="progress" from="baseprogressbar">
++            <position>372,214</position>
++        </progressbar>
++
++        <statetype name="statusstate">
++            <area>129,255,1022,40</area>
++            <state name="start">
++                <area>0,0,1022,40</area>
++                <textarea name="status" from="basetextarea">
++                    <area>0,0,1022,40</area>
++                    <font>basemedium</font>
++                    <align>allcenter</align>
++                    <value>Waking up Database Machine</value>
++                    <multiline>true</multiline>
++                </textarea>
++            </state>
++            <state name="startFail" from="start">
++                <textarea name="status">
++                    <value>Database Machine Failed to Wake Up</value>
++                </textarea>
++            </state>
++            <state name="dbAwake" from="start">
++                <textarea name="status">
++                    <value>Waiting for Database to Start</value>
++                </textarea>
++            </state>
++            <state name="dbAwakeFail" from="start">
++                <textarea name="status">
++                    <value>Database Failed to Start</value>
++                </textarea>
++            </state>
++            <state name="dbStarted" from="start">
++                <textarea name="status">
++                    <value>Attempting to Connect to Database</value>
++                </textarea>
++            </state>
++            <state name="dbStartedFail" from="start">
++                <textarea name="status">
++                    <value>Unable to Connect to Database</value>
++                </textarea>
++            </state>
++            <state name="beWOL" from="start">
++                <textarea name="status">
++                    <value>Attempting to Wake Master Backend</value>
++                </textarea>
++            </state>
++            <state name="beWOLFail" from="start">
++                <textarea name="status">
++                    <value>Master Backend Failed to Wake</value>
++                </textarea>
++            </state>
++            <state name="beAwake" from="start">
++                <textarea name="status">
++                    <value>Attempting to Connect to Master Backend</value>
++                </textarea>
++            </state>
++            <state name="beAwakeFail" from="start">
++                <textarea name="status">
++                    <value>Unable to Connect to Master Backend</value>
++                </textarea>
++            </state>
++        </statetype>
++
++        <statetype name="messagestate">
++            <area>129,316,1022,40</area>
++            <state name="makeselection">
++                <area>0,0,100%,100%</area>
++                <textarea name="message" from="basetextarea">
++                    <area>0,0,100%,100%</area>
++                    <font>basemedium</font>
++                    <align>allcenter</align>
++                    <value></value>
++                    <multiline>true</multiline>
++                </textarea>
++            </state>
++            <state name="empty" from="makeselection">
++                <textarea name="message">
++                    <value></value>
++                </textarea>
++            </state>
++        </statetype>
++
++        <textarea name="helptext" from="basetextarea">
++            <area>139,552,1003,66</area>
++            <font>basesmaller</font>
++            <cutdown>yes</cutdown>
++            <align>allcenter</align>
++            <multiline>yes</multiline>
++        </textarea>
++
++        <button name="dummy" from="base_button">
++            <area>0%,80%,0,0</area>
++            <value></value>
++            <helptext></helptext>
++        </button>
++
++        <button name="retry" from="base_button">
++            <area>205,632,150,40</area>
++            <value>Retry</value>
++            <helptext>Try again to establish connections.</helptext>
++        </button>
++
++        <button name="search" from="base_button">
++            <area>445,632,150,40</area>
++            <value>Search</value>
++            <helptext>Search the local network for the MythTV Backend.</helptext>
++        </button>
++
++        <button name="setup" from="base_button">
++            <area>685,632,150,40</area>
++            <value>Setup</value>
++            <helptext>Use Database setup to enter database parameters.</helptext>
++        </button>
++
++        <button name="exit" from="base_button">
++            <area>925,632,150,40</area>
++            <value>Exit</value>
++            <helptext>Exit from MythTV.</helptext>
++        </button>
++    </window>
++
+ </mythuitheme>
diff --git a/abs/core/linhes-theme/mytharchive-ui.xml.patch b/abs/core/linhes-theme/mytharchive-ui.xml.patch
index b563516..78271f9 100644
--- a/abs/core/linhes-theme/mytharchive-ui.xml.patch
+++ b/abs/core/linhes-theme/mytharchive-ui.xml.patch
@@ -1,5 +1,5 @@
---- mytharchive-ui.xml.orig	2017-10-26 17:13:10.455144739 +0000
-+++ mytharchive-ui.xml	2017-10-26 17:04:02.966374691 +0000
+--- mytharchive-ui.xml.orig	2017-12-01 19:19:38.943858051 +0000
++++ mytharchive-ui.xml	2017-12-01 19:13:29.711674546 +0000
 @@ -70,7 +70,7 @@
  
          <textarea name="destination_text" from="basetextarea">
@@ -27,3 +27,12 @@
                          <preserveaspect>true</preserveaspect>
                      </imagetype>
                      <textarea name="buttontext">
+@@ -1046,7 +1046,7 @@
+ 
+         <textarea name="logitem_text" from="basetextarea">
+             <area>139,538,1003,82</area>
+-            <font>basesmallerblue</font>
++            <font>basesmaller</font>
+             <cutdown>yes</cutdown>
+             <align>allcenter</align>
+             <multiline>yes</multiline>
diff --git a/abs/core/linhes-theme/standardsetting-ui.xml b/abs/core/linhes-theme/standardsetting-ui.xml
index 31bc634..a50e985 100644
--- a/abs/core/linhes-theme/standardsetting-ui.xml
+++ b/abs/core/linhes-theme/standardsetting-ui.xml
@@ -145,18 +145,12 @@
                                 </group>
                             </state>
                             <state name="filebrowser">
-                                <area>0,0,100%,100%</area> 
+                                <area>0,0,100%,100%</area>
                             </state>
                             <state name="spinbox" from="textedit" />
                             <state name="combobox" from="textedit" />
                             <state name="button">
                                 <area>0,0,100%,100%</area>
-                                <!--
-                                <imagetype name="comboboximage">
-                                    <area>100%-20,50%-10,20,20</area>
-                                    <filename>searchbutton_background_selected.png</filename>
-                                </imagetype>
-                                -->
                             </state>
                         </statetype>
                         <!-- we can not put more than one textarea with the same name
@@ -206,6 +200,7 @@
                         <area>15,0,1194,64</area>
                         <font>basesmallyellow</font>
                         <align>left,vcenter</align>
+                        <scroll direction="horizontal" />
                     </textarea>
 
                     <group name="widgets">
@@ -216,12 +211,31 @@
                                     <area>0,5%,100%,95%</area>
                                 </group>
                             </state>
+                            <state name="filebrowser">
+                                <area>0,0,100%,100%</area>
+                                <group name="filebrowsergroup" from="base_textedit_select_bar_selectedactive_group">
+                                    <area>0,5%,100%,95%</area>
+                                </group>
+                            </state>
                             <state name="spinbox" from="textedit" />
                             <state name="combobox" from="textedit" />
-
+                            <state name="standard">
+                                <area>0,0,100%,100%</area>
+                                <group name="buttongroup" from="base_textedit_select_bar_selectedactive_group">
+                                    <area>100%-150,5%,100%,95%</area>
+                                </group>
+                                <textarea name="buttonpress">
+                                    <area>100%-150,0,100%,100%</area>
+                                    <font>basesmallyellow</font>
+                                    <cutdown>yes</cutdown>
+                                    <align>allcenter</align>
+                                    <value>OK</value>
+                                </textarea>
+                            </state>
                         </statetype>
                         <textarea name="value">
                             <font>basesmallyellow</font>
+                            <scroll direction="horizontal" />
                         </textarea>
                     </group>
 
@@ -322,33 +336,105 @@
     </window>
 
     <window name="terminal">
-        <buttonlist name="output" from="basebuttonlist">
-            <area>0,0,100%,90%</area>
-            <arrange>stack</arrange>
-            <align>left</align>
+        <textarea name="heading" from="base_heading">
+            <value>Terminal</value>
+        </textarea>
+
+        <shape name="terminal-backdrop" from="base_backdrop">
+            <area>115,36,1050,488</area>
+        </shape>
+
+        <shape name="terminal-backdrop-line" from="base_backdrop_line">
+            <area>116,37,1048,486</area>
+        </shape>
+
+        <shape name="terminal-top-line" from="base_highlight_line">
+            <area>117,38,1046,2</area>
+        </shape>
+
+        <shape name="terminal-bottom-line" from="base_highlight_line">
+            <area>117,520,1046,2</area>
+        </shape>
+
+        <shape name="terminal-left-line" from="base_highlight_vertical_line">
+            <area>117,40,2,500</area>
+        </shape>
+
+        <shape name="terminal-right-line" from="base_highlight_vertical_line">
+            <area>1161,40,2,500</area>
+        </shape>
+
+        <shape name="terminal-arrows-backdrop" from="base_arrows_backdrop">
+            <area>1112,523,50,12</area>
+        </shape>
+
+        <shape name="terminal-bottom-backdrop" from="base_backdrop">
+            <area>115,534,1050,151</area>
+        </shape>
+
+        <shape name="terminal-bottom-backdrop-line" from="base_backdrop_line">
+            <area>116,535,1048,149</area>
+        </shape>
+
+        <shape name="terminal-bottom-top-line" from="base_highlight_line">
+            <area>117,536,1046,2</area>
+        </shape>
+
+        <shape name="terminal-bottom-bottom-line" from="base_highlight_line">
+            <area>117,681,1046,2</area>
+        </shape>
+
+        <shape name="terminal-bottom-left-line" from="base_highlight_vertical_line">
+            <area>117,538,2,143</area>
+        </shape>
+
+        <shape name="terminal-bottom-right-line" from="base_highlight_vertical_line">
+            <area>1161,538,2,143</area>
+        </shape>
+
+        <shape name="terminal-bottom-seperator-first-line" from="base_line">
+            <area>138,620,1004,2</area>
+        </shape>
+
+        <buttonlist name="output" from="base_list">
+            <area>123,44,1034,488</area>
             <statetype name="buttonitem">
                 <state name="active">
+                    <area>0,0,1034,30</area>
                     <textarea name="buttontext">
-                        <align>left,vcenter</align>
+                        <area>8,0,1018,30</area>
+                        <font>basesmaller</font>
                     </textarea>
                 </state>
                 <state name="selectedactive">
+                    <area>0,0,1034,64</area>
                     <textarea name="buttontext">
-                        <align>left,vcenter</align>
+                        <area>8,0,1018,64</area>
+                        <align>vcenter</align>
+                        <multiline>yes</multiline>
                     </textarea>
                 </state>
                 <state name="selectedinactive">
+                    <area>0,0,1034,64</area>
                     <textarea name="buttontext">
-                        <align>left,vcenter</align>
+                        <area>8,0,1018,64</area>
+                        <align>vcenter</align>
+                        <multiline>yes</multiline>
                     </textarea>
                 </state>
             </statetype>
+            <statetype name="upscrollarrow">
+                <position>997,481</position>
+            </statetype>
+            <statetype name="downscrollarrow">
+                <position>1017,481</position>
+            </statetype>
         </buttonlist>
-        <textedit name="textedit" from="basetextedit">
-            <position>0,90%</position>
+        <textedit name="textedit" from="base_textedit">
+             <area>139,558,1003,42</area>
         </textedit>
-        <button name="enter" from="basebutton">
-            <position>80%,90%</position>
+        <button name="enter" from="base_button">
+            <area>540,631,200,40</area>
             <value>Enter</value>
         </button>
     </window>
-- 
cgit v0.12