From 9a4547f8eb786441be0eee3cee5b0f9605903b67 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 29 Apr 2014 22:53:02 +0000
Subject: python-distribute: replaced by python-setuptools

---
 abs/core/python_modules/python-distribute/PKGBUILD | 54 ----------------------
 .../python_modules/python-distribute/__changelog   |  1 -
 .../distribute-python2_and_3.patch                 | 36 ---------------
 3 files changed, 91 deletions(-)
 delete mode 100644 abs/core/python_modules/python-distribute/PKGBUILD
 delete mode 100644 abs/core/python_modules/python-distribute/__changelog
 delete mode 100644 abs/core/python_modules/python-distribute/distribute-python2_and_3.patch

diff --git a/abs/core/python_modules/python-distribute/PKGBUILD b/abs/core/python_modules/python-distribute/PKGBUILD
deleted file mode 100644
index 5627eb7..0000000
--- a/abs/core/python_modules/python-distribute/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# $Id: PKGBUILD 159385 2012-05-22 22:16:56Z stephane $
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: Sebastien Binet <binet@farnsworth>
-pkgbase=python-distribute
-pkgname=('python2-distribute')
-pkgver=0.6.27
-pkgrel=1
-pkgdesc="Easily build and distribute Python packages"
-arch=('any')
-license=('PSF')
-url="http://pypi.python.org/pypi/distribute"
-makedepends=('python2')
-source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
-        distribute-python2_and_3.patch)
-sha1sums=('cebaaf91938581cb8c4a2f708f2b3e770232d3a5'
-          '9c19c12edac507b0f76696d282b9831c4b653a7e')
-build() {
-   cd "${srcdir}"
-
-   pushd distribute-${pkgver}
-   patch -Np1 -i ../distribute-python2_and_3.patch
-   popd
-
-   cp -a distribute-${pkgver}{,-python2}
-
-   ## Build python 3 module
-   cd distribute-${pkgver}
- #  python setup.py build
-#   python setup.py test
-
-   # Build python 2 module
-   cd ../distribute-${pkgver}-python2
-
-   sed -i -e "s|^#\!.*/usr/bin/python|#!/usr/bin/python2|" setuptools/tests/test_resources.py
-
-   python2 setup.py build
-#   python2 setup.py test
-}
-
-package_python-distribute() {
- #  depends=('python>=3.2')
-
-   cd "${srcdir}/distribute-${pkgver}"
-   python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
-}
-
-package_python2-distribute() {
-   depends=('python2>=2.7')
-   provides=('setuptools')
-   conflicts=('setuptools')
-
-   cd "${srcdir}/distribute-${pkgver}-python2"
-   python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
-}
diff --git a/abs/core/python_modules/python-distribute/__changelog b/abs/core/python_modules/python-distribute/__changelog
deleted file mode 100644
index a995e3a..0000000
--- a/abs/core/python_modules/python-distribute/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-remove python
diff --git a/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch b/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
deleted file mode 100644
index 2c51100..0000000
--- a/abs/core/python_modules/python-distribute/distribute-python2_and_3.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur distribute-0.6.27.ori/distribute.egg-info/entry_points.txt distribute-0.6.27/distribute.egg-info/entry_points.txt
---- distribute-0.6.27.ori/distribute.egg-info/entry_points.txt	2012-05-18 15:46:04.000000000 -0400
-+++ distribute-0.6.27/distribute.egg-info/entry_points.txt	2012-05-22 18:14:17.443383039 -0400
-@@ -11,6 +11,8 @@
- install_egg_info = setuptools.command.install_egg_info:install_egg_info
- alias = setuptools.command.alias:alias
- easy_install = setuptools.command.easy_install:easy_install
-+easy_install-2.7 = setuptools.command.easy_install:main
-+easy_install-3.2 = setuptools.command.easy_install:main  
- install_scripts = setuptools.command.install_scripts:install_scripts
- bdist_wininst = setuptools.command.bdist_wininst:bdist_wininst
- bdist_egg = setuptools.command.bdist_egg:bdist_egg
-diff -Naur distribute-0.6.27.ori/distribute_setup.py distribute-0.6.27/distribute_setup.py
---- distribute-0.6.27.ori/distribute_setup.py	2012-05-18 15:45:03.000000000 -0400
-+++ distribute-0.6.27/distribute_setup.py	2012-05-22 18:14:17.443383039 -0400
-@@ -299,8 +299,7 @@
-         log.warn('Could not find the install location')
-         return
-     pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
--    setuptools_file = 'setuptools-%s-py%s.egg-info' % \
--            (SETUPTOOLS_FAKED_VERSION, pyver)
-+    setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
-     pkg_info = os.path.join(placeholder, setuptools_file)
-     if os.path.exists(pkg_info):
-         log.warn('%s already exists', pkg_info)
-diff -Naur distribute-0.6.27.ori/setup.py distribute-0.6.27/setup.py
---- distribute-0.6.27.ori/setup.py	2012-05-18 15:19:51.000000000 -0400
-+++ distribute-0.6.27/setup.py	2012-05-22 18:14:17.443383039 -0400
-@@ -100,6 +100,7 @@
-             finally:
-                 f.close()
- 
-+console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
- 
- # if we are installing Distribute using "python setup.py install"
- # we need to get setuptools out of the way
-- 
cgit v0.12