From 31841a335c75534c56a8d336a2a8db82e49df7da Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 16 Mar 2015 23:51:01 +0000
Subject: plex-home-theater: stop xscreensaver

---
 abs/extra/plex-home-theater/PKGBUILD                  | 8 ++++----
 abs/extra/plex-home-theater/__changelog               | 3 ++-
 abs/extra/plex-home-theater/plex-home-theater.install | 4 ++++
 abs/extra/plex-home-theater/plex_lib.conf             | 2 +-
 abs/extra/plex-home-theater/plexhometheater.sh        | 8 +++++++-
 5 files changed, 18 insertions(+), 7 deletions(-)

diff --git a/abs/extra/plex-home-theater/PKGBUILD b/abs/extra/plex-home-theater/PKGBUILD
index 2f2c087..cbb8cb1 100755
--- a/abs/extra/plex-home-theater/PKGBUILD
+++ b/abs/extra/plex-home-theater/PKGBUILD
@@ -5,7 +5,7 @@
 pkgname=plex-home-theater
 _pkgver=1.3.6.441-309e72d1
 pkgver=${_pkgver%-*}
-pkgrel=1
+pkgrel=2
 pkgdesc='Plex Home Theater'
 arch=('i686' 'x86_64')
 url='http://www.plexapp.com/'
@@ -60,7 +60,7 @@ package() {
   mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
   mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
   rm -rf "${pkgdir}"/usr/bin/*.so
-  install -m 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/bin/
+  install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
   install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
   install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
 
@@ -74,5 +74,5 @@ md5sums=('370627c3d9e190e7af2cb8cf2a67f488'
          '6704244166497db7fa6b3ddd43a0e53b'
          '066484ad4949f96ddddaa8b1d4d709e1'
          '09e67d694093eb6bd243fb9a4ddf5d70'
-         '8735a4e7857bc85085482c4f8bcb1d01'
-         '8fae1350cc36f40ed65fbf96128a02d0')
+         'c1eedd9f89ee727230833db9ef1e5d29'
+         '4ceae60ed2f9e4304eda4f80d407e799')
diff --git a/abs/extra/plex-home-theater/__changelog b/abs/extra/plex-home-theater/__changelog
index 83f5069..e631336 100644
--- a/abs/extra/plex-home-theater/__changelog
+++ b/abs/extra/plex-home-theater/__changelog
@@ -1,3 +1,4 @@
 PKGBUILD - Remove opt dep pulseaudio
 PKGBUILD - Added plex_lib.conf, this file goes in /etc/gen_lib_xml.d/
-plexhometheater.install - add gen_lib_xml.py to post_install and post_remove
+PKGBUILD - Install plexhometheater.sh to /usr/LH/bin
+plexhometheater.install - add gen_lib_xml.py to post_install and post_remove and post_update
diff --git a/abs/extra/plex-home-theater/plex-home-theater.install b/abs/extra/plex-home-theater/plex-home-theater.install
index 3633bdc..6788abc 100644
--- a/abs/extra/plex-home-theater/plex-home-theater.install
+++ b/abs/extra/plex-home-theater/plex-home-theater.install
@@ -2,6 +2,10 @@ post_install() {
   gen_lib_xml.py
 }
 
+post_upgrade() {
+  gen_lib_xml.py
+}
+
 post_remove() {
   gen_lib_xml.py
 }
diff --git a/abs/extra/plex-home-theater/plex_lib.conf b/abs/extra/plex-home-theater/plex_lib.conf
index 70db20a..1aa78f3 100644
--- a/abs/extra/plex-home-theater/plex_lib.conf
+++ b/abs/extra/plex-home-theater/plex_lib.conf
@@ -3,7 +3,7 @@
        <type>MENU_PLEX</type>
        <text>Launch Plex</text>
        <description>Open Plex Home Theater</description>
-       <action>EXEC /usr/bin/plexhometheater.sh</action>
+       <action>EXEC /usr/LH/bin/plexhometheater.sh</action>
     </button>
 <!--#PLEX--> 
 
diff --git a/abs/extra/plex-home-theater/plexhometheater.sh b/abs/extra/plex-home-theater/plexhometheater.sh
index 53276ff..579bed6 100755
--- a/abs/extra/plex-home-theater/plexhometheater.sh
+++ b/abs/extra/plex-home-theater/plexhometheater.sh
@@ -1,5 +1,11 @@
 #!/bin/sh
+#Stop XScreensaver
+stop_xss.sh &
 
+#Launch plex
 export XBMC_BIN_HOME='/usr/lib/plexhometheater'
 export XBMC_HOME='/usr/share/plexhometheater'
-exec plexhometheater
+plexhometheater
+
+#Start Xscreensaver again
+killall stop_xss.sh
-- 
cgit v0.12