From 77307464f5b324bd8b7ec463482be79c5ebbaff6 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 1 Dec 2012 12:06:35 -0600
Subject: moved  from community to openal, because non-community things depend
 on them:

nvidia-cg-toolkit
openal
opencl-head
wiiuse
---
 abs/extra/community/nvidia-cg-toolkit/PKGBUILD | 37 ------------------
 abs/extra/community/openal/PKGBUILD            | 29 --------------
 abs/extra/community/openal/__changelog         |  2 -
 abs/extra/community/opencl-headers/LICENSE.txt | 20 ----------
 abs/extra/community/opencl-headers/PKGBUILD    | 53 --------------------------
 abs/extra/community/wiiuse/PKGBUILD            | 26 -------------
 abs/extra/community/wiiuse/wiiuse.install      | 17 ---------
 abs/extra/nvidia-cg-toolkit/PKGBUILD           | 37 ++++++++++++++++++
 abs/extra/openal/PKGBUILD                      | 29 ++++++++++++++
 abs/extra/openal/__changelog                   |  2 +
 abs/extra/opencl-headers/LICENSE.txt           | 20 ++++++++++
 abs/extra/opencl-headers/PKGBUILD              | 53 ++++++++++++++++++++++++++
 abs/extra/wiiuse/PKGBUILD                      | 26 +++++++++++++
 abs/extra/wiiuse/wiiuse.install                | 17 +++++++++
 14 files changed, 184 insertions(+), 184 deletions(-)
 delete mode 100644 abs/extra/community/nvidia-cg-toolkit/PKGBUILD
 delete mode 100644 abs/extra/community/openal/PKGBUILD
 delete mode 100644 abs/extra/community/openal/__changelog
 delete mode 100644 abs/extra/community/opencl-headers/LICENSE.txt
 delete mode 100644 abs/extra/community/opencl-headers/PKGBUILD
 delete mode 100644 abs/extra/community/wiiuse/PKGBUILD
 delete mode 100644 abs/extra/community/wiiuse/wiiuse.install
 create mode 100644 abs/extra/nvidia-cg-toolkit/PKGBUILD
 create mode 100644 abs/extra/openal/PKGBUILD
 create mode 100644 abs/extra/openal/__changelog
 create mode 100644 abs/extra/opencl-headers/LICENSE.txt
 create mode 100644 abs/extra/opencl-headers/PKGBUILD
 create mode 100644 abs/extra/wiiuse/PKGBUILD
 create mode 100644 abs/extra/wiiuse/wiiuse.install

diff --git a/abs/extra/community/nvidia-cg-toolkit/PKGBUILD b/abs/extra/community/nvidia-cg-toolkit/PKGBUILD
deleted file mode 100644
index c3f896e..0000000
--- a/abs/extra/community/nvidia-cg-toolkit/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 64721 2012-02-18 02:42:09Z svenstaro $
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Adam Griffiths 
-# Contributor: Nick B <Shirakawasuna at gmail _dot_ com>
-pkgname=nvidia-cg-toolkit 
-pkgver=3.1
-_date="February2012"
-pkgrel=1
-pkgdesc="NVIDIA Cg libraries" 
-arch=('i686' 'x86_64')
-url="http://developer.nvidia.com/object/cg_toolkit.html" 
-license=('custom')
-depends=('glibc' 'mesa') 
-source=(http://developer.download.nvidia.com/cg/Cg_${pkgver}/Cg-${pkgver}_${_date}_${CARCH/i686/x86}.tgz)
-[ "$CARCH" = "i686" ] &&
-md5sums=('af5a3bd72b213b20bf33cf104c83012d')
-[ "$CARCH" = "x86_64" ] && 
-md5sums=('d50dc4e6c68bb93ccfd1a66c139dd6eb')
-
-build() {
-  return 0
-}
-
-package() { 
-  install -Dm755 ${srcdir}/usr/bin/cgc ${pkgdir}/usr/bin/cgc
-  install -dm755 ${pkgdir}/usr/include/Cg
-  install -m644 ${srcdir}/usr/include/Cg/* ${pkgdir}/usr/include/Cg
-  install -dm755 ${pkgdir}/usr/lib
-  [ "$CARCH" = "i686" ] && install -m644 ${srcdir}/usr/lib/* ${pkgdir}/usr/lib
-  [ "$CARCH" = "x86_64" ] && install -m644 ${srcdir}/usr/lib64/* ${pkgdir}/usr/lib
-  install -Dm644 ${srcdir}/usr//local/Cg/docs/license.txt ${pkgdir}/usr/share/licenses/nvidia-cg-toolkit/license.txt
-  cp -r ${srcdir}/usr/local/Cg ${pkgdir}/usr/share/
-  find $pkgdir/usr/share/ -type d -exec chmod -R 755 '{}' ';'
-  find $pkgdir/usr/share/ -type f -exec chmod -R 644 '{}' ';'
-}
-
-# vim: sw=2:ts=2 et:
diff --git a/abs/extra/community/openal/PKGBUILD b/abs/extra/community/openal/PKGBUILD
deleted file mode 100644
index 6d6c669..0000000
--- a/abs/extra/community/openal/PKGBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# $Id: PKGBUILD 149424 2012-02-07 16:51:11Z heftig $
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Allan McRae <allan@archlinux.org>
-# Contributer: Jason Chu <jchu@xentac.net>
-
-pkgname=openal
-pkgver=1.13
-pkgrel=4
-pkgdesc="A cross-platform 3D audio library"
-arch=(i686 x86_64)
-url="http://www.openal.org/"
-license=(LGPL)
-depends=(glibc)
-makedepends=(alsa-lib sdl pkgconfig cmake)
-options=('!libtool')
-source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2)
-md5sums=('58b7d2809790c70681b825644c5f3614')
-
-build() {
-  cd "$srcdir/$pkgname-soft-$pkgver/build"
-  cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release ..
-  make
-}
-
-package() {
-  cd "$srcdir/$pkgname-soft-$pkgver"
-  make -C build DESTDIR="$pkgdir/" install
-  install -Dm644 alsoftrc.sample "$pkgdir/etc/openal/alsoft.conf.sample"
-}
diff --git a/abs/extra/community/openal/__changelog b/abs/extra/community/openal/__changelog
deleted file mode 100644
index 7f47556..0000000
--- a/abs/extra/community/openal/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-4/25/12 - chw - 
-Removed libpulse as a dep.
diff --git a/abs/extra/community/opencl-headers/LICENSE.txt b/abs/extra/community/opencl-headers/LICENSE.txt
deleted file mode 100644
index a89e4f5..0000000
--- a/abs/extra/community/opencl-headers/LICENSE.txt
+++ /dev/null
@@ -1,20 +0,0 @@
- * Copyright (c) 2008-2010 The Khronos Group Inc.
- *
- * Permission is hereby granted, free of charge, to any person obtaining a
- * copy of this software and/or associated documentation files (the
- * "Materials"), to deal in the Materials without restriction, including
- * without limitation the rights to use, copy, modify, merge, publish,
- * distribute, sublicense, and/or sell copies of the Materials, and to
- * permit persons to whom the Materials are furnished to do so, subject to
- * the following conditions:
- *
- * The above copyright notice and this permission notice shall be included
- * in all copies or substantial portions of the Materials.
- *
- * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
- * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
- * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
- * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
- * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
diff --git a/abs/extra/community/opencl-headers/PKGBUILD b/abs/extra/community/opencl-headers/PKGBUILD
deleted file mode 100644
index 0a21ce2..0000000
--- a/abs/extra/community/opencl-headers/PKGBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# $Id: PKGBUILD 60629 2011-12-15 19:18:50Z stephane $
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: Sylvain HENRY <hsyl20@yahoo.fr>
-
-pkgname=opencl-headers
-pkgver=1.1.20110526
-_clbasever=1.1
-pkgrel=1
-epoch=1
-pkgdesc='OpenCL (Open Computing Language) header files'
-arch=('any')
-url='http://www.khronos.org/registry/cl/'
-license=('custom')
-optdepends=('libcl: OpenCL library')
-source=("ftp://ftp.archlinux.org/other/community/${pkgname}/${pkgname}-${pkgver}.src.tar.xz"
-        'LICENSE.txt')
-_headers=("http://www.khronos.org/registry/cl/api/${_clbasever}/cl_ext.h"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl_ext.h"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl.h"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.h"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.hpp"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_platform.h"
-          "http://www.khronos.org/registry/cl/api/${_clbasever}/opencl.h")
-sha1sums=('b9deedbae4f87fa0987ca7b2347f68d608284a02'
-          '98abb35b2eca82d0fc19db6d28fcc7bd20be0655')
-
-# source PKGBUILD && mksource
-mksource() {
-   cd "${srcdir}"
-   _dirname=${pkgname}-${pkgver}
-   mkdir ${_dirname}
-
-   pushd ${_dirname}
-   for _h in ${_headers[@]}; do
-      wget ${_h}
-   done
-   popd
-
-   tar -cJv --exclude=CVS -f ${_dirname}.src.tar.xz ${_dirname}
-   rm -rf ${_dirname}
-}
-
-package() {
-   cd "${srcdir}/${pkgname}-${pkgver}"
-
-   install -dm755 "${pkgdir}"/usr/include/CL
-
-   for h in $(ls -1 *.h *.hpp); do
-      install -m 644 ${h} "${pkgdir}"/usr/include/CL/
-   done
-
-   install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-}
diff --git a/abs/extra/community/wiiuse/PKGBUILD b/abs/extra/community/wiiuse/PKGBUILD
deleted file mode 100644
index d8b1e2b..0000000
--- a/abs/extra/community/wiiuse/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-#Contributor:Andrea Tarocchi <valdar@email.it> 
-pkgname=wiiuse
-pkgver=0.12
-pkgrel=2
-pkgdesc="Wiiuse is a library written in C that connects with several Nintendo Wii remotes." 
-arch=(i686 x86_64)
-url="http://wiiuse.sourceforge.net/" 
-depends=('bluez')
-license="GPL3"
-install=wiiuse.install
-postfix=_src.tar.gz
-source=(http://downloads.sourceforge.net/sourceforge/wiiuse/wiiuse_v$pkgver\_src.tar.gz) 
-
-md5sums=('29b555096f79dbd3fbc9b96b8d443083')
-
-build() {
-  cd $startdir/src/wiiuse_v$pkgver
-  make wiiuse || return 1
-
-#installing
-  mkdir -p $startdir/pkg/usr/lib
-  mkdir -p $startdir/pkg/usr/include
-
-  install -D -m644 ./src/release-`gcc -v 2>&1|grep ^Target:|cut -d' ' -f2`/libwiiuse.so $startdir/pkg/usr/lib
-  install -D -m644 ./src/wiiuse.h $startdir/pkg/usr/include
-}
diff --git a/abs/extra/community/wiiuse/wiiuse.install b/abs/extra/community/wiiuse/wiiuse.install
deleted file mode 100644
index d856696..0000000
--- a/abs/extra/community/wiiuse/wiiuse.install
+++ /dev/null
@@ -1,17 +0,0 @@
-# arg 1:  the new package version
-post_install() {
-cat << EOF
-Note:
-==> for using this lib in your projects include wiiuse.h and link against libwiiuse.so
-EOF
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  post_install $1
-}
-
-op=$1
-shift
-$op $*
\ No newline at end of file
diff --git a/abs/extra/nvidia-cg-toolkit/PKGBUILD b/abs/extra/nvidia-cg-toolkit/PKGBUILD
new file mode 100644
index 0000000..c3f896e
--- /dev/null
+++ b/abs/extra/nvidia-cg-toolkit/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 64721 2012-02-18 02:42:09Z svenstaro $
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Adam Griffiths 
+# Contributor: Nick B <Shirakawasuna at gmail _dot_ com>
+pkgname=nvidia-cg-toolkit 
+pkgver=3.1
+_date="February2012"
+pkgrel=1
+pkgdesc="NVIDIA Cg libraries" 
+arch=('i686' 'x86_64')
+url="http://developer.nvidia.com/object/cg_toolkit.html" 
+license=('custom')
+depends=('glibc' 'mesa') 
+source=(http://developer.download.nvidia.com/cg/Cg_${pkgver}/Cg-${pkgver}_${_date}_${CARCH/i686/x86}.tgz)
+[ "$CARCH" = "i686" ] &&
+md5sums=('af5a3bd72b213b20bf33cf104c83012d')
+[ "$CARCH" = "x86_64" ] && 
+md5sums=('d50dc4e6c68bb93ccfd1a66c139dd6eb')
+
+build() {
+  return 0
+}
+
+package() { 
+  install -Dm755 ${srcdir}/usr/bin/cgc ${pkgdir}/usr/bin/cgc
+  install -dm755 ${pkgdir}/usr/include/Cg
+  install -m644 ${srcdir}/usr/include/Cg/* ${pkgdir}/usr/include/Cg
+  install -dm755 ${pkgdir}/usr/lib
+  [ "$CARCH" = "i686" ] && install -m644 ${srcdir}/usr/lib/* ${pkgdir}/usr/lib
+  [ "$CARCH" = "x86_64" ] && install -m644 ${srcdir}/usr/lib64/* ${pkgdir}/usr/lib
+  install -Dm644 ${srcdir}/usr//local/Cg/docs/license.txt ${pkgdir}/usr/share/licenses/nvidia-cg-toolkit/license.txt
+  cp -r ${srcdir}/usr/local/Cg ${pkgdir}/usr/share/
+  find $pkgdir/usr/share/ -type d -exec chmod -R 755 '{}' ';'
+  find $pkgdir/usr/share/ -type f -exec chmod -R 644 '{}' ';'
+}
+
+# vim: sw=2:ts=2 et:
diff --git a/abs/extra/openal/PKGBUILD b/abs/extra/openal/PKGBUILD
new file mode 100644
index 0000000..6d6c669
--- /dev/null
+++ b/abs/extra/openal/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 149424 2012-02-07 16:51:11Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributer: Jason Chu <jchu@xentac.net>
+
+pkgname=openal
+pkgver=1.13
+pkgrel=4
+pkgdesc="A cross-platform 3D audio library"
+arch=(i686 x86_64)
+url="http://www.openal.org/"
+license=(LGPL)
+depends=(glibc)
+makedepends=(alsa-lib sdl pkgconfig cmake)
+options=('!libtool')
+source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2)
+md5sums=('58b7d2809790c70681b825644c5f3614')
+
+build() {
+  cd "$srcdir/$pkgname-soft-$pkgver/build"
+  cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release ..
+  make
+}
+
+package() {
+  cd "$srcdir/$pkgname-soft-$pkgver"
+  make -C build DESTDIR="$pkgdir/" install
+  install -Dm644 alsoftrc.sample "$pkgdir/etc/openal/alsoft.conf.sample"
+}
diff --git a/abs/extra/openal/__changelog b/abs/extra/openal/__changelog
new file mode 100644
index 0000000..7f47556
--- /dev/null
+++ b/abs/extra/openal/__changelog
@@ -0,0 +1,2 @@
+4/25/12 - chw - 
+Removed libpulse as a dep.
diff --git a/abs/extra/opencl-headers/LICENSE.txt b/abs/extra/opencl-headers/LICENSE.txt
new file mode 100644
index 0000000..a89e4f5
--- /dev/null
+++ b/abs/extra/opencl-headers/LICENSE.txt
@@ -0,0 +1,20 @@
+ * Copyright (c) 2008-2010 The Khronos Group Inc.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and/or associated documentation files (the
+ * "Materials"), to deal in the Materials without restriction, including
+ * without limitation the rights to use, copy, modify, merge, publish,
+ * distribute, sublicense, and/or sell copies of the Materials, and to
+ * permit persons to whom the Materials are furnished to do so, subject to
+ * the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included
+ * in all copies or substantial portions of the Materials.
+ *
+ * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
diff --git a/abs/extra/opencl-headers/PKGBUILD b/abs/extra/opencl-headers/PKGBUILD
new file mode 100644
index 0000000..0a21ce2
--- /dev/null
+++ b/abs/extra/opencl-headers/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 60629 2011-12-15 19:18:50Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sylvain HENRY <hsyl20@yahoo.fr>
+
+pkgname=opencl-headers
+pkgver=1.1.20110526
+_clbasever=1.1
+pkgrel=1
+epoch=1
+pkgdesc='OpenCL (Open Computing Language) header files'
+arch=('any')
+url='http://www.khronos.org/registry/cl/'
+license=('custom')
+optdepends=('libcl: OpenCL library')
+source=("ftp://ftp.archlinux.org/other/community/${pkgname}/${pkgname}-${pkgver}.src.tar.xz"
+        'LICENSE.txt')
+_headers=("http://www.khronos.org/registry/cl/api/${_clbasever}/cl_ext.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl_ext.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.hpp"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_platform.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/opencl.h")
+sha1sums=('b9deedbae4f87fa0987ca7b2347f68d608284a02'
+          '98abb35b2eca82d0fc19db6d28fcc7bd20be0655')
+
+# source PKGBUILD && mksource
+mksource() {
+   cd "${srcdir}"
+   _dirname=${pkgname}-${pkgver}
+   mkdir ${_dirname}
+
+   pushd ${_dirname}
+   for _h in ${_headers[@]}; do
+      wget ${_h}
+   done
+   popd
+
+   tar -cJv --exclude=CVS -f ${_dirname}.src.tar.xz ${_dirname}
+   rm -rf ${_dirname}
+}
+
+package() {
+   cd "${srcdir}/${pkgname}-${pkgver}"
+
+   install -dm755 "${pkgdir}"/usr/include/CL
+
+   for h in $(ls -1 *.h *.hpp); do
+      install -m 644 ${h} "${pkgdir}"/usr/include/CL/
+   done
+
+   install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/abs/extra/wiiuse/PKGBUILD b/abs/extra/wiiuse/PKGBUILD
new file mode 100644
index 0000000..d8b1e2b
--- /dev/null
+++ b/abs/extra/wiiuse/PKGBUILD
@@ -0,0 +1,26 @@
+#Contributor:Andrea Tarocchi <valdar@email.it> 
+pkgname=wiiuse
+pkgver=0.12
+pkgrel=2
+pkgdesc="Wiiuse is a library written in C that connects with several Nintendo Wii remotes." 
+arch=(i686 x86_64)
+url="http://wiiuse.sourceforge.net/" 
+depends=('bluez')
+license="GPL3"
+install=wiiuse.install
+postfix=_src.tar.gz
+source=(http://downloads.sourceforge.net/sourceforge/wiiuse/wiiuse_v$pkgver\_src.tar.gz) 
+
+md5sums=('29b555096f79dbd3fbc9b96b8d443083')
+
+build() {
+  cd $startdir/src/wiiuse_v$pkgver
+  make wiiuse || return 1
+
+#installing
+  mkdir -p $startdir/pkg/usr/lib
+  mkdir -p $startdir/pkg/usr/include
+
+  install -D -m644 ./src/release-`gcc -v 2>&1|grep ^Target:|cut -d' ' -f2`/libwiiuse.so $startdir/pkg/usr/lib
+  install -D -m644 ./src/wiiuse.h $startdir/pkg/usr/include
+}
diff --git a/abs/extra/wiiuse/wiiuse.install b/abs/extra/wiiuse/wiiuse.install
new file mode 100644
index 0000000..d856696
--- /dev/null
+++ b/abs/extra/wiiuse/wiiuse.install
@@ -0,0 +1,17 @@
+# arg 1:  the new package version
+post_install() {
+cat << EOF
+Note:
+==> for using this lib in your projects include wiiuse.h and link against libwiiuse.so
+EOF
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  post_install $1
+}
+
+op=$1
+shift
+$op $*
\ No newline at end of file
-- 
cgit v0.12