From 8a553769984b0153c7f35dc49b5c9c08155efd66 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 16 Apr 2014 20:00:31 +0000
Subject: libimobiledevice: update to 1.1.6

---
 abs/extra/libimobiledevice/HOME-segfault.patch | 14 --------------
 abs/extra/libimobiledevice/PKGBUILD            | 20 ++++++++------------
 2 files changed, 8 insertions(+), 26 deletions(-)
 delete mode 100644 abs/extra/libimobiledevice/HOME-segfault.patch

diff --git a/abs/extra/libimobiledevice/HOME-segfault.patch b/abs/extra/libimobiledevice/HOME-segfault.patch
deleted file mode 100644
index e48e6cb..0000000
--- a/abs/extra/libimobiledevice/HOME-segfault.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-The patch fixes segfault when both $XDG_CONFIG_HOME and $HOME are unset
-Signed-off-by: Maxim Mikityanskiy <maxtram95@gmail.com>
---- src/userpref.c.orig	2012-06-04 17:04:57.387303630 +0300
-+++ src/userpref.c	2012-06-04 17:06:05.741301627 +0300
-@@ -125,6 +125,9 @@
- 	const char *cdir = getenv("XDG_CONFIG_HOME");
- 	if (!cdir) {
- 		cdir = getenv("HOME");
-+		if (!cdir) {
-+			cdir="/root";
-+		}
- 		strcpy(__config_dir, cdir);
- 		strcat(__config_dir, DIR_SEP_S);
- 		strcat(__config_dir, ".config");
diff --git a/abs/extra/libimobiledevice/PKGBUILD b/abs/extra/libimobiledevice/PKGBUILD
index bc921ac..9c4a74a 100644
--- a/abs/extra/libimobiledevice/PKGBUILD
+++ b/abs/extra/libimobiledevice/PKGBUILD
@@ -1,24 +1,22 @@
-# $Id: PKGBUILD 164989 2012-08-08 00:24:19Z tomegun $
+# $Id$
+# Maintainer : Tom Gundersen <teg@jklm.no>
 # Maintainer : Ionut Biru <ibiru@archlinux.org>
 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
 
 pkgname=libimobiledevice
-pkgver=1.1.4
-pkgrel=2
+pkgver=1.1.6
+pkgrel=1
 pkgdesc="Is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux"
 url="http://libimobiledevice.org/"
 arch=('i686' 'x86_64')
 license=('GPL2' 'LGPL2.1')
-depends=('usbmuxd' 'gnutls' 'libgcrypt')
-options=('!libtool')
-source=(http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
-	HOME-segfault.patch)
+depends=('libusbmuxd' 'gnutls' 'libgcrypt')
+makedepends=('python2')
+source=(http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2)
+md5sums=('274783651e9b772774cd9fed2fc52e08')
 
 build() {
   cd "$pkgname-$pkgver"
-
-  patch -p0 < "$srcdir/HOME-segfault.patch"
-
   PYTHON=/usr/bin/python2 ./configure --prefix=/usr
   make
 }
@@ -27,5 +25,3 @@ package() {
   cd "$pkgname-$pkgver"
   make DESTDIR="$pkgdir" install
 }
-md5sums=('3f28cbc6a2e30d34685049c0abde5183'
-         '0de709dbf8e79d0b00cca06f5e61d57c')
-- 
cgit v0.12