From 2705bb4450b02596183fc000996e0b348face96d Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 3 Oct 2014 20:54:40 +0000
Subject: lighttpd: update to 1.4.35

---
 abs/core/lighttpd/PKGBUILD             | 12 ++++++------
 abs/core/lighttpd/__changelog          |  3 +++
 abs/core/lighttpd/openssl-0.9.8m.patch | 11 -----------
 3 files changed, 9 insertions(+), 17 deletions(-)
 delete mode 100644 abs/core/lighttpd/openssl-0.9.8m.patch

diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index a29db8e..a2c3b7d 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,8 +2,8 @@
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=lighttpd
-pkgver=1.4.32
-pkgrel=3
+pkgver=1.4.35
+pkgrel=1
 pkgdesc='A secure, fast, compliant and very flexible web-server'
 license=('custom')
 arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ optdepends=('libxml2: mod_webdav' \
             'libmysqlclient: mod_mysql_vhost' \
             'sqlite3: mod_webdav' \
             'gdbm: mod_trigger_b4_dl')
-backup=(etc/lighttpd/lighttpd.conf etc/logrotate.d/lighttpd etc/lighttpd/auth-inc.conf etc/lighttpd/conf.include etc/lighttpd/html.include)
+backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf' 'etc/lighttpd/conf.include' 'etc/lighttpd/html.include')
 options=('!libtool' 'emptydirs')
 source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
         'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' 'ssl-inc.conf')
@@ -24,7 +24,7 @@ build() {
 	cd ${srcdir}/${pkgname}-${pkgver}
 
 	./configure --prefix=/usr \
-                --sbindir=/usr/bin \
+        --sbindir=/usr/bin \
 		--libexecdir=/usr/lib/lighttpd/modules \
 		--sysconfdir=/etc/lighttpd \
 		--sharedstatedir=/usr/var \
@@ -46,7 +46,7 @@ build() {
 }
 
 package() {
-        cd ${srcdir}/${pkgname}-${pkgver}
+    cd ${srcdir}/${pkgname}-${pkgver}
 	make DESTDIR=${pkgdir} install || return 1
 
 	install -D -m755 ../lighttpd.rc.d ${pkgdir}/etc/rc.d/lighttpd
@@ -77,7 +77,7 @@ package() {
 
 	install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
 }
-md5sums=('8e2d4ae8e918d4de1aeb9842584d170b'
+md5sums=('f7a88130ee9984b421ad8aa80629750a'
          'bd690eee0d9e51857448770a151023b0'
          'e17a29ebcdac82a853389c3df468c980'
          '7945bd60801295010e9e2cac1dba78b7'
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index 84a588c..e87d620 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -34,3 +34,6 @@ add proxy for shellinaboxd
 
 # 8/14/2013
 move proxy to shellinabox pkg
+
+# 10/3/2014
+didn't pull pkgbuild from arch just upgrade to 1.4.35
diff --git a/abs/core/lighttpd/openssl-0.9.8m.patch b/abs/core/lighttpd/openssl-0.9.8m.patch
deleted file mode 100644
index 321e10b..0000000
--- a/abs/core/lighttpd/openssl-0.9.8m.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lighttpd-1.4.26/src/network.c.orig	2010-03-12 01:19:34.000000000 +0000
-+++ src/lighttpd-1.4.26/src/network.c	2010-03-12 01:20:45.000000000 +0000
-@@ -525,7 +525,7 @@
- 
- 		if (!s->ssl_use_sslv2) {
- 			/* disable SSLv2 */
--			if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
-+                        if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
- 				log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
- 						ERR_error_string(ERR_get_error(), NULL));
- 				return -1;
-- 
cgit v0.12