From 02ed2d32465e5f074eae2bca648c2b344c7a3044 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 21 Sep 2012 23:09:21 -0500
Subject: LinHES-system: myth_status.py: fix conflicted recordings

conflicted recordings would always trigger the except because len of an list iterator fails
---
 abs/core/LinHES-system/PKGBUILD       |  4 ++--
 abs/core/LinHES-system/myth_status.py | 15 +++++++--------
 2 files changed, 9 insertions(+), 10 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 686d3bc..eb53138 100644
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=60
+pkgrel=61
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -70,7 +70,7 @@ md5sums=('d1a5963c5a440a608031c6d750232633'
          '542e670e78d117657f93141e9689f54d'
          '41951459ea9d2b0567be521b67e6285a'
          'ba351b92e69bcaf26a9bf80417b09c3c'
-         '4545eb39213d40b5a2bdeda5e066cdc4'
+         '309638acf596ce3c790aa2bf5c7c9880'
          '962a3e9eaba2d1466251b7ab0956705d'
          'd03aedeeeda0f5e9c1eb437411c88477'
          '94ce8f1d5085c0db7b267db8c2e9a3ff'
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index b4f4375..da43679 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -92,14 +92,13 @@ print ""
 print "Conflicted Recordings:"
 print "----------------------"
 a=be.getConflictedRecordings()
-try:
-    if len(a) == 0:
-        print "    No conflicts"
-    else:
-        for i in a:
-            title_chan="%s (%s)" %(i.title, i.channame)
-            print "    %s -  %-50s " %(i.starttime,title_chan)
-except:
+c=0
+for i in a:
+    title_chan="%s (%s)" %(i.title, i.channame)
+    print "    %s -  %-50s " %(i.starttime,title_chan)
+    c=c+1
+
+if c == 0:
     print "    No conflicts"
 
 print ""
-- 
cgit v0.12