From b70d287cc0202d48c25cf63f3067e504b317878b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 May 2018 19:34:41 +0000
Subject: perl-list-utilsby: initial

---
 abs/core/perl_modules/perl-list-utilsby/PKGBUILD | 44 ++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 abs/core/perl_modules/perl-list-utilsby/PKGBUILD

diff --git a/abs/core/perl_modules/perl-list-utilsby/PKGBUILD b/abs/core/perl_modules/perl-list-utilsby/PKGBUILD
new file mode 100644
index 0000000..74c937d
--- /dev/null
+++ b/abs/core/perl_modules/perl-list-utilsby/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname=perl-list-utilsby
+_cpanname="List-UtilsBy"
+pkgver=0.11
+pkgrel=1
+pkgdesc="Higher-order list utility functions"
+arch=('any')
+url="http://search.cpan.org/~pevans/$_cpanname"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.5.0')
+options=('!emptydirs')
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+	cd "$srcdir/$_cpanname-$pkgver"
+	export \
+		PERL_MM_USE_DEFAULT=1 \
+		PERL_AUTOINSTALL=--skipdeps \
+		PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='"$pkgdir"'" \
+		PERL_MB_OPT="--installdirs vendor --destdir '"$pkgdir"'" \
+		MODULEBUILDRC=/dev/null
+}
+source=("http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_cpanname-$pkgver.tar.gz")
+sha256sums=('faddf43b4bc21db8e4c0e89a26e5f23fe626cde3491ec651b6aa338627f5775a')
+
+build() {
+	prepareEnvironment
+	/usr/bin/perl Makefile.PL
+	make
+}
+
+check() {
+	prepareEnvironment
+	make test
+}
+
+package() {
+	prepareEnvironment
+	make install
+
+	# Remove "perllocal.pod" and ".packlist".
+	find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
-- 
cgit v0.12