From 6ce5f7daf1ab8a3ba4b792e50c34f59b8af94304 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 30 Jan 2010 18:54:39 -0600
Subject: linhes-system: update firstboot to use mythsmolt jumppoint, instead
 of telnet interface.

---
 abs/core-testing/LinHES-system/PKGBUILD     |  2 +-
 abs/core-testing/LinHES-system/firstboot.sh | 33 +++++++++++++++++------------
 2 files changed, 21 insertions(+), 14 deletions(-)

diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 156d027..f4718bb 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=70
+pkgrel=71
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/LinHES-system/firstboot.sh b/abs/core-testing/LinHES-system/firstboot.sh
index 47aa0f9..7e2f603 100755
--- a/abs/core-testing/LinHES-system/firstboot.sh
+++ b/abs/core-testing/LinHES-system/firstboot.sh
@@ -1,22 +1,29 @@
 #!/bin/bash
 . ~/.configured
 ATTEMPT=0
+
 function try_smolt {
-	((ATTEMPT=ATTEMPT+1))
-	status=$(echo "jump mythsmolt" | telnet localhost 6546 2>&1)
-	echo $status|grep -q refused
- 	status=$?
-	if [ $status  != 0  ]
-	then
-		fb_status=0
-		echo "FB=NO" > ~/.configured
-	fi
-	if [ $ATTEMPT = 200 ]
-	then
-		fb_status=0
-	fi
+        ((ATTEMPT=ATTEMPT+1))
+        WID=`xdotool search "mythfrontend" | head -1`
+        xdotool windowfocus $WID
+        status=$?
+        if [ $status = 0 ]
+        then
+                sleep 2
+                xdotool key "ctrl+alt+p"
+                xdotool key "ctrl+alt+p"
+                fb_status=0
+                echo "FB=NO" > ~/.configured
+        fi
+
+        if [ $ATTEMPT = 200 ]
+        then
+                fb_status=0
+        fi
+
 }
 
+
 if [ ! -e /tmp/debug ]
 then
 	if [ ! -e /tmp/nomfe ]
-- 
cgit v0.12