From b770aa798aa8372bf914f5f0f4d60ec7e435e9d0 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 6 Aug 2012 21:25:37 -0500
Subject: glib 1.2.10

---
 abs/core/glib/PKGBUILD     | 41 +++++++++++++++++++++++------------------
 abs/core/glib/__changelog  |  1 -
 abs/core/glib/glib.install | 20 ++++++++++++++++++++
 3 files changed, 43 insertions(+), 19 deletions(-)
 delete mode 100644 abs/core/glib/__changelog
 create mode 100644 abs/core/glib/glib.install

diff --git a/abs/core/glib/PKGBUILD b/abs/core/glib/PKGBUILD
index 42f4420..480a521 100644
--- a/abs/core/glib/PKGBUILD
+++ b/abs/core/glib/PKGBUILD
@@ -1,32 +1,37 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 135061 2011-08-10 01:01:44Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
 
 pkgname=glib
 pkgver=1.2.10
-pkgrel=10
+pkgrel=9
 pkgdesc="Common C routines used by Gtk+ and other libs"
 arch=('i686' 'x86_64')
 url="http://www.gtk.org/"
 license=('LGPL')
 depends=('glibc')
-options=('!libtool' '!emptydirs' '!docs' )
-source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
-	gcc340.patch \
-	aclocal-fixes.patch)
-md5sums=('6fe30dad87c77b91b632def29dd69ef9' '877b3330e822a4be69a0f8a8c268cfd7'\
+options=('!libtool')
+install=glib.install
+source=(ftp://ftp.gtk.org/pub/gtk/v1.2/${pkgname}-${pkgver}.tar.gz \
+	gcc340.patch aclocal-fixes.patch)
+md5sums=('6fe30dad87c77b91b632def29dd69ef9'
+         '877b3330e822a4be69a0f8a8c268cfd7'
          'e52c4b88427b9785bb8049dbdc9ff6fb')
-sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'\
-          'a2cc224a66aeffdcac16ebd9e8af18143cf54918'\
+sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
+          'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
           'ae4438cf56c0c9264ee36f6973fb445f9a820be0')
 
 build() {
-  cd $startdir/src/$pkgname-$pkgver
-  patch -Np1 -i ../gcc340.patch || return 1
-  patch -Np0 -i ../aclocal-fixes.patch || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  patch -Np1 -i ../gcc340.patch
+  patch -Np0 -i ../aclocal-fixes.patch
 
-  #Arch64 fixes --build/host
-  ./configure --prefix=/usr #--host=i686-pc-linux-gnu
-  make || return 1
-  make DESTDIR=$startdir/pkg install
+  [ "$CARCH" = 'x86_64' ] && CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+  ./configure --prefix=/usr --mandir=/usr/share/man \
+    --infodir=/usr/share/info $CONFIGFLAG
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
 }
diff --git a/abs/core/glib/__changelog b/abs/core/glib/__changelog
deleted file mode 100644
index f2439db..0000000
--- a/abs/core/glib/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-added !emptydir !docs to options
diff --git a/abs/core/glib/glib.install b/abs/core/glib/glib.install
new file mode 100644
index 0000000..c0046fe
--- /dev/null
+++ b/abs/core/glib/glib.install
@@ -0,0 +1,20 @@
+infodir=usr/share/info
+filelist=(glib.info.gz)
+
+post_install() {
+  [ -x usr/bin/install-info ] || return 0
+  for file in ${filelist[@]}; do
+    install-info $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  [ -x usr/bin/install-info ] || return 0
+  for file in ${filelist[@]}; do
+    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
-- 
cgit v0.12