From 5a04c12e361286dfb06158729ef40f47b71e1b53 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Sat, 6 Nov 2010 03:44:26 +0000
Subject: libcrystalhd-git: initial include

---
 abs/extra/libcrystalhd-git/PKGBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 abs/extra/libcrystalhd-git/PKGBUILD

diff --git a/abs/extra/libcrystalhd-git/PKGBUILD b/abs/extra/libcrystalhd-git/PKGBUILD
new file mode 100644
index 0000000..27d8fff
--- /dev/null
+++ b/abs/extra/libcrystalhd-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Petteri Tolonen <petteri.tolonen@gmail.com>
+pkgname=libcrystalhd-git
+pkgver=`date +%Y%m%d`
+pkgrel=1
+pkgdesc="Broadcom Crystal HD library from git.wilsonet.com"
+arch=('i686' 'x86_64')
+url="http://git.wilsonet.com/crystalhd.git/"
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('git' 'make')
+conflicts=('libcrystalhd')
+
+_gitroot='git://git.wilsonet.com/crystalhd.git'
+_gitname='crystalhd'
+
+build() {
+
+    cd $startdir/src
+
+    msg "Connecting to git.wilsonet.com GIT server...."
+
+    if [ -d $startdir/src/$_gitname ] ; then
+        cd $_gitname && git pull origin
+        msg "The local files are updated."
+    else
+        git clone $_gitroot
+        cd $_gitname
+    fi
+
+    cd linux_lib/libcrystalhd
+
+    make || return 1
+    make install DESTDIR=$pkgdir || return 1
+
+}
-- 
cgit v0.12