From 4bc7b0f67aa62aa9455b940cb7ec14661be98193 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 4 Aug 2011 23:36:19 +0000
Subject: smartmontools: update to 5.41

---
 abs/extra/smartmontools/PKGBUILD              | 13 +++++--------
 abs/extra/smartmontools/__changelog           |  2 ++
 abs/extra/smartmontools/smartmontools.install | 24 ++++++++++++++++++++++++
 3 files changed, 31 insertions(+), 8 deletions(-)
 create mode 100644 abs/extra/smartmontools/__changelog
 create mode 100644 abs/extra/smartmontools/smartmontools.install

diff --git a/abs/extra/smartmontools/PKGBUILD b/abs/extra/smartmontools/PKGBUILD
index ecb4fd5..fe12bd5 100644
--- a/abs/extra/smartmontools/PKGBUILD
+++ b/abs/extra/smartmontools/PKGBUILD
@@ -4,7 +4,7 @@
 # Contributor: Jani Talikka <jani.talikka@gmail.com>
 
 pkgname=smartmontools
-pkgver=5.40
+pkgver=5.41
 pkgrel=1
 pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
 url="http://smartmontools.sourceforge.net"
@@ -12,20 +12,17 @@ license=('GPL')
 arch=('i686' 'x86_64')
 depends=('gcc-libs')
 backup=('etc/smartd.conf')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz \
-        smartd)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+install=smartmontools.install
 
 build()
 {
   cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/src/linux-2.6.37-LinHES
+  ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/src/linux-2.6.39-LinHES
   make || return 1
 }
 package() {
   cd ${srcdir}/${pkgname}-${pkgver}
   make DESTDIR=${pkgdir} install
-  rm -rf ${pkgdir}/etc/rc.d
-  install -D -m 755 ../smartd ${pkgdir}/etc/rc.d/smartd
 }
-md5sums=('0f0be0239914ad87830a4fff594bda5b'
-         '850f98b6792b7642ff193a49a2f1139d')
+md5sums=('4577886bea79d4ff12bd9a7d323ce692')
diff --git a/abs/extra/smartmontools/__changelog b/abs/extra/smartmontools/__changelog
new file mode 100644
index 0000000..8e0d8a6
--- /dev/null
+++ b/abs/extra/smartmontools/__changelog
@@ -0,0 +1,2 @@
+* remove the rc script. runit script in runit-scripts pkg
+* added smartmontools.install
diff --git a/abs/extra/smartmontools/smartmontools.install b/abs/extra/smartmontools/smartmontools.install
new file mode 100644
index 0000000..f2baacd
--- /dev/null
+++ b/abs/extra/smartmontools/smartmontools.install
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+post_install() {
+
+  echo ""
+  echo "==> Configure your /etc/smart.conf config file and then"
+  echo "==> $ sudo add_service.sh smartd"
+  echo "==> to start the monitoring service."
+
+}
+
+post_upgrade() {
+
+  post_install
+
+}
+
+pre_remove() {
+
+  if [ -L /service/smartd ]; then
+    remove_service.sh smartd
+  fi
+
+}
-- 
cgit v0.12


From 8ca639078819fb0229652e9feb47c9550fe8747f Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 4 Aug 2011 23:36:41 +0000
Subject: runit-scripts: fix smartd run file and remove unnecessary finish
 file.

---
 abs/core/runit-scripts/PKGBUILD                         |  2 +-
 abs/core/runit-scripts/runitscripts/services/smartd/run | 11 +++--------
 2 files changed, 4 insertions(+), 9 deletions(-)

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index e186f99..828e54c 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=2.1.1
-pkgrel=24
+pkgrel=25
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/smartd/run b/abs/core/runit-scripts/runitscripts/services/smartd/run
index 15ed769..b8eafb6 100755
--- a/abs/core/runit-scripts/runitscripts/services/smartd/run
+++ b/abs/core/runit-scripts/runitscripts/services/smartd/run
@@ -3,11 +3,6 @@
  . /etc/rc.conf
  . /etc/rc.d/functions
 
-     stat_runit "Starting smartd"
-     /usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null
-     if [ $? -ne 0 ]; then
-       stat_fail
-     else
-       add_daemon smartd
-       stat_done
-     fi
+stat_runit "Starting smartd"
+
+  exec /usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null
-- 
cgit v0.12