From 8ebf19d99904e330468627415b25bd16cb87da16 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 15 Aug 2012 10:40:00 -0500
Subject: automoc4: 0.9.88

---
 abs/extra/automoc4/PKGBUILD    | 42 ++++++++++++++++++++++--------------------
 abs/extra/automoc4/license.txt | 31 +++++++++++++++++++++++++++++++
 2 files changed, 53 insertions(+), 20 deletions(-)
 create mode 100644 abs/extra/automoc4/license.txt

diff --git a/abs/extra/automoc4/PKGBUILD b/abs/extra/automoc4/PKGBUILD
index ece3a62..4e13090 100644
--- a/abs/extra/automoc4/PKGBUILD
+++ b/abs/extra/automoc4/PKGBUILD
@@ -1,31 +1,33 @@
-# $ Id: $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# $Id: PKGBUILD 149006 2012-02-05 13:49:43Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=automoc4
 pkgver=0.9.88
-pkgrel=1
-pkgdesc="KDE automoc4"
+pkgrel=3
+pkgdesc="Automatic moc for Qt4"
 arch=('i686' 'x86_64')
-url='http://www.kde.org'
+url='http://www.kde.org/'
 license=('custom')
-depends=('qt>=4.4')
+depends=('qt')
 makedepends=('pkgconfig' 'cmake')
-source=("ftp://ftp.archlinux.org/other/automoc4/automoc4-${pkgver}.tar.bz2")
-md5sums=('adffb45ea2b550f284b1e3455f525176')
+source=("http://download.kde.org/stable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+        'license.txt')
+md5sums=('91bf517cb940109180ecd07bc90c69ec'
+         '9014edbb7e2f02fe90b2db8707487bce')
 
 build() {
-        cd ${srcdir}
-        mkdir build
-        cd build
-        cmake ../${pkgname}-${pkgver} \
-                -DCMAKE_BUILD_TYPE=Release \
-                -DCMAKE_INSTALL_PREFIX=/usr
-        make || return 1
+	cd "${srcdir}"
+	mkdir build
+	cd build
+	cmake ../${pkgname}-${pkgver} \
+		-DCMAKE_BUILD_TYPE=Release \
+		-DCMAKE_INSTALL_PREFIX=/usr
+	make
 }
-package() {
-        cd ${srcdir}/build
-        make DESTDIR=$pkgdir install || return 1
 
-        grep -A 21 '^    Copyright' ${srcdir}/${pkgname}-${pkgver}/kde4automoc.cpp > license.txt
-        install -D license.txt ${pkgdir}/usr/share/licenses/automoc4/license.txt
+package() {
+    cd "${srcdir}/build"
+	make DESTDIR="${pkgdir}" install
+	install -Dm644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
 }
diff --git a/abs/extra/automoc4/license.txt b/abs/extra/automoc4/license.txt
new file mode 100644
index 0000000..f9db603
--- /dev/null
+++ b/abs/extra/automoc4/license.txt
@@ -0,0 +1,31 @@
+Upstream Authors: 
+
+	Mathias Kretz <kretz@kde.org>
+	Alexander Neundorff <neundorff@kde.org>
+
+Copyright: 
+
+	Copyright (c) 2007 Mathias Kretz <kretz@kde.org>
+
+License:
+
+    Redistribution and use in source and binary forms, with or without
+    modification, are permitted provided that the following conditions
+    are met:
+
+    1. Redistributions of source code must retain the above copyright
+       notice, this list of conditions and the following disclaimer.
+    2. Redistributions in binary form must reproduce the above copyright
+       notice, this list of conditions and the following disclaimer in the
+       documentation and/or other materials provided with the distribution.
+
+    THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+    IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+    OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+    IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+    INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+    NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+    DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+    THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+    (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+    THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-- 
cgit v0.12