From 68eb9a240bd2208928a7267a41cfc1fa92a43b33 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 28 Feb 2018 16:04:34 +0000
Subject: iproute2: update to 4.15.0

---
 abs/core/iproute2/PKGBUILD    | 73 +++++++++++++++----------------------------
 abs/core/iproute2/__changelog |  1 -
 2 files changed, 26 insertions(+), 48 deletions(-)
 delete mode 100644 abs/core/iproute2/__changelog

diff --git a/abs/core/iproute2/PKGBUILD b/abs/core/iproute2/PKGBUILD
index 566c75b..e26cafa 100644
--- a/abs/core/iproute2/PKGBUILD
+++ b/abs/core/iproute2/PKGBUILD
@@ -3,27 +3,38 @@
 # Maintainer: Ronald van Haren <ronald.archlinux.org>
 # Contributor: Judd Vinet <jvinet@zeroflux.org>
 
-pkgbase=iproute2
-#pkgname=(iproute2 iproute2-doc)
-pkgname=(iproute2)
-pkgver=4.9.0
+pkgname=iproute2
+pkgver=4.15.0
 pkgrel=1
 pkgdesc='IP Routing Utilities'
-arch=('i686' 'x86_64')
+arch=('x86_64')
 license=('GPL2')
-url='http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2'
-#makedepends=('iptables' 'linux-atm' 'linuxdoc-tools' 'texlive-bin' 'texlive-core' 'texlive-latexextra')
-makedepends=('iptables' 'linux-atm')
-options=('staticlibs' '!makeflags')
+url='https://git.kernel.org/pub/scm/network/iproute2/iproute2.git'
+depends=('glibc' 'iptables' 'libelf')
+optdepends=('linux-atm: ATM support')
+groups=('base')
+provides=('iproute')
+# Upstream commit b2fd7a0e6efa7b85a041b5cb9ea6fc1a6a798fd3 removed old documentation.
+# Add conflict and replace to get rid of the package. TODO: Remove anytime soon.
+conflicts=('iproute' 'iproute2-doc')
+replaces=('iproute' 'iproute2-doc')
+backup=('etc/iproute2/ematch_map'
+        'etc/iproute2/rt_dsfield'
+        'etc/iproute2/rt_protos'
+        'etc/iproute2/rt_realms'
+        'etc/iproute2/rt_scopes'
+        'etc/iproute2/rt_tables')
+makedepends=('linux-atm')
+options=('staticlibs')
 validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
-source=("https://www.kernel.org/pub/linux/utils/net/${pkgbase}/${pkgbase}-${pkgver}.tar."{xz,sign}
+source=("https://www.kernel.org/pub/linux/utils/net/${pkgname}/${pkgname}-${pkgver}.tar."{xz,sign}
         '0001-make-iproute2-fhs-compliant.patch')
-sha256sums=('c0f30f043f7767cc1b2cd2197b08d4e9b2392c95823fabe30bbce308c30116c4'
+sha256sums=('48d4616a99d7b609b7b795c0ae8ec57099fb0271ed89253e8772c02327798355'
             'SKIP'
             'f60fefe4c17d3b768824bb50ae6416292bcebba06d73452e23f4147b46b827d3')
 
 prepare() {
-  cd "${srcdir}/${pkgbase}-${pkgver}"
+  cd "${srcdir}/${pkgname}-${pkgver}"
 
   # set correct fhs structure
   patch -Np1 -i "${srcdir}/0001-make-iproute2-fhs-compliant.patch"
@@ -34,51 +45,19 @@ prepare() {
 }
 
 build() {
-  cd "${srcdir}/${pkgbase}-${pkgver}"
+  cd "${srcdir}/${pkgname}-${pkgver}"
 
   ./configure
   make
-
-#  cd "${srcdir}/${pkgbase}-${pkgver}/doc/"
-
-#  make html pdf
 }
 
-package_iproute2() {
-  depends=('glibc' 'iptables')
-  optdepends=('linux-atm: ATM support')
-  groups=('base')
-  provides=('iproute')
-  conflicts=('iproute')
-  replaces=('iproute')
-  backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
-    'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
-
-  cd "${srcdir}/${pkgbase}-${pkgver}"
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
 
   make DESTDIR="${pkgdir}" SBINDIR="/usr/bin" install
 
-  # remove documentation
-  rm -rf "${pkgdir}/usr/share/doc/"
-
   # libnetlink isn't installed, install it FS#19385
   install -Dm0644 include/libnetlink.h "${pkgdir}/usr/include/libnetlink.h"
   install -Dm0644 lib/libnetlink.a "${pkgdir}/usr/lib/libnetlink.a"
 }
 
-package_iproute2-doc() {
-  pkgdesc='IP Routing Utilities documentation'
-
-  cd "${srcdir}/${pkgbase}-${pkgver}"
-
-  make DESTDIR="${pkgdir}" install
-
-  # documentation is included in default install target... So clean up here.
-  find "${pkgdir}/" ! -type d ! -regex '.*examples.*' -delete
-  find "${pkgdir}/" -empty -delete
-  find "${pkgdir}/" -name '*.sgml' -delete
-  find "${pkgdir}/" -name '*.tex' -delete
-
-  install -m0644 doc/*.html doc/*.pdf "${pkgdir}/usr/share/doc/iproute2/"
-}
-
diff --git a/abs/core/iproute2/__changelog b/abs/core/iproute2/__changelog
deleted file mode 100644
index fd3fc81..0000000
--- a/abs/core/iproute2/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: disable iproute2-doc and tex doc deps
-- 
cgit v0.12