From 7e68652b329beefeba09edf35c672877a6453f70 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 3 Dec 2014 21:40:38 +0000
Subject: zip: update to 3.0-4

---
 abs/extra/zip/PKGBUILD | 34 +++++++++++++++++++---------------
 1 file changed, 19 insertions(+), 15 deletions(-)

diff --git a/abs/extra/zip/PKGBUILD b/abs/extra/zip/PKGBUILD
index dca1103..2182077 100644
--- a/abs/extra/zip/PKGBUILD
+++ b/abs/extra/zip/PKGBUILD
@@ -1,28 +1,32 @@
-# $Id: PKGBUILD 149604 2012-02-08 19:38:19Z pierre $
-# Maintainer:
+# $Id$
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
 # Contributor: dorphell <dorphell@archlinux.org>
 
 pkgname=zip
 pkgver=3.0
-_pkgver=30
-pkgrel=3
-pkgdesc="Creates PKZIP-compatible .zip files"
+_pkgver=${pkgver/./}
+pkgrel=4
+pkgdesc='Compressor/archiver for creating and modifying zipfiles'
+url='http://www.info-zip.org/Zip.html'
 arch=('i686' 'x86_64')
-url="http://www.info-zip.org/Zip.html"
-license=('BSD')
+license=('custom')
 depends=('bzip2')
+source=("http://downloads.sourceforge.net/infozip/${pkgname}${_pkgver}.tar.gz")
+sha1sums=('c9f4099ecf2772b53c2dd4a8e508064ce015d182')
+
 options=('!makeflags')
-source=("ftp://ftp.info-zip.org/pub/infozip/src/${pkgname}${_pkgver}.zip")
-md5sums=('e88492c8abd68fa9cfba72bc08757dba')
 
 build() {
-   cd "${srcdir}/${pkgname}${_pkgver}"
-   make -f unix/Makefile LOCAL_ZIP="$CFLAGS" prefix=/usr generic_gcc
+	cd "${srcdir}/${pkgname}${_pkgver}"
+	make -f unix/Makefile prefix=/usr \
+		LOCAL_ZIP="$CFLAGS $CPPFLAGS $LDFLAGS" \
+		generic_gcc
 }
 
 package() {
-   cd "${srcdir}/${pkgname}${_pkgver}"
-   make -f unix/Makefile INSTALL=/bin/install prefix=${pkgdir}/usr \
-     MANDIR=${pkgdir}/usr/share/man/man1 install
-   install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+	cd "${srcdir}/${pkgname}${_pkgver}"
+	make -f unix/Makefile prefix="${pkgdir}"/usr \
+		MANDIR=${pkgdir}/usr/share/man/man1 \
+		install
+	install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
 }
-- 
cgit v0.12