From 9f77bf47533c65bbd18e5b338a963a607853dc93 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 1 May 2015 17:32:20 +0000
Subject: mythinstall: use audio card name instead of number in case devices
 move around on boot

---
 abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp | 5 +++--
 abs/core/mythinstall/PKGBUILD                                        | 2 +-
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 05acc5e..41b67c6 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -3109,7 +3109,8 @@ void  SoundALSAsettings::fillALSAselection()
                 }
                 //card 0: I82801DBICH4:q [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
                 alsadescription=line.section( ", " , 0 ,0 );
-                alsadescription=alsadescription.section(":",1,1);
+                alsadescription=alsadescription.section(": ",1,1);
+                alsadescription=alsadescription.section(" ",0,0);
 
                 alsadescription2=line.section( ", " , 1 ,1 );
                 //alsadescription2=alsadescription.section(":",0,0);
@@ -3122,7 +3123,7 @@ void  SoundALSAsettings::fillALSAselection()
                 temphwdevice=temphwdevice.section(" ",-1,-1 );
                 hwdevice.append(",");
                 hwdevice.append(temphwdevice);
-                simpleitem=alsadescription2 + "(plughw:" + hwdevice + ")";
+                simpleitem=alsadescription + " " + alsadescription2 + "(plughw:" + alsadescription + "," + temphwdevice + ")";
                 if (line.contains("IEC958") || line.contains("Digital") || line.contains("PCM") || line.contains("HDMI"))
                     HostSoundALSADigital->addSelection(simpleitem);
                 else
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 901f6ad..e74402e 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.3
-pkgrel=6
+pkgrel=7
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
-- 
cgit v0.12