From ef8e4d21086ac4c1737231dcd8373e10e8bf446e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 27 Sep 2020 21:47:27 +0000
Subject: cython: update to 0.29.21

---
 abs/core/python_modules/cython/PKGBUILD | 20 ++++++++++++--------
 1 file changed, 12 insertions(+), 8 deletions(-)

diff --git a/abs/core/python_modules/cython/PKGBUILD b/abs/core/python_modules/cython/PKGBUILD
index 6826749..6383f1c 100644
--- a/abs/core/python_modules/cython/PKGBUILD
+++ b/abs/core/python_modules/cython/PKGBUILD
@@ -1,23 +1,27 @@
-# $Id$
 # Maintainer: Antonio Rojas <arojas@archlinux.org>
 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
 # Contributor: Igor Scabini <furester @ gmail.com>
 
 pkgname=(cython cython2)
 pkgbase=cython
-pkgver=0.27.3
-pkgrel=3
+pkgver=0.29.21
+pkgrel=1
 pkgdesc="C-Extensions for Python"
 arch=(x86_64)
-url="http://cython.org"
+url="https://cython.org"
 license=(APACHE)
 makedepends=(python-setuptools python2-setuptools)
-source=($pkgbase-$pkgver.tar.gz::"https://github.com/cython/cython/archive/$pkgver.tar.gz")
-sha256sums=('648feb8a257574a3e4ef854475e7d767732ef26e870d2f9fcc1ca5b244b3ac89')
+source=($pkgbase-$pkgver.tar.gz::"https://github.com/cython/cython/archive/$pkgver.tar.gz"
+        cython-hash-int-conversion.patch::"https://github.com/cython/cython/commit/28251032.patch")
+sha256sums=('e2e38e1f0572ca54d6085df3dec8b607d20e81515fb80215aed19c81e8fe2079'
+            '28b2b065a9853e86d0bc09287e8a21f50ebc1f3cfee3b2ab03b6b917cb9e81d8')
 
 prepare() {
   cp -r cython-$pkgver cython2-$pkgver
   find cython2-$pkgver -name '*.py' | xargs sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -e 's|/usr/bin/python|/usr/bin/python2|' -i
+
+  cd cython-$pkgver
+  patch -p1 -i ../cython-hash-int-conversion.patch # Allow non-int conversion to Py_hash_t, needed by sagemath
 }
 
 build() {
@@ -29,7 +33,7 @@ build() {
 }
 
 package_cython() {
-  depends=(python python-setuptools)
+  depends=(python-setuptools)
 
   cd cython-$pkgver
   python setup.py install --root="$pkgdir" --skip-build
@@ -41,7 +45,7 @@ package_cython() {
 }
 
 package_cython2() {
-  depends=(python2 python2-setuptools)
+  depends=(python2-setuptools)
 
   cd cython2-$pkgver
   python2 setup.py install --root="$pkgdir" --skip-build
-- 
cgit v0.12